summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-16 09:16:58 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-16 09:21:58 +0100
commitab0ef2741c191250c6c48b7ce19f21573cb39c9c (patch)
tree5bbc2ac67db3c7273ebe449ae5f08a82b958e36a /app-arch/lz4
parentdev-python/zope-event: Remove old (diff)
downloadgentoo-ab0ef2741c191250c6c48b7ce19f21573cb39c9c.tar.gz
gentoo-ab0ef2741c191250c6c48b7ce19f21573cb39c9c.tar.bz2
gentoo-ab0ef2741c191250c6c48b7ce19f21573cb39c9c.zip
app-arch/lz4: Bump to 1.9.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-arch/lz4')
-rw-r--r--app-arch/lz4/Manifest1
-rw-r--r--app-arch/lz4/lz4-1.9.3.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/app-arch/lz4/Manifest b/app-arch/lz4/Manifest
index cfa76df25ec4..10d1933d483b 100644
--- a/app-arch/lz4/Manifest
+++ b/app-arch/lz4/Manifest
@@ -1 +1,2 @@
DIST lz4-1.9.2.tar.gz 305796 BLAKE2B 0021487bee8657bc825fdd2b98a6dc8a6d10be3240fe0bebf6563e9c855a15bf5440a02d5cd6ee1f1e8502743348bcec1e866d3287b07e623887e9eb9da35eee SHA512 ae714c61ec8e33ed91359b63f2896cfa102d66b730dce112b74696ec5850e59d88bd5527173e01e354a70fbe8f036557a47c767ee0766bc5f9c257978116c3c1
+DIST lz4-1.9.3.tar.gz 320958 BLAKE2B 9a194bd18ff52f780aa03a8a53fe7fab7b58117d768f4ba8e5005830c935d16328d0f7cc54f9413b58faf245017c0ac85fb4e709a9db150cb150a0a2a3c21645 SHA512 c246b0bda881ee9399fa1be490fa39f43b291bb1d9db72dba8a85db1a50aad416a97e9b300eee3d2a4203c2bd88bda2762e81bc229c3aa409ad217eb306a454c
diff --git a/app-arch/lz4/lz4-1.9.3.ebuild b/app-arch/lz4/lz4-1.9.3.ebuild
new file mode 100644
index 000000000000..dbf92b78579c
--- /dev/null
+++ b/app-arch/lz4/lz4-1.9.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS=cmake
+inherit cmake-multilib
+
+DESCRIPTION="Extremely Fast Compression algorithm"
+HOMEPAGE="https://github.com/lz4/lz4"
+SRC_URI="https://github.com/lz4/lz4/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2 GPL-2"
+# https://abi-laboratory.pro/tracker/timeline/lz4/
+SLOT="0/r132"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+CMAKE_USE_DIR=${S}/build/cmake
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_STATIC_LIBS=$(usex static-libs)
+ )
+
+ cmake_src_configure
+}