summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-arch/lzlib
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-arch/lzlib')
-rw-r--r--app-arch/lzlib/Manifest2
-rw-r--r--app-arch/lzlib/lzlib-1.6.ebuild38
-rw-r--r--app-arch/lzlib/lzlib-1.7.ebuild38
-rw-r--r--app-arch/lzlib/metadata.xml8
4 files changed, 86 insertions, 0 deletions
diff --git a/app-arch/lzlib/Manifest b/app-arch/lzlib/Manifest
new file mode 100644
index 000000000000..25d7d4cd47a9
--- /dev/null
+++ b/app-arch/lzlib/Manifest
@@ -0,0 +1,2 @@
+DIST lzlib-1.6.tar.gz 91734 SHA256 c187ef5ffa9ffb01abaec667dda4d8c8b378291c68ad094c63bd75ee049e4780 SHA512 b4ebf3ad0c634593b7162479d43497b2daa1c47b979695988ed278e828fc6f6eac721b9eae238f50b7ee543f8c163fc4b51c6dcd575c37aa59aff8ca3cf903a2 WHIRLPOOL da2b6e1755c7697e3f8c7dbd82c4fc51b3503234498bfa9b860a144e8a53345e40fcd0062ad152742b247c3b03ccfb9d66046dc2372503333f30a2692efaa18d
+DIST lzlib-1.7.tar.gz 94257 SHA256 88c919dbb16a8b5409fc8ccec31d3c604551d73e84cec8c964fd639452536214 SHA512 de91417f301e7c41da39b57a5bbce112d24170008f24c87ddbe7977ad912a982e62aac7ed5c2964abbf1905d6ebb2faf64b29cfba0a2bea40d35aed5eb437728 WHIRLPOOL 7ee577edf78a3f79319469eafbecd418917c6b2da29be4b000438481b3e4692dca13902516f0486d260832813404e6920c1e8234c6c65ba7fad8eb88093343c8
diff --git a/app-arch/lzlib/lzlib-1.6.ebuild b/app-arch/lzlib/lzlib-1.6.ebuild
new file mode 100644
index 000000000000..517faae1e18f
--- /dev/null
+++ b/app-arch/lzlib/lzlib-1.6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Library for lzip compression"
+HOMEPAGE="http://www.nongnu.org/lzip/lzlib.html"
+SRC_URI="http://download.savannah.gnu.org/releases-noredirect/lzip/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+src_configure() {
+ # not autotools-based
+ ./configure \
+ --enable-shared \
+ --prefix="${EPREFIX}"/usr \
+ --libdir="${EPREFIX}"/usr/$(get_libdir) \
+ CC="$(tc-getCC)" \
+ CPPFLAGS="${CPPFLAGS}" \
+ CFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}" || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" LDCONFIG=: install
+ einstalldocs
+
+ # this sucking thing does not support disabling static libs
+ if ! use static-libs; then
+ rm "${ED%/}"/usr/$(get_libdir)/*.a || die
+ fi
+}
diff --git a/app-arch/lzlib/lzlib-1.7.ebuild b/app-arch/lzlib/lzlib-1.7.ebuild
new file mode 100644
index 000000000000..517faae1e18f
--- /dev/null
+++ b/app-arch/lzlib/lzlib-1.7.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Library for lzip compression"
+HOMEPAGE="http://www.nongnu.org/lzip/lzlib.html"
+SRC_URI="http://download.savannah.gnu.org/releases-noredirect/lzip/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+src_configure() {
+ # not autotools-based
+ ./configure \
+ --enable-shared \
+ --prefix="${EPREFIX}"/usr \
+ --libdir="${EPREFIX}"/usr/$(get_libdir) \
+ CC="$(tc-getCC)" \
+ CPPFLAGS="${CPPFLAGS}" \
+ CFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}" || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" LDCONFIG=: install
+ einstalldocs
+
+ # this sucking thing does not support disabling static libs
+ if ! use static-libs; then
+ rm "${ED%/}"/usr/$(get_libdir)/*.a || die
+ fi
+}
diff --git a/app-arch/lzlib/metadata.xml b/app-arch/lzlib/metadata.xml
new file mode 100644
index 000000000000..5cb9324943ab
--- /dev/null
+++ b/app-arch/lzlib/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+</pkgmetadata>