summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-20 11:07:57 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-20 11:39:53 +0100
commita850679ed848600abd4c31f4657e0c0f93f792c7 (patch)
treec9e291254a68b0710bd15f43c3ec8c414f637ad7 /app-arch/stormlib
parentapp-shells/bash: Bump to version 5.1_p4 (diff)
downloadgentoo-a850679ed848600abd4c31f4657e0c0f93f792c7.tar.gz
gentoo-a850679ed848600abd4c31f4657e0c0f93f792c7.tar.bz2
gentoo-a850679ed848600abd4c31f4657e0c0f93f792c7.zip
app-arch/stormlib: Add as a dep for games-strategy/wargus
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-arch/stormlib')
-rw-r--r--app-arch/stormlib/Manifest1
-rw-r--r--app-arch/stormlib/files/stormlib-9.23-gnuinstalldirs.patch55
-rw-r--r--app-arch/stormlib/metadata.xml8
-rw-r--r--app-arch/stormlib/stormlib-9.23.ebuild39
4 files changed, 103 insertions, 0 deletions
diff --git a/app-arch/stormlib/Manifest b/app-arch/stormlib/Manifest
new file mode 100644
index 000000000000..99bea60fa5bd
--- /dev/null
+++ b/app-arch/stormlib/Manifest
@@ -0,0 +1 @@
+DIST StormLib-9.23.tar.gz 605295 BLAKE2B 2489e309f218f3e5c5069b56856415cc5985efb2352f36a33530442d539c786262b7c55d134dd67db3098981b1ad98ce8bfa77a16f86d28f326831b09752b705 SHA512 c851159596e252b42facdbac9c52f7477c61de35b44054ab608a22b42e7dc3b4179f50ba9d8cbd30448ed7787cc74e7efd2e08faafdd91289136cd91399d4f09
diff --git a/app-arch/stormlib/files/stormlib-9.23-gnuinstalldirs.patch b/app-arch/stormlib/files/stormlib-9.23-gnuinstalldirs.patch
new file mode 100644
index 000000000000..66b8f91183f0
--- /dev/null
+++ b/app-arch/stormlib/files/stormlib-9.23-gnuinstalldirs.patch
@@ -0,0 +1,55 @@
+From f89f1341cf59f7098af985ecd683d5e0407d2dc7 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Sun, 20 Dec 2020 10:52:34 +0100
+Subject: [PATCH] cmake: Use GNUInstallDirs for configurable install
+ directories
+
+Use the standard GNUInstallDirs CMake module to provide configurable
+install directories rather than hardcoding 'bin', 'lib', etc. Most
+importantly, this fixes install on modern amd64 systems that use 'lib64'
+rather than 'lib'.
+---
+ CMakeLists.txt | 13 +++++++------
+ 1 file changed, 7 insertions(+), 6 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index bd8d336..2b09191 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -4,6 +4,7 @@ cmake_minimum_required(VERSION 2.8.12)
+ set(LIBRARY_NAME storm)
+
+ include(CMakeDependentOption)
++include(GNUInstallDirs)
+
+ option(BUILD_SHARED_LIBS "Compile shared libraries" OFF)
+ option(STORM_SKIP_INSTALL "Skip installing files" OFF)
+@@ -331,12 +332,12 @@ endif()
+
+ if (NOT STORM_SKIP_INSTALL)
+ install(TARGETS ${LIBRARY_NAME}
+- RUNTIME DESTINATION bin
+- LIBRARY DESTINATION lib
+- ARCHIVE DESTINATION lib
++ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
++ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
++ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ FRAMEWORK DESTINATION /Library/Frameworks
+- PUBLIC_HEADER DESTINATION include
+- INCLUDES DESTINATION include)
++ PUBLIC_HEADER DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}
++ INCLUDES DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
+
+ #CPack configurtion
+ SET(CPACK_GENERATOR "DEB" "RPM")
+@@ -369,6 +370,6 @@ endif()
+ if(STORM_BUILD_TESTS)
+ add_executable(StormLib_test ${TEST_SRC_FILES})
+ target_link_libraries(StormLib_test ${LIBRARY_NAME})
+- install(TARGETS StormLib_test RUNTIME DESTINATION bin)
++ install(TARGETS StormLib_test RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
+ endif()
+
+--
+2.29.2
+
diff --git a/app-arch/stormlib/metadata.xml b/app-arch/stormlib/metadata.xml
new file mode 100644
index 000000000000..0319eec4c8be
--- /dev/null
+++ b/app-arch/stormlib/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-arch/stormlib/stormlib-9.23.ebuild b/app-arch/stormlib/stormlib-9.23.ebuild
new file mode 100644
index 000000000000..3e60afca6b70
--- /dev/null
+++ b/app-arch/stormlib/stormlib-9.23.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+MY_P=StormLib-${PV}
+DESCRIPTION="Library to read and write MPQ archives (Diablo, StarCraft)"
+HOMEPAGE="
+ http://www.zezula.net/en/mpq/stormlib.html
+ https://github.com/ladislav-zezula/StormLib"
+SRC_URI="
+ https://github.com/ladislav-zezula/StormLib/archive/v${PV}.tar.gz
+ -> ${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-arch/bzip2:=
+ sys-libs/zlib:="
+
+PATCHES=(
+ "${FILESDIR}"/stormlib-9.23-gnuinstalldirs.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=ON
+ # interactive test app
+ -DSTORM_BUILD_TESTS=OFF
+ # -DWITH_LIBTOMCRYPT=ON when we have tomcrypt packaged
+ )
+
+ cmake_src_configure
+}