summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-12-29 12:54:13 +0100
committerDavid Seifert <soap@gentoo.org>2017-12-29 14:16:09 +0100
commit74cb78ba9e2a2ede0c725bd649674aa26e73e008 (patch)
tree807753e336e3a348ddf93427a6e9b5ce549bd0b4 /app-arch/tapeutils
parentapp-arch/afio: [QA] Minor touchups (diff)
downloadgentoo-74cb78ba9e2a2ede0c725bd649674aa26e73e008.tar.gz
gentoo-74cb78ba9e2a2ede0c725bd649674aa26e73e008.tar.bz2
gentoo-74cb78ba9e2a2ede0c725bd649674aa26e73e008.zip
app-arch/tapeutils: Port to EAPI 6
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-arch/tapeutils')
-rw-r--r--app-arch/tapeutils/files/tapeutils-0.4-fix-C-decl.patch31
-rw-r--r--app-arch/tapeutils/files/tapeutils-0.4-fix-build-system.patch11
-rw-r--r--app-arch/tapeutils/tapeutils-0.4.ebuild16
3 files changed, 54 insertions, 4 deletions
diff --git a/app-arch/tapeutils/files/tapeutils-0.4-fix-C-decl.patch b/app-arch/tapeutils/files/tapeutils-0.4-fix-C-decl.patch
new file mode 100644
index 000000000000..ee07c252d168
--- /dev/null
+++ b/app-arch/tapeutils/files/tapeutils-0.4-fix-C-decl.patch
@@ -0,0 +1,31 @@
+--- a/tapecopy.c
++++ b/tapecopy.c
+@@ -26,6 +26,8 @@
+ Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+ */
+
++#include <stdlib.h>
++
+ #include "tapeio.h"
+ #include "stdio.h"
+ #include "stdarg.h"
+--- a/tapedump.c
++++ b/tapedump.c
+@@ -26,6 +26,8 @@
+ Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+ */
+
++#include <stdlib.h>
++
+ #include "tapeio.h"
+ #include "stdio.h"
+ #include "stdarg.h"
+@@ -158,7 +160,7 @@
+ len = getrec (src, buf, MAX_REC_LEN);
+ if (len == 0)
+ {
+- printf ("total length of file %d = %d records, %d bytes\n",
++ printf ("total length of file %d = %d records, %lu bytes\n",
+ file, record, filebytes);
+ tapebytes += filebytes;
+ file++;
diff --git a/app-arch/tapeutils/files/tapeutils-0.4-fix-build-system.patch b/app-arch/tapeutils/files/tapeutils-0.4-fix-build-system.patch
new file mode 100644
index 000000000000..e1670a47fe2b
--- /dev/null
+++ b/app-arch/tapeutils/files/tapeutils-0.4-fix-build-system.patch
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -20,8 +20,6 @@
+ # options
+ # -----------------------------------------------------------------------------
+
+-CFLAGS = -O2
+-LDFLAGS =
+
+ # CFLAGS = -g
+ # LDFLAGS = -g
diff --git a/app-arch/tapeutils/tapeutils-0.4.ebuild b/app-arch/tapeutils/tapeutils-0.4.ebuild
index b70a469e36db..50e3aac72747 100644
--- a/app-arch/tapeutils/tapeutils-0.4.ebuild
+++ b/app-arch/tapeutils/tapeutils-0.4.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
+EAPI=6
+
inherit toolchain-funcs
DESCRIPTION="Utilities for manipulation of tapes and tape image files"
@@ -12,13 +14,19 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
+DEPEND=""
RDEPEND="!app-emulation/hercules"
-src_compile() {
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" || die
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.4-fix-build-system.patch
+ "${FILESDIR}"/${PN}-0.4-fix-C-decl.patch
+)
+
+src_configure() {
+ tc-export CC
}
src_install() {
- dobin tapecopy tapedump || die
+ dobin tapecopy tapedump
# no docs to install
}