summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno <hanno@gentoo.org>2016-11-08 11:33:45 +0100
committerHanno <hanno@gentoo.org>2016-11-08 11:33:45 +0100
commitc43dd3465b73647260df6c048d887cf34d4f9688 (patch)
tree19b13ea0deaff918bf2c8b2ef5e865f685803817 /app-arch/unar
parentapp-arch/unar: Remove old versions (diff)
downloadgentoo-c43dd3465b73647260df6c048d887cf34d4f9688.tar.gz
gentoo-c43dd3465b73647260df6c048d887cf34d4f9688.tar.bz2
gentoo-c43dd3465b73647260df6c048d887cf34d4f9688.zip
app-arch/unar: Fix dependencies and make warning
Add missing dependencies found by depcheck (zlib, bzip2), move gnustep-make from RDEPEND to DEPEND. Avoid jobserver warning by removing direct make call from Makefile. Package-Manager: portage-2.3.2
Diffstat (limited to 'app-arch/unar')
-rw-r--r--app-arch/unar/unar-1.10.1.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/app-arch/unar/unar-1.10.1.ebuild b/app-arch/unar/unar-1.10.1.ebuild
index e79d2b143d40..51d2a84fc779 100644
--- a/app-arch/unar/unar-1.10.1.ebuild
+++ b/app-arch/unar/unar-1.10.1.ebuild
@@ -16,13 +16,21 @@ KEYWORDS="amd64"
IUSE=""
RDEPEND="gnustep-base/gnustep-base
- >=gnustep-base/gnustep-make-2.6.0[native-exceptions]
- dev-libs/icu:="
+ dev-libs/icu:=
+ sys-libs/zlib
+ app-arch/bzip2"
DEPEND="${RDEPEND}
+ >=gnustep-base/gnustep-make-2.6.0[native-exceptions]
sys-devel/gcc[objc]"
S="${WORKDIR}/The Unarchiver/XADMaster"
+src_prepare() {
+ # avoid jobserver warning, upstream bug:
+ # https://bitbucket.org/WAHa_06x36/theunarchiver/issues/918/dont-call-make-from-makefile
+ sed -i -e 's:make:$(MAKE):g' Makefile.linux
+}
+
src_compile() {
emake -f Makefile.linux \
AR="$(tc-getAR)" \