summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaul E Rangel <rrangel@chromium.org>2023-04-03 14:34:39 -0600
committerMike Gilbert <floppym@gentoo.org>2023-04-12 10:32:30 -0400
commit0e2d85999128ffd8df2b17b1ba1379b81ad69ea0 (patch)
tree089b95a048c4f8f2c908ac43ea105d8fc1d3a044 /app-arch/zip
parentprofiles/prefix/linux: add arm64 profile (diff)
downloadgentoo-0e2d85999128ffd8df2b17b1ba1379b81ad69ea0.tar.gz
gentoo-0e2d85999128ffd8df2b17b1ba1379b81ad69ea0.tar.bz2
gentoo-0e2d85999128ffd8df2b17b1ba1379b81ad69ea0.zip
app-arch/zip: Fix dependencies
DEPEND should reference RDEPEND after it's set otherwise the DEPEND variable will be incorrect. aarch64-cros-linux-gnu-clang -c -I. ... -o fileio_.o fileio.c zipup.c:37:14: fatal error: 'bzlib.h' file not found # include "bzlib.h" ^~~~~~~~~ zip.c:67:1 error generated. Signed-off-by: Raul E Rangel <rrangel@chromium.org> Closes: https://github.com/gentoo/gentoo/pull/30466 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'app-arch/zip')
-rw-r--r--app-arch/zip/zip-3.0-r7.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/app-arch/zip/zip-3.0-r7.ebuild b/app-arch/zip/zip-3.0-r7.ebuild
index f1f6d540e823..f21af88f5e91 100644
--- a/app-arch/zip/zip-3.0-r7.ebuild
+++ b/app-arch/zip/zip-3.0-r7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -16,9 +16,9 @@ SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux"
IUSE="bzip2 crypt natspec unicode"
-DEPEND="${RDEPEND}"
RDEPEND="bzip2? ( app-arch/bzip2 )
natspec? ( dev-libs/libnatspec )"
+DEPEND="${RDEPEND}"
BDEPEND="app-arch/unzip"
PATCHES=(