summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-04-12 16:47:48 -0400
committerMatt Turner <mattst88@gentoo.org>2021-04-12 17:59:21 -0400
commit7fa2274b5f6971f85a360c8d7584879a02e9d0ff (patch)
tree063fa562540474b882cfd9ad98aba7f8cec45963 /app-arch
parentmedia-video/pipewire: Bump to 0.3.25 & ebuild overhaul (diff)
downloadgentoo-7fa2274b5f6971f85a360c8d7584879a02e9d0ff.tar.gz
gentoo-7fa2274b5f6971f85a360c8d7584879a02e9d0ff.tar.bz2
gentoo-7fa2274b5f6971f85a360c8d7584879a02e9d0ff.zip
app-arch/file-roller: Version bump to 3.38.1
Bug: https://bugs.gentoo.org/780858 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/file-roller/Manifest1
-rw-r--r--app-arch/file-roller/file-roller-3.38.1.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/app-arch/file-roller/Manifest b/app-arch/file-roller/Manifest
index 7280c869d29c..f1e6b4942e03 100644
--- a/app-arch/file-roller/Manifest
+++ b/app-arch/file-roller/Manifest
@@ -1,2 +1,3 @@
DIST file-roller-3.36.3.tar.xz 870608 BLAKE2B 4c57b99f2ca0eb4db3fac0216b63207d1664829ee54e21eb976a327bd65aec5abfd2a02b84bc80246fde131ede6ff63deaf8b63451db6a0fecc0121c8bce1a5b SHA512 41558ca8061276b1248fd3599e856051dcd69ca831fb4d8a33666dc373b4abed56e7ef204a6e041ceace05ea7234448d15bc7be8c48dc1809ac6d445de251370
DIST file-roller-3.38.0.tar.xz 877960 BLAKE2B af1c4800e24adfb36a8f8f108740f9cad14bcd40f797b2430d00e428d723587de75be03848aca612536cee768b6b372534e0b6a322dc40d7ab1c41eef540916b SHA512 9c2e3c105397bceb08e30c9796b9242633fe49772aed2e7f67461c34a51be1493e922301b1fc29bdcb0fa50d220f4a7db2ee7642f629007ce2bef00334d7110e
+DIST file-roller-3.38.1.tar.xz 875572 BLAKE2B 29a05d48971c2172177bd1aa52448ed5432a69733644b131517dbd7dd50cab971801d1bff5837dba74ae48ea0487614c7c7ebd4669f04f7d42e6257161fe1776 SHA512 b1936481140084c84d7bdbf361859b0ff1fed8329e26b692f0f0c8d1a3a1ec494b493aa0fb4de9f0ea5004b18e4bd69859656fe424bf413d720b04fc56e453f6
diff --git a/app-arch/file-roller/file-roller-3.38.1.ebuild b/app-arch/file-roller/file-roller-3.38.1.ebuild
new file mode 100644
index 000000000000..583372f40951
--- /dev/null
+++ b/app-arch/file-roller/file-roller-3.38.1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org gnome2-utils meson readme.gentoo-r1 xdg
+
+DESCRIPTION="Archive manager for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/FileRoller"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+SLOT="0"
+IUSE="libnotify nautilus"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+# gdk-pixbuf used extensively in the source
+# cairo used in eggtreemultidnd.c
+# pango used in fr-window
+RDEPEND="
+ >=app-arch/libarchive-3:=
+ >=dev-libs/glib-2.38:2
+ >=dev-libs/json-glib-0.14
+ >=x11-libs/gtk+-3.22.0:3
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango
+ libnotify? ( >=x11-libs/libnotify-0.4.3:= )
+ nautilus? ( >=gnome-base/nautilus-3.28.0 )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="
+${PN} is a frontend for several archiving utilities. If you want a
+particular archive format support, see ${HOMEPAGE}
+and install the relevant package. For example:
+7-zip - app-arch/p7zip
+ace - app-arch/unace
+arj - app-arch/arj
+brotli - app-arch/brotli
+cpio - app-arch/cpio
+deb - app-arch/dpkg
+iso - app-cdr/cdrtools
+jar,zip - app-arch/zip and app-arch/unzip
+lha - app-arch/lha
+lzop - app-arch/lzop
+lz4 - app-arch/lz4
+rar - app-arch/unrar or app-arch/unar
+rpm - app-arch/rpm
+unstuff - app-arch/stuffit
+zstd - app-arch/zstd
+zoo - app-arch/zoo"
+
+src_prepare() {
+ # File providing Gentoo package names for various archivers
+ cp -v "${FILESDIR}"/3.36-packages.match data/packages.match || die
+
+ xdg_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ -Drun-in-place=false
+ $(meson_use nautilus nautilus-actions)
+ $(meson_use libnotify notification)
+ -Dpackagekit=false
+ -Dlibarchive=true
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}