summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-backup/deja-dup
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-backup/deja-dup')
-rw-r--r--app-backup/deja-dup/Manifest2
-rw-r--r--app-backup/deja-dup/deja-dup-32.0-r1.ebuild79
-rw-r--r--app-backup/deja-dup/deja-dup-34.0.ebuild74
-rw-r--r--app-backup/deja-dup/files/deja-dup-29.1-cmake-backport-1.patch11
-rw-r--r--app-backup/deja-dup/files/deja-dup-29.1-cmake-backport-2.patch32
-rw-r--r--app-backup/deja-dup/files/deja-dup-29.5-cmake.patch16
-rw-r--r--app-backup/deja-dup/files/deja-dup-32.0-duplicity-0.6.25.patch41
-rw-r--r--app-backup/deja-dup/metadata.xml14
8 files changed, 269 insertions, 0 deletions
diff --git a/app-backup/deja-dup/Manifest b/app-backup/deja-dup/Manifest
new file mode 100644
index 000000000000..ccdd2c24ca6e
--- /dev/null
+++ b/app-backup/deja-dup/Manifest
@@ -0,0 +1,2 @@
+DIST deja-dup-32.0.tar.xz 690424 SHA256 3ed3da64e6ce7d1f45816a6e490fdcaef1d3796d1e478e2bab6186b0090a109b SHA512 ad8ee1066539ffc55e3ce1d167641d7dc14dfaa6508d41c7003a2571db63a6ae2e84b6055e9df559ff42e7fd9ac647bd851168ed84edac31562d01e4e1f619cf WHIRLPOOL 2d941ac4c4cd78be822e9a4b331ada883796f93c49b4f3c6a4362b4012d82f69c33c8546fa64dea72a9cd49bdb76927256459368b0c2b9418af014676f2eb2cf
+DIST deja-dup-34.0.tar.xz 670644 SHA256 a12da41c989c1fdf43e430965efe8934b0ed9919aab29b372ef7edcedd9fd468 SHA512 70e1b7bb9490acba2b3f2656bc3210a6278a28be3cb8fa4a05feb4b9a88bf8f3728a25d09023bae6203124a38dd71c931d245eaa8302fa0ebf3322151b9f79ba WHIRLPOOL 3661ff7f63049f816f606cb7b11303fed6cb48fb1ec2e78a0dc9260ddb6b267526ef06e658794578a8bccb9d5db370d485f33ae9411aa07efb8accb8e3ae720b
diff --git a/app-backup/deja-dup/deja-dup-32.0-r1.ebuild b/app-backup/deja-dup/deja-dup-32.0-r1.ebuild
new file mode 100644
index 000000000000..d2c3114fafde
--- /dev/null
+++ b/app-backup/deja-dup/deja-dup-32.0-r1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+GNOME2_LA_PUNT="yes"
+
+VALA_MIN_API_VERSION="0.22" # for >=gtk+-3.10
+VALA_MAX_API_VERSION="0.24"
+
+inherit cmake-utils eutils gnome2 vala
+
+DESCRIPTION="Simple backup tool using duplicity back-end"
+HOMEPAGE="https://launchpad.net/deja-dup/"
+SRC_URI="http://launchpad.net/${PN}/32/${PV}/+download/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="nautilus test"
+
+RESTRICT="test"
+
+COMMON_DEPEND="
+ app-crypt/libsecret[vala]
+ >=dev-libs/glib-2.34:2
+ >=dev-libs/libpeas-1.0
+ >=x11-libs/gtk+-3.10:3
+ >=x11-libs/libnotify-0.7
+
+ >=app-backup/duplicity-0.6.23
+ dev-libs/dbus-glib
+
+ nautilus? ( gnome-base/nautilus )"
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/dconf
+ gnome-base/gvfs[fuse]"
+DEPEND="${COMMON_DEPEND}
+ app-text/yelp-tools
+ $(vala_depend)
+ dev-perl/Locale-gettext
+ virtual/pkgconfig
+ dev-util/intltool
+ sys-devel/gettext"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-duplicity-0.6.25.patch
+)
+
+src_prepare() {
+ sed \
+ -e '/RPATH/s:PKG_LIBEXECDIR:PKG_LIBDIR:g' \
+ -i CMakeLists.txt || die
+ vala_src_prepare
+ gnome2_src_prepare
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DVALA_EXECUTABLE="${VALAC}"
+ -DENABLE_CCPANEL=OFF
+ -DENABLE_UNITY=OFF
+ -DENABLE_UNITY_CCPANEL=OFF
+ -DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}"/etc
+ $(cmake-utils_use_enable nautilus)
+ $(cmake-utils_use_enable test TESTING)
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+}
diff --git a/app-backup/deja-dup/deja-dup-34.0.ebuild b/app-backup/deja-dup/deja-dup-34.0.ebuild
new file mode 100644
index 000000000000..804305cd9154
--- /dev/null
+++ b/app-backup/deja-dup/deja-dup-34.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+GNOME2_LA_PUNT="yes"
+
+VALA_MIN_API_VERSION="0.22" # for >=gtk+-3.10
+
+inherit cmake-utils eutils gnome2 vala
+
+DESCRIPTION="Simple backup tool using duplicity back-end"
+HOMEPAGE="https://launchpad.net/deja-dup/"
+SRC_URI="http://launchpad.net/${PN}/34/${PV}/+download/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nautilus test"
+
+RESTRICT="test"
+
+COMMON_DEPEND="
+ app-crypt/libsecret[vala]
+ >=dev-libs/glib-2.34:2
+ >=dev-libs/libpeas-1.0
+ >=x11-libs/gtk+-3.10:3
+ >=x11-libs/libnotify-0.7
+
+ >=app-backup/duplicity-0.6.23
+ dev-libs/dbus-glib
+
+ nautilus? ( gnome-base/nautilus )"
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/dconf
+ gnome-base/gvfs[fuse]"
+DEPEND="${COMMON_DEPEND}
+ app-text/yelp-tools
+ $(vala_depend)
+ dev-perl/Locale-gettext
+ virtual/pkgconfig
+ dev-util/intltool
+ sys-devel/gettext"
+
+src_prepare() {
+ sed \
+ -e '/RPATH/s:PKG_LIBEXECDIR:PKG_LIBDIR:g' \
+ -i CMakeLists.txt || die
+ vala_src_prepare
+ gnome2_src_prepare
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DVALA_EXECUTABLE="${VALAC}"
+ -DENABLE_CCPANEL=OFF
+ -DENABLE_UNITY=OFF
+ -DENABLE_UNITY_CCPANEL=OFF
+ -DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}"/etc
+ $(cmake-utils_use_enable nautilus)
+ $(cmake-utils_use_enable test TESTING)
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+}
diff --git a/app-backup/deja-dup/files/deja-dup-29.1-cmake-backport-1.patch b/app-backup/deja-dup/files/deja-dup-29.1-cmake-backport-1.patch
new file mode 100644
index 000000000000..1c122d1723d0
--- /dev/null
+++ b/app-backup/deja-dup/files/deja-dup-29.1-cmake-backport-1.patch
@@ -0,0 +1,11 @@
+=== modified file 'deja-dup/nautilus/CMakeLists.txt'
+--- deja-dup/nautilus/CMakeLists.txt 2013-10-11 19:57:03 +0000
++++ deja-dup/nautilus/CMakeLists.txt 2013-11-08 03:32:53 +0000
+@@ -23,5 +23,6 @@
+ OUTPUT_NAME deja-dup
+ INCLUDE_DIRECTORIES "${CMAKE_BINARY_DIR}/libdeja"
+ COMPILE_FLAGS "${GLIB_CFLAGS} ${NAUTILUS_CFLAGS} ${COMMON_CFLAGS}")
++add_dependencies(deja-dup-nautilus deja) # needs DirHandling.c
+ install(TARGETS deja-dup-nautilus DESTINATION "${NAUTILUS_EXTENSIONDIR}")
+ endif()
+
diff --git a/app-backup/deja-dup/files/deja-dup-29.1-cmake-backport-2.patch b/app-backup/deja-dup/files/deja-dup-29.1-cmake-backport-2.patch
new file mode 100644
index 000000000000..7411d1927ff5
--- /dev/null
+++ b/app-backup/deja-dup/files/deja-dup-29.1-cmake-backport-2.patch
@@ -0,0 +1,32 @@
+=== modified file 'cmake/DejaDupMacros.cmake'
+--- cmake/DejaDupMacros.cmake 2013-10-11 19:57:03 +0000
++++ cmake/DejaDupMacros.cmake 2013-11-09 05:59:00 +0000
+@@ -34,19 +34,15 @@
+ endmacro()
+
+ macro(deja_enable_option)
+- if(NOT ENABLE_${ARGV0})
+- return() # nothing to do
+- endif()
+-
+- deja_check_modules(${ARGV})
+-
+- if(NOT ${ARGV0}_FOUND)
+- if(ENABLE_${ARGV0} STREQUAL "CHECK")
+- set(ENABLE_${ARGV0} OFF)
+- else()
+- message(FATAL_ERROR "You enabled ${ARGV0}, but required dependencies could not be found")
++ if(ENABLE_${ARGV0})
++ deja_check_modules(${ARGV})
++ if(NOT ${ARGV0}_FOUND)
++ if(ENABLE_${ARGV0} STREQUAL "CHECK")
++ set(ENABLE_${ARGV0} OFF)
++ else()
++ message(FATAL_ERROR "You enabled ${ARGV0}, but required dependencies could not be found")
++ endif()
+ endif()
+- return()
+ endif()
+ endmacro()
+
+
diff --git a/app-backup/deja-dup/files/deja-dup-29.5-cmake.patch b/app-backup/deja-dup/files/deja-dup-29.5-cmake.patch
new file mode 100644
index 000000000000..6b364d4ef736
--- /dev/null
+++ b/app-backup/deja-dup/files/deja-dup-29.5-cmake.patch
@@ -0,0 +1,16 @@
+ deja-dup/widgets/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/deja-dup/widgets/CMakeLists.txt b/deja-dup/widgets/CMakeLists.txt
+index 78f0e21..e885ac8 100644
+--- a/deja-dup/widgets/CMakeLists.txt
++++ b/deja-dup/widgets/CMakeLists.txt
+@@ -52,7 +52,7 @@ vala_precompile(VALA_C ConfigBool.vala
+ GENERATE_VAPI widgets
+ GENERATE_HEADER widgets)
+ add_library(widgets SHARED ${VALA_C})
+-target_link_libraries(widgets deja "${GTK_LDFLAGS} ${NOTIFY_LDFLAGS} ${PEAS_LDFLAGS} ${SECRET_LDFLAGS} ${UNITY_LDFLAGS}")
++target_link_libraries(widgets deja ${GTK_LDFLAGS} ${NOTIFY_LDFLAGS} ${PEAS_LDFLAGS} ${SECRET_LDFLAGS} ${UNITY_LDFLAGS})
+ set_target_properties(widgets PROPERTIES
+ INCLUDE_DIRECTORIES "${CMAKE_BINARY_DIR}/libdeja;${CMAKE_SOURCE_DIR}/libdeja"
+ COMPILE_FLAGS "${GTK_CFLAGS} ${NOTIFY_CFLAGS} ${PEAS_CFLAGS} ${SECRET_CFLAGS} ${UNITY_CFLAGS} ${COMMON_CFLAGS}")
diff --git a/app-backup/deja-dup/files/deja-dup-32.0-duplicity-0.6.25.patch b/app-backup/deja-dup/files/deja-dup-32.0-duplicity-0.6.25.patch
new file mode 100644
index 000000000000..016e67829fd5
--- /dev/null
+++ b/app-backup/deja-dup/files/deja-dup-32.0-duplicity-0.6.25.patch
@@ -0,0 +1,41 @@
+=== modified file 'AUTHORS'
+--- AUTHORS 2014-04-29 02:38:47 +0000
++++ AUTHORS 2014-10-23 06:41:44 +0000
+@@ -12,6 +12,10 @@
+ Comment: For specific author information, see the bzr logs
+ License: GPL-3+
+
++Files: libdeja/tools/duplicity/DuplicityPlugin.vala
++Copyright: 2014 Adrien Bak <adrien.bak@gmail.com>
++Licence: GPL-3+
++
+ Files: po/*.po
+ Copyright: 2008–2013 Rosetta Contributors and Canonical Ltd
+ License: GPL-3+
+
+=== modified file 'libdeja/tools/duplicity/DuplicityPlugin.vala'
+--- libdeja/tools/duplicity/DuplicityPlugin.vala 2014-01-24 16:07:59 +0000
++++ libdeja/tools/duplicity/DuplicityPlugin.vala 2014-10-23 06:41:44 +0000
+@@ -35,13 +35,17 @@
+ {
+ string output;
+ Process.spawn_command_line_sync("duplicity --version", out output, null, null);
++ var tokens = output.split(" ");
+
+- var tokens = output.split(" ", 2);
+- if (tokens == null || tokens[0] == null || tokens[1] == null)
++ if (tokens == null || tokens.length < 2 )
+ throw new SpawnError.FAILED(_("Could not understand duplicity version."));
+
+- // First token is 'duplicity' and is ignorable. Second looks like '0.5.03'
+- var version_string = tokens[1].strip();
++ // in version 0.6.25, the output fro duplicity --version changed and the string
++ // "duplicity major.minor.micro" is not preceded by a deprecation warning
++ // as a consequence, the substring "major.minor.micro" is now
++ // always the penultimate token (the last one always being null)
++
++ var version_string = tokens[tokens.length - 1].strip();
+ int major, minor, micro;
+ if (!DejaDup.parse_version(version_string, out major, out minor, out micro))
+ throw new SpawnError.FAILED(_("Could not understand duplicity version ‘%s’.").printf(version_string));
+
diff --git a/app-backup/deja-dup/metadata.xml b/app-backup/deja-dup/metadata.xml
new file mode 100644
index 000000000000..d9dd1919780e
--- /dev/null
+++ b/app-backup/deja-dup/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="nautilus">Build gnome-base/nautilus extension</flag>
+ </use>
+ <upstream>
+ <remote-id type="launchpad">deja-dup</remote-id>
+ </upstream>
+</pkgmetadata>