summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergiy Borodych <Sergiy.Borodych@gmail.com>2016-08-12 12:19:35 +0300
committerPatrice Clement <monsieurp@gentoo.org>2016-08-18 14:38:28 +0200
commit12aa13fe86ecdb08983e7365f36de30463705978 (patch)
tree51b797f724675a13cd9c6c109a6cc0f9cd84d449 /app-backup/rsnapshot/rsnapshot-1.4.2.ebuild
parentdev-ml/ocaml-cstruct: bump to 2.3.0 (diff)
downloadgentoo-12aa13fe86ecdb08983e7365f36de30463705978.tar.gz
gentoo-12aa13fe86ecdb08983e7365f36de30463705978.tar.bz2
gentoo-12aa13fe86ecdb08983e7365f36de30463705978.zip
app-backup/rsnapshot: version bump to 1.4.2.
Also bump to EAPI version 6. Closes: https://github.com/gentoo/gentoo/pull/2072 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-backup/rsnapshot/rsnapshot-1.4.2.ebuild')
-rw-r--r--app-backup/rsnapshot/rsnapshot-1.4.2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-backup/rsnapshot/rsnapshot-1.4.2.ebuild b/app-backup/rsnapshot/rsnapshot-1.4.2.ebuild
new file mode 100644
index 000000000000..802d154582c3
--- /dev/null
+++ b/app-backup/rsnapshot/rsnapshot-1.4.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="A filesystem backup utility based on rsync"
+HOMEPAGE="http://www.rsnapshot.org"
+SRC_URI="http://www.rsnapshot.org/downloads/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND=">=dev-lang/perl-5.8.2
+ dev-perl/Lchown
+ >=sys-apps/util-linux-2.12-r4
+ >=sys-apps/coreutils-5.0.91-r4
+ >=net-misc/openssh-3.7.1_p2-r1
+ >=net-misc/rsync-2.6.0"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ # Change sysconfdir to install the template file as documentation
+ # rather than in /etc.
+ emake install DESTDIR="${D}" \
+ sysconfdir="${EPREFIX}/usr/share/doc/${PF}"
+
+ dodoc README.md AUTHORS ChangeLog \
+ docs/Upgrading_from_1.1
+
+ docinto utils
+ dodoc utils/{README,rsnaptar,*.sh,*.pl}
+
+ docinto utils/rsnapshotdb
+ dodoc utils/rsnapshotdb/*
+}
+
+pkg_postinst() {
+ elog "The template configuration file has been installed as"
+ elog "/usr/share/doc/${PF}/rsnapshot.conf.default"
+ elog "Copy and edit the the above file as /etc/rsnapshot.conf"
+}