summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-08-18 07:16:58 -0400
committerAnthony G. Basile <blueness@gentoo.org>2015-08-18 07:16:58 -0400
commit1982454b78140a6fc4578c09212e106907611297 (patch)
tree89efa56a56b71c48688ac133e5f5b887162badb4 /app-backup
parentapp-portage/g-sorcery: update live ebuild (diff)
downloadgentoo-1982454b78140a6fc4578c09212e106907611297.tar.gz
gentoo-1982454b78140a6fc4578c09212e106907611297.tar.bz2
gentoo-1982454b78140a6fc4578c09212e106907611297.zip
app-backup/spideroak-bin: version bump to 6.0
Gentoo-Bug: 556220 Package-Manager: portage-2.2.20.1
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/spideroak-bin/Manifest2
-rw-r--r--app-backup/spideroak-bin/spideroak-bin-6.0.ebuild94
2 files changed, 96 insertions, 0 deletions
diff --git a/app-backup/spideroak-bin/Manifest b/app-backup/spideroak-bin/Manifest
index d1671d4d5be9..48cf281768cc 100644
--- a/app-backup/spideroak-bin/Manifest
+++ b/app-backup/spideroak-bin/Manifest
@@ -4,3 +4,5 @@ DIST spideroak-bin-5.1.8_amd64.deb 20000116 SHA256 b91f3077c2238bbb1123361afc597
DIST spideroak-bin-5.1.8_x86.deb 19361954 SHA256 806aae6ac96cb47443c50bfc3bc3f5f7b00abc0b5d978cc2746d10cb1f6b6742 SHA512 43242b9fcd577fc51b838de72215fa971f385ae1f6ea7c606cc198b2dacd0bbca9b693ea2452c2c957c3af6dc97625d6bd15176067542dfdcbc1505a50c8b42b WHIRLPOOL 5f88e3b699be60151471c71998b2aad2d7e5a42a1c179ccb10a168940dd4ea291f812e6d6e9eb475345b53f403aa3a09cd785759413a0cf50edc9b92300af14f
DIST spideroak-bin-5.2.0_amd64.deb 20284404 SHA256 f9b452f891796fcd1046c4a955d2b4722b0a452b24f8ea728a30833c0a576f32 SHA512 75a96c6f6f0ec6a14255fc4f3bdad96ba54be4a4ee2ea385159c575e7b0e05bf3cfcfc4b0595a430b4a686acda3cb2674df5959d0b1a3ddc609a590d7737d94e WHIRLPOOL c6045af1101008b2ca25df4fd4d34d55b3dcda2187660f3601fbc9a6aa53c7e9ad3d59fffa954c2eb57022a46ecf04a42f39577914fc01dbe2c46c4c5e184475
DIST spideroak-bin-5.2.0_x86.deb 19641884 SHA256 f4689dcc0630e4b46b039c64a16e291d740cc245b7507863ae5938473f504c30 SHA512 e98041b98c77e011774abe5b832c9a2ee4ecd179864bd39aacdb439f906110797f9f96e7326a394a6da0cbb88650c242da51060b501de0c379a0efdb75594403 WHIRLPOOL bf96a2cd8f3bbf6ab2ec26c532546b8c40dda09a1902075332fb2c8787af4a4a1808094fb6e7fb90f27c9da2d480b1129e235fa656c76bd1acbfd3b8bbda90d5
+DIST spideroak-bin-6.0_amd64.deb 26676730 SHA256 5825635b706da95740e4b2e1d36870d17d0cfd6a8b26ded6116708d9496e0551 SHA512 9c0cb6195a0c553e0e1e691d4f22950fd826142c526035ac0ef84628a15a17f293dcaed5bf2ab138ddfb94a47265e06906f6b55e78582212672c9dcb503e86f9 WHIRLPOOL d31fb7a4bd3bc3a49d0a7241bd4bd723ccee28b784ddfbf75c598638bf47dbc0fc75edbdcb5134ea2574f5897d399a79fe42d59a22b41bdc31c63c9fe48f28e0
+DIST spideroak-bin-6.0_x86.deb 26196770 SHA256 0d655cddc6201188f7bb04d46774bdca42ca6e9958ed458a1bf89bc53485fc58 SHA512 692418c59462f53930583df01bc5f31520b33d10f9bf616cca6bffcea425d667f65e194c4d40c8357822895f7f54e42f747b25e1dd9af522ab44cec940a66c45 WHIRLPOOL a963aa5a05e85fd55d53849d09099aa585b481c2c9f4756f3d4a7e2c17edd5375da12c669341073453f9a62e471c9121a92008a90288a20b10c75f323885d4d5
diff --git a/app-backup/spideroak-bin/spideroak-bin-6.0.ebuild b/app-backup/spideroak-bin/spideroak-bin-6.0.ebuild
new file mode 100644
index 000000000000..f6b262a6e1e3
--- /dev/null
+++ b/app-backup/spideroak-bin/spideroak-bin-6.0.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils unpacker
+
+SRC_URI_BASE="https://spideroak.com/getbuild?platform=ubuntu"
+
+DESCRIPTION="An easy, secure and consolidated free online backup, storage, access and sharing system"
+HOMEPAGE="https://spideroak.com"
+SRC_URI="x86? ( ${SRC_URI_BASE}&arch=i386&version=${PV} -> ${P}_x86.deb )
+ amd64? ( ${SRC_URI_BASE}&arch=x86_64&version=${PV} -> ${P}_amd64.deb )"
+RESTRICT="mirror strip"
+
+LICENSE="spideroak"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus X"
+
+DEPEND="dev-util/patchelf"
+RDEPEND="
+ app-crypt/mit-krb5[keyutils]
+ dbus? ( sys-apps/dbus )
+ X? (
+ media-libs/fontconfig
+ media-libs/freetype:2
+ dev-libs/glib:2
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libXrender
+ x11-libs/libXt
+ )
+"
+
+S=${WORKDIR}
+
+QA_PREBUILT="*"
+
+src_prepare() {
+ # Set RPATH for preserve-libs handling (bug #400979).
+ cd "${S}/opt/SpiderOakONE/lib" || die
+ local x
+ for x in `find` ; do
+ # Use \x7fELF header to separate ELF executables and libraries
+ [[ -f ${x} && $(od -t x1 -N 4 "${x}") == *"7f 45 4c 46"* ]] || continue
+ patchelf --set-rpath '$ORIGIN' "${x}" || \
+ die "patchelf failed on ${x}"
+ done
+}
+
+src_install() {
+ #install the wrapper script
+ exeinto /usr/bin
+ doexe usr/bin/SpiderOakONE
+
+ # inotify_dir_watcher needs to be marked executable, bug #453266
+ #chmod a+rx opt/SpiderOakONE/lib/inotify_dir_watcher
+
+ #install the executable
+ exeinto /opt/SpiderOakONE/lib
+ doexe opt/SpiderOakONE/lib/SpiderOakONE
+ doexe opt/SpiderOakONE/lib/inotify_dir_watcher
+ rm -f opt/SpiderOakONE/lib/{SpiderOakONE,inotify_dir_watcher}
+
+ #install the prebundled libraries
+ insinto /opt/SpiderOakONE
+ doins -r opt/SpiderOakONE/lib
+
+ #install the config files
+ use dbus || rm -rf etc/dbus-1
+ insinto /
+ doins -r etc
+
+ #install the manpage
+ doman usr/share/man/man1/SpiderOakONE.1.gz
+
+ if use X; then
+ domenu usr/share/applications/spideroakone.desktop
+ doicon usr/share/pixmaps/SpiderOakONE.png
+ fi
+}
+
+pkg_postinst() {
+ if ! use X; then
+ einfo "For instructions on running SpiderOakONE without a GUI, please read the FAQ:"
+ einfo " https://spideroak.com/faq/questions/62/how_do_i_install_spideroak_on_a_headless_linux_server/"
+ einfo " https://spideroak.com/faq/questions/67/how_can_i_use_spideroak_from_the_commandline/"
+ fi
+}