summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThibaud CANALE <thican@thican.net>2022-11-06 14:12:31 +0100
committerMatthew Thode <prometheanfire@gentoo.org>2023-02-16 09:57:00 -0600
commit51f64a7f8199962ad741caecf4668785dd7debbd (patch)
tree870d7bc7b9eb07664577a229a587d76a8ee600fe /app-crypt/certbot/certbot-9999.ebuild
parentapp-crypt/acme: brings multiple reworks (bug 881043) (diff)
downloadgentoo-51f64a7f8199962ad741caecf4668785dd7debbd.tar.gz
gentoo-51f64a7f8199962ad741caecf4668785dd7debbd.tar.bz2
gentoo-51f64a7f8199962ad741caecf4668785dd7debbd.zip
app-crypt/certbot: brings multiple reworks (bug 881043)
Bug: https://bugs.gentoo.org/881043 The purpose of this commit is to provide a common base for this package and its bindings. For example, we should keep only one and single archive name to avoid duplication, saving storage and download time. Warnings: some modifications might require some reviews, tests were done but maybe not thorough. Reworks: - replaces deprecated DISTUTILS_USE_SETUPTOOLS by DISTUTILS_USE_PEP517, with "setuptools" (DistutilsNonPEP517Build); - stores archive with ".gh" in its extension (PythonGHDistfileSuffix); - uses plaintext URL for SRC_URI. Also removes zope since 2.0.0 version, see upstream commit 9d736d5c9c939ef5a47b001ef9cb3ea97122c1c4: https://github.com/certbot/certbot/commit/9d736d5c9c939ef5a47b001ef9cb3ea97122c1c4 Signed-off-by: Thibaud CANALE <thican@thican.net> Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-crypt/certbot/certbot-9999.ebuild')
-rw-r--r--app-crypt/certbot/certbot-9999.ebuild43
1 files changed, 31 insertions, 12 deletions
diff --git a/app-crypt/certbot/certbot-9999.ebuild b/app-crypt/certbot/certbot-9999.ebuild
index 729204440566..a8c222abcae4 100644
--- a/app-crypt/certbot/certbot-9999.ebuild
+++ b/app-crypt/certbot/certbot-9999.ebuild
@@ -4,27 +4,46 @@
EAPI=8
PYTHON_COMPAT=( python3_{9..11} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
+DISTUTILS_USE_PEP517=setuptools
-if [[ ${PV} == 9999* ]]; then
- EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+inherit distutils-r1
+
+if [[ "${PV}" == *9999 ]]; then
inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ EGIT_SUBMODULES=()
+ EGIT_CHECKOUT_DIR="${WORKDIR}/${P}"
else
- SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="
+ https://github.com/certbot/certbot/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
fi
-S=${WORKDIR}/${P}/${PN}
-inherit distutils-r1
-
-DESCRIPTION="Let's encrypt client to automate deployment of X.509 certificates"
-HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+DESCRIPTION="Let’s Encrypt client to automate deployment of X.509 certificates"
+HOMEPAGE="
+ https://github.com/certbot/certbot
+ https://letsencrypt.org/
+"
LICENSE="Apache-2.0"
SLOT="0"
IUSE="selinux"
+S="${WORKDIR}/${P}/${PN}"
+
+BDEPEND="
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ )
+"
+
# See certbot/setup.py for acme >= dep
RDEPEND="
>=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
@@ -36,8 +55,8 @@ RDEPEND="
>=dev-python/parsedatetime-2.4[${PYTHON_USEDEP}]
dev-python/pyrfc3339[${PYTHON_USEDEP}]
>=dev-python/pytz-2019.3[${PYTHON_USEDEP}]
- dev-python/zope-component[${PYTHON_USEDEP}]
- dev-python/zope-interface[${PYTHON_USEDEP}]
- selinux? ( sec-policy/selinux-certbot )"
+ selinux? ( sec-policy/selinux-certbot )
+"
+distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
distutils_enable_tests pytest