summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/oclhashcat-lite-bin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/oclhashcat-lite-bin')
-rw-r--r--app-crypt/oclhashcat-lite-bin/Manifest1
-rw-r--r--app-crypt/oclhashcat-lite-bin/metadata.xml11
-rw-r--r--app-crypt/oclhashcat-lite-bin/oclhashcat-lite-bin-0.15.ebuild150
3 files changed, 162 insertions, 0 deletions
diff --git a/app-crypt/oclhashcat-lite-bin/Manifest b/app-crypt/oclhashcat-lite-bin/Manifest
new file mode 100644
index 000000000000..ee8ff31a351c
--- /dev/null
+++ b/app-crypt/oclhashcat-lite-bin/Manifest
@@ -0,0 +1 @@
+DIST oclHashcat-lite-0.15.7z 6026598 SHA256 40fd6f5410e1c0d5d5e7c9d60c173d838289025a2fc36b86690fb26657ed5796 SHA512 b70738a40cdbc5062cb72f1de93a2d29cdd824b7f3cb0f5bc42e3a7e83246d2247385040efe230afffa26ddf26823ecefabf16f31b1925c7460e7cd8933342b8 WHIRLPOOL b53ce94f04dd464fd6727641726aa56620ec6dcf5c557887c7346955b08b33f187b59db27debf98210c477299ef13c8f7334e8c3b2234b27edf0fe97b1438235
diff --git a/app-crypt/oclhashcat-lite-bin/metadata.xml b/app-crypt/oclhashcat-lite-bin/metadata.xml
new file mode 100644
index 000000000000..8006cb0e3265
--- /dev/null
+++ b/app-crypt/oclhashcat-lite-bin/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>crypto</herd>
+<maintainer>
+<email>zerochaos@gentoo.org</email>
+<name>Rick Farina</name>
+</maintainer>
+<use><flag name="virtualcl">Support for Mosix VirtualCL Clustering Platform</flag></use>
+</pkgmetadata>
+
diff --git a/app-crypt/oclhashcat-lite-bin/oclhashcat-lite-bin-0.15.ebuild b/app-crypt/oclhashcat-lite-bin/oclhashcat-lite-bin-0.15.ebuild
new file mode 100644
index 000000000000..caf544ad8bf3
--- /dev/null
+++ b/app-crypt/oclhashcat-lite-bin/oclhashcat-lite-bin-0.15.ebuild
@@ -0,0 +1,150 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils pax-utils
+
+DESCRIPTION="An opencl hash cracker"
+HOMEPAGE="http://hashcat.net/oclhashcat-lite/"
+MY_P="oclHashcat-lite-${PV}"
+SRC_URI="http://hashcat.net/files/${MY_P}.7z"
+
+#license applies to this version per http://hashcat.net/forum/thread-1348.html
+LICENSE="hashcat"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+IUSE_VIDEO_CARDS="video_cards_fglrx
+ video_cards_nvidia"
+
+IUSE="virtualcl ${IUSE_VIDEO_CARDS}"
+
+RDEPEND="sys-libs/zlib
+ video_cards_nvidia? ( >=x11-drivers/nvidia-drivers-310.32 )
+ video_cards_fglrx? ( >=x11-drivers/ati-drivers-13.1 )"
+DEPEND="${RDEPEND}
+ app-arch/p7zip"
+
+S="${WORKDIR}/${MY_P}"
+
+RESTRICT="strip"
+QA_PREBUILT="*Hashcat-lite*.bin"
+
+src_prepare() {
+ if use x86; then
+ rm oclHashcat-lite64.bin || die
+ rm cudaHashcat-lite64.bin || die
+ fi
+ if use amd64; then
+ rm oclHashcat-lite32.bin || die
+ rm cudaHashcat-lite32.bin || die
+ fi
+ if ! use video_cards_fglrx; then
+ rm -r kernels/4098 || die
+ rm oclHashcat-lite*.bin || die
+ fi
+ if ! use video_cards_nvidia; then
+ rm -r kernels/4318 || die
+ rm cudaHashcat-lite*.bin || die
+ fi
+ use virtualcl || { rm vclHashcat-lite* || die; }
+
+ pax-mark r *Hashcat-lite*.bin
+}
+
+src_test() {
+ printf "%02x" ${PV#0.} > "${S}"/eula.accepted
+ if use video_cards_nvidia; then
+ addwrite /dev/nvidia0
+ addwrite /dev/nvidiactl
+ if [ ! -w /dev/nvidia0 ]; then
+ einfo "To run these tests, portage likely must be in the video group."
+ einfo "Please run \"passwd -a portage video\" if the tests will fail"
+ fi
+ if use amd64; then
+ ./cudaHashcat-lite64.bin 6fc33db981c6c55189bbda9625eacd6d
+ elif use x86; then
+ ./cudaHashcat-lite32.bin 6fc33db981c6c55189bbda9625eacd6d
+ fi
+ fi
+ if use video_cards_fglrx; then
+ addwrite /dev/ati
+ if use amd64; then
+ ./oclHashcat-lite64.bin 6fc33db981c6c55189bbda9625eacd6d
+ elif use x86; then
+ ./oclHashcat-lite32.bin 6fc33db981c6c55189bbda9625eacd6d
+ fi
+ fi
+ rm eula.accepted cudaHashcat-lite.restore
+}
+
+src_install() {
+ dodoc docs/*
+ rm -r "${S}"/*.exe "${S}"/*.cmd "${S}"/docs || die
+
+ insinto /opt/${PN}
+ doins -r "${S}"/*
+
+ dodir /opt/bin
+
+ cat <<-EOF > "${ED}"/opt/bin/oclhashcat-lite
+ #! /bin/sh
+ echo "oclHashcat-lite and all related files have been installed in /opt/${PN}"
+ echo "Please run one of the following binaries to use gpu accelerated hashcat:"
+ EOF
+
+ for x in oclHashcat-lite64.bin oclHashcat-lite32.bin cudaHashcat-lite64.bin cudaHashcat-lite32.bin vclHashcat-lite64.bin vclHashcat-lite32.bin
+ do
+ if [ -f "${ED}"/opt/${PN}/${x} ]
+ then
+ case "${x}" in
+ oclHashcat-lite64.bin)
+ echo "echo '64 bit ATI accelerated \"oclHashcat-lite64.bin\"'" >> "${ED}"/opt/bin/oclhashcat-lite
+ ;;
+ oclHashcat-lite32.bin)
+ echo "echo '32 bit ATI accelerated \"oclHashcat-lite32.bin\"'" >> "${ED}"/opt/bin/oclhashcat-lite
+ ;;
+ cudaHashcat-lite64.bin)
+ echo "echo '64 bit NVIDIA accelerated \"cudaHashcat-lite64.bin\"'" >> "${ED}"/opt/bin/oclhashcat-lite
+ ;;
+ cudaHashcat-lite32.bin)
+ echo "echo '32 bit NVIDIA accelerated \"cudaHashcat-lite32.bin\"'" >> "${ED}"/opt/bin/oclhashcat-lite
+ ;;
+ vclHashcat-lite64.bin)
+ echo "echo '64 bit VirtualCL Cluster support \"vclHashcat-lite64.bin\"'" >> "${ED}"/opt/bin/oclhashcat-lite
+ ;;
+ vclHashcat-lite32.bin)
+ echo "echo '32 bit VirtualCL Cluster support \"vclHashcat-lite32.bin\"'" >> "${ED}"/opt/bin/oclhashcat-lite
+ ;;
+ esac
+
+ fperms +x /opt/${PN}/${x}
+
+ cat <<-EOF > "${ED}"/opt/bin/${x}
+ #! /bin/sh
+ cd /opt/${PN}
+ echo "Warning: ${x} is running from /opt/${PN} so be careful of relative paths."
+ exec ./${x} "\$@"
+ EOF
+
+ fperms +x /opt/bin/${x}
+
+ fi
+ done
+
+ fperms +x /opt/bin/oclhashcat-lite
+ fowners -R root:video /opt/${PN}
+ fperms g+w /opt/${PN}
+ einfo "oclhashcat-lite can be run as user if you are in the video group"
+}
+
+pkg_preinst() {
+ #I feel so dirty doing this
+ #first we remove the eula.accepted because it cannot properly handle and empty or old one (crash or doesn't run at all)
+ rm -f "${EROOT}"/opt/${PN}/eula.accepted
+ #next we remove any compiled kernel files as these get built on first run only if they aren't there because there are no timestamp checks
+ rm -f "${EROOT}"/opt/${PN}/kernels/{4318,4098}/"*.kernel"
+ #have mercy on my soul
+}