summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/oclhashcat-plus-bin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/oclhashcat-plus-bin')
-rw-r--r--app-crypt/oclhashcat-plus-bin/Manifest1
-rw-r--r--app-crypt/oclhashcat-plus-bin/metadata.xml11
-rw-r--r--app-crypt/oclhashcat-plus-bin/oclhashcat-plus-bin-0.15.ebuild147
3 files changed, 159 insertions, 0 deletions
diff --git a/app-crypt/oclhashcat-plus-bin/Manifest b/app-crypt/oclhashcat-plus-bin/Manifest
new file mode 100644
index 000000000000..7037fa24213d
--- /dev/null
+++ b/app-crypt/oclhashcat-plus-bin/Manifest
@@ -0,0 +1 @@
+DIST oclHashcat-plus-0.15.7z 71543716 SHA256 545bbaa4ea4fb45a4c4af365e880c56dce8d8bd9c8d73ad2f9cdc16b5df47f14 SHA512 0b11aa805b186a432ee8a9f6ff5823235986d2552fc99b5365150c165bd10232a76408b375887483375cf1e29d8e78de2dadf2e046863061c7ce8722c7591da4 WHIRLPOOL 1a8e52990831ed113c06d702f0de4e5a82f0d3250c630fde8b3b11e5c4d48a0361a1fd8513ce0f183513c3329aa4aa7dd276789f2b04bde44226a16d7e86829a
diff --git a/app-crypt/oclhashcat-plus-bin/metadata.xml b/app-crypt/oclhashcat-plus-bin/metadata.xml
new file mode 100644
index 000000000000..8006cb0e3265
--- /dev/null
+++ b/app-crypt/oclhashcat-plus-bin/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>crypto</herd>
+<maintainer>
+<email>zerochaos@gentoo.org</email>
+<name>Rick Farina</name>
+</maintainer>
+<use><flag name="virtualcl">Support for Mosix VirtualCL Clustering Platform</flag></use>
+</pkgmetadata>
+
diff --git a/app-crypt/oclhashcat-plus-bin/oclhashcat-plus-bin-0.15.ebuild b/app-crypt/oclhashcat-plus-bin/oclhashcat-plus-bin-0.15.ebuild
new file mode 100644
index 000000000000..b45527e33d5a
--- /dev/null
+++ b/app-crypt/oclhashcat-plus-bin/oclhashcat-plus-bin-0.15.ebuild
@@ -0,0 +1,147 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils pax-utils
+
+DESCRIPTION="An opencl multihash cracker"
+HOMEPAGE="http://hashcat.net/oclhashcat-plus/"
+
+MY_P="oclHashcat-plus-${PV}"
+SRC_URI="http://hashcat.net/files/${MY_P}.7z"
+
+LICENSE="hashcat"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+IUSE_VIDEO_CARDS="video_cards_fglrx
+ video_cards_nvidia"
+
+IUSE="virtualcl ${IUSE_VIDEO_CARDS}"
+
+RDEPEND="sys-libs/zlib
+ video_cards_nvidia? ( >=x11-drivers/nvidia-drivers-319.37 )
+ video_cards_fglrx? ( >=x11-drivers/ati-drivers-13.4 )"
+DEPEND="${RDEPEND}
+ app-arch/p7zip"
+
+S="${WORKDIR}/${MY_P}"
+
+RESTRICT="strip"
+QA_PREBUILT="*Hashcat-plus*.bin
+ opt/${PN}/kernels/4098/*.llvmir"
+
+src_prepare() {
+ use x86 && rm *Hashcat-plus64*
+ use amd64 && rm *Hashcat-plus32*
+ use virtualcl || rm vclHashcat-plus*
+
+ if ! use video_cards_fglrx; then
+ rm -r kernels/4098 || die
+ rm oclHashcat-plus*.bin || die
+ fi
+ if ! use video_cards_nvidia; then
+ rm -r kernels/4318 || die
+ rm cudaHashcat-plus*.bin || die
+ fi
+
+ #paxmark goes here so test and install works
+ pax-mark r *Hashcat-plus*.bin
+}
+
+src_test() {
+ printf "%02x" ${PV#0.} > "${S}"/eula.accepted
+ if use video_cards_nvidia; then
+ addwrite /dev/nvidia0
+ addwrite /dev/nvidiactl
+ if [ ! -w /dev/nvidia0 ]; then
+ einfo "To run these tests, portage likely must be in the video group."
+ einfo "Please run \"gpasswd -a portage video\" if the tests will fail"
+ fi
+ if use amd64; then
+ ./cudaHashcat-plus64.bin -a 3 -m 1500 nQCk49SiErOgk || die
+ elif use x86; then
+ ./cudaHashcat-plus32.bin -a 3 -m 1500 nQCk49SiErOgk || die
+ fi
+ fi
+ if use video_cards_fglrx; then
+ addwrite /dev/ati
+ if use amd64; then
+ ./oclHashcat-plus64.bin -a 3 -m 1500 nQCk49SiErOgk || die
+ elif use x86; then
+ ./oclHashcat-plus32.bin -a 3 -m 1500 nQCk49SiErOgk || die
+ fi
+ fi
+ rm eula.accepted hashcat.pot hashcat.dictstat
+}
+
+src_install() {
+ dodoc docs/*
+ rm -r "${S}"/*.exe "${S}"/*.cmd "${S}"/docs || die
+
+ insinto /opt/${PN}
+ doins -r "${S}"/* || die "Copy files failed"
+
+ dodir /opt/bin
+
+ cat <<-EOF > "${ED}"/opt/bin/oclhashcat-plus
+ #! /bin/sh
+ echo "oclHashcat-plus and all related files have been installed in /opt/${PN}"
+ echo "Please run one of the following binaries to use gpu accelerated hashcat:"
+ EOF
+
+ for x in oclHashcat-plus64.bin oclHashcat-plus32.bin cudaHashcat-plus64.bin cudaHashcat-plus32.bin vclHashcat-plus64.bin vclHashcat-plus32.bin
+ do
+ if [ -f "${ED}"/opt/${PN}/${x} ]
+ then
+ case "${x}" in
+ oclHashcat-plus64.bin)
+ echo "echo '64 bit ATI accelerated \"oclHashcat-plus64.bin\"'" >> "${ED}"/opt/bin/oclhashcat-plus
+ ;;
+ oclHashcat-plus32.bin)
+ echo "echo '32 bit ATI accelerated \"oclHashcat-plus32.bin\"'" >> "${ED}"/opt/bin/oclhashcat-plus
+ ;;
+ cudaHashcat-plus64.bin)
+ echo "echo '64 bit NVIDIA accelerated \"cudaHashcat-plus64.bin\"'" >> "${ED}"/opt/bin/oclhashcat-plus
+ ;;
+ cudaHashcat-plus32.bin)
+ echo "echo '32 bit NVIDIA accelerated \"cudaHashcat-plus32.bin\"'" >> "${ED}"/opt/bin/oclhashcat-plus
+ ;;
+ vclHashcat-plus64.bin)
+ echo "echo '64 bit VirtualCL Cluster support \"vclHashcat-plus64.bin\"'" >> "${ED}"/opt/bin/oclhashcat-plus
+ ;;
+ vclHashcat-plus32.bin)
+ echo "echo '32 bit VirtualCL Cluster support \"vclHashcat-plus32.bin\"'" >> "${ED}"/opt/bin/oclhashcat-plus
+ ;;
+ esac
+
+ fperms +x /opt/${PN}/${x}
+
+ cat <<-EOF > "${ED}"/opt/bin/${x}
+ #! /bin/sh
+ cd /opt/${PN}
+ echo "Warning: ${x} is running from /opt/${PN} so be careful of relative paths."
+ exec ./${x} "\$@"
+ EOF
+
+ fperms +x /opt/bin/${x}
+
+ fi
+ done
+
+ fperms +x /opt/bin/oclhashcat-plus
+ fowners -R root:video /opt/${PN}
+ fperms g+w /opt/${PN}
+ einfo "oclhashcat-plus can be run as user if you are in the video group"
+}
+
+pkg_preinst() {
+ #I feel so dirty doing this
+ #first we remove the eula.accepted because it cannot properly handle and empty or old one (crash or doesn't run at all)
+ rm -f "${EROOT}"/opt/${PN}/eula.accepted
+ #next we remove any compiled kernel files as these get built on first run only if they aren't there because there are no timestamp checks
+ rm -f "${EROOT}"/opt/${PN}/kernels/{4318,4098}/"*.kernel"
+ #have mercy on my soul
+}