summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Kurakin <kuraga333@mail.ru>2023-11-02 13:00:43 +0300
committerSam James <sam@gentoo.org>2024-01-20 13:27:21 +0000
commit1087385d058998c93e1f8f75ed44d3833032211a (patch)
tree5ae74a85a5ab389f46f6ac86824c00900a590472 /app-dicts
parentapp-emulation/cloud-init: Update test deps (diff)
downloadgentoo-1087385d058998c93e1f8f75ed44d3833032211a.tar.gz
gentoo-1087385d058998c93e1f8f75ed44d3833032211a.tar.bz2
gentoo-1087385d058998c93e1f8f75ed44d3833032211a.zip
app-dicts/myspell-en: add 20240101, update the copyright year
Closes: https://bugs.gentoo.org/916712 Signed-off-by: Alexander Kurakin <kuraga333@mail.ru> Closes: https://github.com/gentoo/gentoo/pull/33645 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-dicts')
-rw-r--r--app-dicts/myspell-en/Manifest1
-rw-r--r--app-dicts/myspell-en/myspell-en-20240101.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/app-dicts/myspell-en/Manifest b/app-dicts/myspell-en/Manifest
index efc7ddce58ae..ac6158ca5dbc 100644
--- a/app-dicts/myspell-en/Manifest
+++ b/app-dicts/myspell-en/Manifest
@@ -1,2 +1,3 @@
DIST dict-en-20230701_lo.oxt 6102145 BLAKE2B ecf95d76415317fb3dbe4c8e2d30fa37f9d798ae979d83d7e3eaab566264a7db12ed3133e8ed5d1580225171143056edd5189b1685064dab201fadbf59466b7e SHA512 3e495fb7c130d2767d88c4ff21f556c4c64f3739d7b1974355f252329fa526b8ac647a6121f1341396ec9170dda96346463a51b2df06d15e1dcccec4f800593e
DIST dict-en-20230901_lo.oxt 6102109 BLAKE2B d90bb0614217103ad0d4fb4bd411028925311c372047cd88d3075d8480ca1f7d10fa73b3099eea01e06edf22cd85e4cb7aee0e92da89e3e4887a2433ab10bbcb SHA512 76afc82b6d32e1204d36f1fdd602fd4a073b096f49676faab8edd1ab3322f305a4549d07c9e6740463ac4130948dc008181d741d6ebc110bdb87ff1465f03ba2
+DIST dict-en-20240101_lo.oxt 6105115 BLAKE2B 8d81a60fe73adc4b12b0023915aa131eeaf6bbd33f816b05dcb5d0ad40c7806f35c724be1b380904ed62c50c2f3c71925981fdc7bd653f155d7da11383e2ed1e SHA512 cbb6dec8486df96678e0c6c75297645af2455a41194c5232e71ac7a0edcbf2b15115985958529427c57b82a41ca853af86fa4baffbdc8ea50d23f9f48c868940
diff --git a/app-dicts/myspell-en/myspell-en-20240101.ebuild b/app-dicts/myspell-en/myspell-en-20240101.ebuild
new file mode 100644
index 000000000000..e1be4d0fc2a1
--- /dev/null
+++ b/app-dicts/myspell-en/myspell-en-20240101.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit myspell-r2
+
+DESCRIPTION="English dictionaries for myspell/hunspell"
+HOMEPAGE="
+ https://extensions.libreoffice.org/extensions/english-dictionaries
+ https://proofingtoolgui.org
+ https://github.com/marcoagpinto/aoo-mozilla-en-dict
+"
+SRC_URI="https://extensions.libreoffice.org/assets/downloads/41/1704094893/dict-en-20240101_lo.oxt"
+
+LICENSE="BSD MIT LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+PLOCALES=( "en-AU" "en-CA" "en-GB" "en-US" "en-ZA" )
+IUSE+="+l10n_en ${PLOCALES[@]/#/l10n_}"
+REQUIRED_USE="|| ( l10n_en ${PLOCALES[@]/#/l10n_} )"
+
+src_prepare() {
+ if use l10n_en-GB || use l10n_en; then
+ MYSPELL_HYPH+=( "hyph_en_GB.dic" )
+ fi
+ if use l10n_en-US || use l10n_en; then
+ MYSPELL_THES+=(
+ "th_en_US_v2.dat"
+ "th_en_US_v2.idx"
+ )
+ MYSPELL_HYPH+=( "hyph_en_US.dic" )
+ fi
+
+ MYSPELL_DICT=( )
+ for lang in "${PLOCALES[@]}"; do
+ if [[ "${lang}" == "en" ]]; then
+ continue
+ fi
+ local mylinguas="${lang//-/_}"
+ if use "l10n_${lang}" || use l10n_en; then
+ MYSPELL_DICT+=( "${mylinguas}.aff" "${mylinguas}.dic" )
+ else
+ rm "README_${mylinguas}.txt" || die
+ if [[ ${lang} == "en-US" ]]; then
+ rm "README_hyph_en_US.txt" || die
+ fi
+ if [[ ${lang} == "en-GB" ]]; then
+ rm "README_hyph_en_GB.txt" || die
+ rm "README_en_GB_thes.txt" || die
+ fi
+ fi
+ done
+
+ default
+}