summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Kurakin <kuraga333@mail.ru>2022-08-10 18:42:30 +0300
committerJoonas Niilola <juippis@gentoo.org>2022-08-28 11:22:09 +0300
commit24893e6ae17f6a56ae8c85b9a7433a488a0563a4 (patch)
tree7dd8477d6b981a43da3299826e13cdb9b9d7e598 /app-dicts
parentnet-misc/uftp: drop 4.10.1-r1, 5.0-r1 (diff)
downloadgentoo-24893e6ae17f6a56ae8c85b9a7433a488a0563a4.tar.gz
gentoo-24893e6ae17f6a56ae8c85b9a7433a488a0563a4.tar.bz2
gentoo-24893e6ae17f6a56ae8c85b9a7433a488a0563a4.zip
app-dicts/myspell-en: 20220801 version bump
Closes: https://bugs.gentoo.org/864811 Signed-off-by: Alexander Kurakin <kuraga333@mail.ru> Closes: https://github.com/gentoo/gentoo/pull/26812 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-dicts')
-rw-r--r--app-dicts/myspell-en/Manifest1
-rw-r--r--app-dicts/myspell-en/myspell-en-20220801.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/app-dicts/myspell-en/Manifest b/app-dicts/myspell-en/Manifest
index b8f47381cbc3..f3dd4971d53d 100644
--- a/app-dicts/myspell-en/Manifest
+++ b/app-dicts/myspell-en/Manifest
@@ -1,2 +1,3 @@
DIST dict-en-20210601.oxt 6104083 BLAKE2B 192252e85918d3d47167ff9243f70178bc548de3e93152c4139e64ffb013e147fda1fa9c7741ce7bf74b149ec0ab6e001760990cd1ee33dad06fd5e3813ef591 SHA512 c9d791a12aa97d6c2a0928f9f500b22492208b415f877d6b5bd192b5da4c243c32b8d0b7af6b3f5cbfefe6b1c695626db204fc29a922dc4b083538ed144cb472
DIST dict-en-20220701_lo.oxt 6124450 BLAKE2B 0fcd479efcbe9cbf6d2e7d479cb070b32bcf62d6ab6154e64c27d155dbc6d9e7521aee4a76e08288b77b583a7f3273f7817694a3b7fe194861ac64b785188ce8 SHA512 3df04d9ff2edf12d1d717a6b95893cf69e394fe2cbdcba77d0c804b37500feeaf42379d743f3c21cb9c8f8ae17ad2eb990806ea3f9fc8af954bd7b89f3253a4d
+DIST dict-en-20220801_lo.oxt 6098496 BLAKE2B 38d216627665aac750528f29eef09baee43bc4cddfe931f8b6a4fa69442fa0489dc89a996850d93a4fc955953e6d33f7950f2efa2549932dbdb862bb07505ac1 SHA512 4ec52df3fafe6432b522f0b2912b3c046820518fd11079ae46506fc120943c31df46820164c7a786881797ae3508263d34e26c6226d23b861097926d7dd396e4
diff --git a/app-dicts/myspell-en/myspell-en-20220801.ebuild b/app-dicts/myspell-en/myspell-en-20220801.ebuild
new file mode 100644
index 000000000000..a207732d153b
--- /dev/null
+++ b/app-dicts/myspell-en/myspell-en-20220801.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit myspell-r2
+
+DESCRIPTION="English dictionaries for myspell/hunspell"
+HOMEPAGE="https://extensions.libreoffice.org/extensions/english-dictionaries"
+SRC_URI="https://extensions.libreoffice.org/assets/downloads/41/1659325608/dict-en-20220801_lo.oxt"
+
+LICENSE="BSD MIT LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x86-solaris"
+
+PLOCALES=( "en" "en-AU" "en-CA" "en-GB" "en-US" "en-ZA" )
+IUSE+="${PLOCALES[@]/#/l10n_}"
+REQUIRED_USE="|| ( ${IUSE[@]} )"
+
+src_prepare() {
+ if use l10n_en-GB || use l10n_en; then
+ MYSPELL_HYPH+=( "hyph_en_GB.dic" )
+ fi
+ if use l10n_en-US || use l10n_en; then
+ MYSPELL_THES+=(
+ "th_en_US_v2.dat"
+ "th_en_US_v2.idx"
+ )
+ MYSPELL_HYPH+=( "hyph_en_US.dic" )
+ fi
+
+ MYSPELL_DICT=( )
+ for lang in "${PLOCALES[@]}"; do
+ if [[ "${lang}" == "en" ]]; then
+ continue
+ fi
+ local mylinguas="${lang//-/_}"
+ if use "l10n_${lang}" || use l10n_en; then
+ MYSPELL_DICT+=( "${mylinguas}.aff" "${mylinguas}.dic" )
+ else
+ rm "README_${mylinguas}.txt" || die
+ if [[ ${lang} == "en-US" ]]; then
+ rm "README_hyph_en_US.txt" || die
+ fi
+ if [[ ${lang} == "en-GB" ]]; then
+ rm "README_hyph_en_GB.txt" || die
+ rm "README_en_GB_thes.txt" || die
+ fi
+ fi
+ done
+
+ default
+}