summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Kurakin <kuraga333@mail.ru>2023-03-02 20:46:56 +0300
committerViorel Munteanu <ceamac@gentoo.org>2023-03-20 09:27:00 +0200
commit7a6d357f8141b125a399763513501828d7bbff84 (patch)
tree5628f6249d0434d5dd7dff55de52485f54e37e39 /app-dicts
parentdev-java/java-dep-check: fixed opcode version in the java file to be the same... (diff)
downloadgentoo-7a6d357f8141b125a399763513501828d7bbff84.tar.gz
gentoo-7a6d357f8141b125a399763513501828d7bbff84.tar.bz2
gentoo-7a6d357f8141b125a399763513501828d7bbff84.zip
app-dicts/myspell-en: add 20230301
Closes: https://bugs.gentoo.org/899184 Signed-off-by: Alexander Kurakin <kuraga333@mail.ru> Closes: https://github.com/gentoo/gentoo/pull/29912 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'app-dicts')
-rw-r--r--app-dicts/myspell-en/Manifest1
-rw-r--r--app-dicts/myspell-en/myspell-en-20230301.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/app-dicts/myspell-en/Manifest b/app-dicts/myspell-en/Manifest
index 1597b4e5db04..5190969cad8b 100644
--- a/app-dicts/myspell-en/Manifest
+++ b/app-dicts/myspell-en/Manifest
@@ -1,2 +1,3 @@
DIST dict-en-20230101_lo.oxt 6099782 BLAKE2B 5103d0bdf9558184deb8d5d3d9ce00d7b597d4bdf4bfa2fefe3caa68d6e0fa68e2f9295d87c7a8315ba244ccbf007c198cad017aee6faf6590914f63c161cf61 SHA512 d34948b012245c0ad07819d625cd417a85b9edc13b842ad7d3974ed1428af4d2e02020ff0b89cde64a1b844ca8c2a54a7e77f37076e8cc1b38d6a2473da01d7d
DIST dict-en-20230201_lo.oxt 6100214 BLAKE2B c75e6ce32020c10291909191eba888535a56cc4126f2d30c18516a967ca9ca88d7da6d26fa9026c7de75246ee42cc5977fe9db8494e224df3ca484667626d3c0 SHA512 9b9d893ed5061c32c808c91d2078e6f45716dfd3f5590edd02945e50cdb349b23bd35ff0d30aab352b0ddd318993091dcf180d5725016e238e209060eb7180dc
+DIST dict-en-20230301_lo.oxt 6099726 BLAKE2B 3db7fc83af03a42f5f06fb13ff4f78415e0a806d86794b2e76e42f892a76281b9cf178e2c3ccddcc5a42a8d4d804657de5972905a58d817382bc970363763713 SHA512 b64c71ab00e5792411b56212b178a36b72fe10b83fa89db37cbbf3c1f9ce96f8d2c46a58d1773aabbb37a05c1812b59c45cc93fe5a1dd9fc19e0129c764aa251
diff --git a/app-dicts/myspell-en/myspell-en-20230301.ebuild b/app-dicts/myspell-en/myspell-en-20230301.ebuild
new file mode 100644
index 000000000000..69910d320224
--- /dev/null
+++ b/app-dicts/myspell-en/myspell-en-20230301.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit myspell-r2
+
+DESCRIPTION="English dictionaries for myspell/hunspell"
+HOMEPAGE="
+ https://extensions.libreoffice.org/extensions/english-dictionaries
+ https://proofingtoolgui.org
+ https://github.com/marcoagpinto/aoo-mozilla-en-dict
+"
+SRC_URI="https://extensions.libreoffice.org/assets/downloads/41/1677661772/dict-en-20230301_lo.oxt"
+
+LICENSE="BSD MIT LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x86-solaris"
+
+PLOCALES=( "en-AU" "en-CA" "en-GB" "en-US" "en-ZA" )
+IUSE+="+l10n_en ${PLOCALES[@]/#/l10n_}"
+REQUIRED_USE="|| ( l10n_en ${PLOCALES[@]/#/l10n_} )"
+
+src_prepare() {
+ if use l10n_en-GB || use l10n_en; then
+ MYSPELL_HYPH+=( "hyph_en_GB.dic" )
+ fi
+ if use l10n_en-US || use l10n_en; then
+ MYSPELL_THES+=(
+ "th_en_US_v2.dat"
+ "th_en_US_v2.idx"
+ )
+ MYSPELL_HYPH+=( "hyph_en_US.dic" )
+ fi
+
+ MYSPELL_DICT=( )
+ for lang in "${PLOCALES[@]}"; do
+ if [[ "${lang}" == "en" ]]; then
+ continue
+ fi
+ local mylinguas="${lang//-/_}"
+ if use "l10n_${lang}" || use l10n_en; then
+ MYSPELL_DICT+=( "${mylinguas}.aff" "${mylinguas}.dic" )
+ else
+ rm "README_${mylinguas}.txt" || die
+ if [[ ${lang} == "en-US" ]]; then
+ rm "README_hyph_en_US.txt" || die
+ fi
+ if [[ ${lang} == "en-GB" ]]; then
+ rm "README_hyph_en_GB.txt" || die
+ rm "README_en_GB_thes.txt" || die
+ fi
+ fi
+ done
+
+ default
+}