summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEsteve Varela Colominas <esteve.varela@gmail.com>2023-08-15 11:48:48 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-09-01 20:18:34 +0300
commit7e2202957e34becb97e07ca96dfcde8e96935235 (patch)
treed7c1e0267b3c7db5f976a066507b4df9ff521c85 /app-dicts
parentdev-libs/modsecurity: drop old (diff)
downloadgentoo-7e2202957e34becb97e07ca96dfcde8e96935235.tar.gz
gentoo-7e2202957e34becb97e07ca96dfcde8e96935235.tar.bz2
gentoo-7e2202957e34becb97e07ca96dfcde8e96935235.zip
app-dicts/myspell-ca: Bump to 3.0.8
Signed-off-by: Esteve Varela Colominas <esteve.varela@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/32317 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-dicts')
-rw-r--r--app-dicts/myspell-ca/Manifest1
-rw-r--r--app-dicts/myspell-ca/myspell-ca-3.0.8.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/app-dicts/myspell-ca/Manifest b/app-dicts/myspell-ca/Manifest
index 604ab37a9ce0..6e46146b3a7e 100644
--- a/app-dicts/myspell-ca/Manifest
+++ b/app-dicts/myspell-ca/Manifest
@@ -1,2 +1,3 @@
DIST myspell-ca-3.0.7.oxt 4743865 BLAKE2B 019d171f06b8bc5c4e3359213907bdb11f53aaf153899e643d18c0fd2f2c090b05018d0ef32c9f3238730ecad7859423ddb3f7b9081acdda820f29af192c58bc SHA512 75f42a3e1723e75a535f352e72018add4baf0faab4c89208fbd732579f75f040138d9c784fe6e96bbc8194c2416731e920a6950fd9a9a196dbacfd1a03d4512d
DIST myspell-ca-3.0.7_p202305.oxt 5191449 BLAKE2B 91ea6718843e6c273418727d4dd9208b609e18101ed079a675b59fac2e90399b8b2a59cdb559e4ae26d6aa2866a5a533017e278266bb55205ce359a9217ec4ad SHA512 0865d2ff4b7f9280438cf9a0f25adabae43e7d5a28ad26e9de7552413ff097b1df18b5e0fec76dba53924c4d3d13b3ff097c33fee70bd0a27de67498abcd24f6
+DIST myspell-ca-3.0.8.oxt 5217894 BLAKE2B 44b0cfa1bd2ff7aac3fae24be49426b62c77b3f2a40ad68be94859f8b7ee6c9327173346d7433ffbaa6aeba5d808113c664acf951092e5e38f16ad888c383fac SHA512 2d38bd14cbe45c2324c48c87ec85cf733fc0d3c3851621af90c41107615f69ccf4e8f3a27b1e0806139b52437491dff6092ea83a5fa78cb5f0d9c0ab4c2be169
diff --git a/app-dicts/myspell-ca/myspell-ca-3.0.8.ebuild b/app-dicts/myspell-ca/myspell-ca-3.0.8.ebuild
new file mode 100644
index 000000000000..1964d143e0ec
--- /dev/null
+++ b/app-dicts/myspell-ca/myspell-ca-3.0.8.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MYSPELL_DICT=(
+ "ca_ES.aff"
+ "ca_ES.dic"
+ "ca_ES-valencia.aff"
+ "ca_ES-valencia.dic"
+)
+
+MYSPELL_HYPH=(
+ "hyph_ca_ES.dic"
+)
+
+MYSPELL_THES=(
+ "th_ca_ES.idx"
+ "th_ca_ES.dat"
+)
+
+inherit myspell-r2
+
+DESCRIPTION="Catalan dictionaries for myspell/hunspell"
+HOMEPAGE="https://www.softcatala.org/programes/corrector-ortografic-de-catala-general-per-al-libreoffice-i-lapache-openoffice/ https://github.com/Softcatala/catalan-dict-tools/"
+
+MY_PV="${PV%_p*}"
+SRC_URI="https://github.com/Softcatala/catalan-dict-tools/releases/download/v${MY_PV}/ca.${MY_PV}.oxt -> ${P}.oxt"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+src_prepare() {
+ default
+
+ # rename to conform the common naming scheme
+ mv ca.aff ca_ES.aff || die
+ mv ca.dic ca_ES.dic || die
+ mv ca-ES-valencia.aff ca_ES-valencia.aff || die
+ mv ca-ES-valencia.dic ca_ES-valencia.dic || die
+ mv hyph_ca.dic hyph_ca_ES.dic || die
+
+ # remove licenses
+ rm LICENSES-en.txt LLICENCIES-ca.txt || die
+}