summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Kurakin <kuraga333@mail.ru>2023-05-03 13:19:49 +0300
committerJoonas Niilola <juippis@gentoo.org>2023-05-07 10:05:01 +0300
commitc975866c6a1e7ec74b9a220a6fedf5a7c43ea4d6 (patch)
treea9b4956ba90be8309713fe2f69a05d42f0479a57 /app-dicts
parentx11-misc/slop: revbump due to the previous icu change (diff)
downloadgentoo-c975866c6a1e7ec74b9a220a6fedf5a7c43ea4d6.tar.gz
gentoo-c975866c6a1e7ec74b9a220a6fedf5a7c43ea4d6.tar.bz2
gentoo-c975866c6a1e7ec74b9a220a6fedf5a7c43ea4d6.zip
app-dicts/myspell-en: add 20230501
Closes: https://bugs.gentoo.org/905646 Signed-off-by: Alexander Kurakin <kuraga333@mail.ru> Closes: https://github.com/gentoo/gentoo/pull/30855 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-dicts')
-rw-r--r--app-dicts/myspell-en/Manifest1
-rw-r--r--app-dicts/myspell-en/myspell-en-20230501.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/app-dicts/myspell-en/Manifest b/app-dicts/myspell-en/Manifest
index 5c8454903221..a22ae861f87a 100644
--- a/app-dicts/myspell-en/Manifest
+++ b/app-dicts/myspell-en/Manifest
@@ -2,3 +2,4 @@ DIST dict-en-20230101_lo.oxt 6099782 BLAKE2B 5103d0bdf9558184deb8d5d3d9ce00d7b59
DIST dict-en-20230201_lo.oxt 6100214 BLAKE2B c75e6ce32020c10291909191eba888535a56cc4126f2d30c18516a967ca9ca88d7da6d26fa9026c7de75246ee42cc5977fe9db8494e224df3ca484667626d3c0 SHA512 9b9d893ed5061c32c808c91d2078e6f45716dfd3f5590edd02945e50cdb349b23bd35ff0d30aab352b0ddd318993091dcf180d5725016e238e209060eb7180dc
DIST dict-en-20230301_lo.oxt 6099726 BLAKE2B 3db7fc83af03a42f5f06fb13ff4f78415e0a806d86794b2e76e42f892a76281b9cf178e2c3ccddcc5a42a8d4d804657de5972905a58d817382bc970363763713 SHA512 b64c71ab00e5792411b56212b178a36b72fe10b83fa89db37cbbf3c1f9ce96f8d2c46a58d1773aabbb37a05c1812b59c45cc93fe5a1dd9fc19e0129c764aa251
DIST dict-en-20230401_lo.oxt 6100359 BLAKE2B 4a1b8bfa8e7987d0ba957d483ec55d3e1d7912cf56556af11c9ef9941c5725467cdb276363bfec253b788d06dfb9232e733055d74113749f69c73cd092822502 SHA512 79e4c143ebfb20e5b3b2aa3b20c68594ed2bd5d0bc203fc865a9924f2470b3436a502712de1f660cdb0dc9804bd826591a1bb416c6cf00b72e25ab8db3a18377
+DIST dict-en-20230501_lo.oxt 6101115 BLAKE2B f0acdeccf1c4b58b7becabfd61167eb3f4767c5ae3da7ad752645cce49f3f3262219cfb08d373d02b49b67ddaff184102683c2981f4c28eb6b97d92961b07219 SHA512 bc8172f61cf3d18c0ac519f800b39ed69736e085d51251c60c527677552eefd4fe08e5b5e9fdba3a5856605ea44d3831901b00745f00f16146136d6e8376e4ee
diff --git a/app-dicts/myspell-en/myspell-en-20230501.ebuild b/app-dicts/myspell-en/myspell-en-20230501.ebuild
new file mode 100644
index 000000000000..e7f0c955d7d1
--- /dev/null
+++ b/app-dicts/myspell-en/myspell-en-20230501.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit myspell-r2
+
+DESCRIPTION="English dictionaries for myspell/hunspell"
+HOMEPAGE="
+ https://extensions.libreoffice.org/extensions/english-dictionaries
+ https://proofingtoolgui.org
+ https://github.com/marcoagpinto/aoo-mozilla-en-dict
+"
+SRC_URI="https://extensions.libreoffice.org/assets/downloads/41/1682907652/dict-en-20230501_lo.oxt"
+
+LICENSE="BSD MIT LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x86-solaris"
+
+PLOCALES=( "en-AU" "en-CA" "en-GB" "en-US" "en-ZA" )
+IUSE+="+l10n_en ${PLOCALES[@]/#/l10n_}"
+REQUIRED_USE="|| ( l10n_en ${PLOCALES[@]/#/l10n_} )"
+
+src_prepare() {
+ if use l10n_en-GB || use l10n_en; then
+ MYSPELL_HYPH+=( "hyph_en_GB.dic" )
+ fi
+ if use l10n_en-US || use l10n_en; then
+ MYSPELL_THES+=(
+ "th_en_US_v2.dat"
+ "th_en_US_v2.idx"
+ )
+ MYSPELL_HYPH+=( "hyph_en_US.dic" )
+ fi
+
+ MYSPELL_DICT=( )
+ for lang in "${PLOCALES[@]}"; do
+ if [[ "${lang}" == "en" ]]; then
+ continue
+ fi
+ local mylinguas="${lang//-/_}"
+ if use "l10n_${lang}" || use l10n_en; then
+ MYSPELL_DICT+=( "${mylinguas}.aff" "${mylinguas}.dic" )
+ else
+ rm "README_${mylinguas}.txt" || die
+ if [[ ${lang} == "en-US" ]]; then
+ rm "README_hyph_en_US.txt" || die
+ fi
+ if [[ ${lang} == "en-GB" ]]; then
+ rm "README_hyph_en_GB.txt" || die
+ rm "README_en_GB_thes.txt" || die
+ fi
+ fi
+ done
+
+ default
+}