summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-10-18 14:18:24 +0200
committerDavid Seifert <soap@gentoo.org>2019-10-18 14:18:24 +0200
commitef51a27547be21682b697f5ca889ea57b05dd9fb (patch)
tree73481b67212b11c5ba65b841ae519b5c95faff03 /app-doc/autobook
parentapp-crypt/hashalot: Port to EAPI 7 (diff)
downloadgentoo-ef51a27547be21682b697f5ca889ea57b05dd9fb.tar.gz
gentoo-ef51a27547be21682b697f5ca889ea57b05dd9fb.tar.bz2
gentoo-ef51a27547be21682b697f5ca889ea57b05dd9fb.zip
app-doc/autobook: Port to EAPI 7
Closes: https://bugs.gentoo.org/697386 Package-Manager: Portage-2.3.77, Repoman-2.3.17 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-doc/autobook')
-rw-r--r--app-doc/autobook/autobook-1.5.ebuild36
1 files changed, 15 insertions, 21 deletions
diff --git a/app-doc/autobook/autobook-1.5.ebuild b/app-doc/autobook/autobook-1.5.ebuild
index 30c31ea61eaa..5d6cf8494750 100644
--- a/app-doc/autobook/autobook-1.5.ebuild
+++ b/app-doc/autobook/autobook-1.5.ebuild
@@ -1,33 +1,27 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
DESCRIPTION="GNU Autoconf, Automake and Libtool"
HOMEPAGE="https://sourceware.org/autobook/"
-SRC_URI="https://sourceware.org/autobook/${P}.tar.gz
- examples? (
- https://sourceware.org/autobook/foonly-2.0.tar.gz
- https://sourceware.org/autobook/small-2.0.tar.gz
- https://sourceware.org/autobook/hello-2.0.tar.gz
- https://sourceware.org/autobook/convenience-2.0.tar.gz
- )"
+SRC_URI="
+ https://sourceware.org/autobook/${P}.tar.gz
+ https://sourceware.org/autobook/foonly-2.0.tar.gz
+ https://sourceware.org/autobook/small-2.0.tar.gz
+ https://sourceware.org/autobook/hello-2.0.tar.gz
+ https://sourceware.org/autobook/convenience-2.0.tar.gz"
LICENSE="OPL"
SLOT="0"
KEYWORDS="amd64 arm hppa ia64 m68k ppc s390 sh x86"
-IUSE="examples"
-
-DEPEND=""
-RDEPEND=""
src_install() {
- dohtml * || die
- if use examples ; then
- local d
- for d in {convenience,foonly,hello,small}-2.0 ; do
- insinto /usr/share/doc/${PF}/${d}
- doins -r "${WORKDIR}"/${d}/* || die "doins ${d} failed"
- done
- fi
+ local HTML_DOCS=( . )
+ einstalldocs
+
+ local d
+ for d in {convenience,foonly,hello,small}-2.0; do
+ dodoc -r "${WORKDIR}"/${d}
+ done
}