summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2018-10-01 21:10:59 -0500
committerMatthias Maier <tamiko@gentoo.org>2018-10-01 21:13:51 -0500
commit4126e1d5bc12eddbbafaab0e2fb6530526170500 (patch)
tree8a69b2eb7c5ebb5dd0e38136f056c559b70a9157 /app-doc
parentapp-doc/doxygen: update live ebuild (diff)
downloadgentoo-4126e1d5bc12eddbbafaab0e2fb6530526170500.tar.gz
gentoo-4126e1d5bc12eddbbafaab0e2fb6530526170500.tar.bz2
gentoo-4126e1d5bc12eddbbafaab0e2fb6530526170500.zip
app-doc/doxygen: apply llvm patches, fix subslot
- apply llvm patches, thanks to Stephen Newell for the patch. - add missing subslot operator Closes: https://bugs.gentoo.org/666692 Closes: https://bugs.gentoo.org/657556 Package-Manager: Portage-2.3.50, Repoman-2.3.11 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/doxygen/doxygen-1.8.14-r1.ebuild5
-rw-r--r--app-doc/doxygen/files/doxygen-1.8.14-llvm7.patch25
2 files changed, 28 insertions, 2 deletions
diff --git a/app-doc/doxygen/doxygen-1.8.14-r1.ebuild b/app-doc/doxygen/doxygen-1.8.14-r1.ebuild
index 4c7544e05324..dce8fc8f3c85 100644
--- a/app-doc/doxygen/doxygen-1.8.14-r1.ebuild
+++ b/app-doc/doxygen/doxygen-1.8.14-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -30,7 +30,7 @@ RDEPEND="app-text/ghostscript-gpl
media-gfx/graphviz
media-libs/freetype
)
- doxysearch? ( dev-libs/xapian )
+ doxysearch? ( dev-libs/xapian:= )
latex? (
dev-texlive/texlive-bibtexextra
dev-texlive/texlive-fontsextra
@@ -59,6 +59,7 @@ RESTRICT="test"
PATCHES=(
"${FILESDIR}/${PN}-1.8.9.1-empty-line-sigsegv.patch" #454348
"${FILESDIR}/${PN}-1.8.12-link_with_pthread.patch"
+ "${FILESDIR}/${PN}-1.8.14-llvm7.patch" #666692
)
DOCS=( LANGUAGE.HOWTO README.md )
diff --git a/app-doc/doxygen/files/doxygen-1.8.14-llvm7.patch b/app-doc/doxygen/files/doxygen-1.8.14-llvm7.patch
new file mode 100644
index 000000000000..86e6d7999418
--- /dev/null
+++ b/app-doc/doxygen/files/doxygen-1.8.14-llvm7.patch
@@ -0,0 +1,25 @@
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 5c55efae..1ad32b2e 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -262,7 +262,7 @@ if (use_libclang)
+ add_definitions(${LLVM_DEFINITIONS})
+ llvm_map_components_to_libnames(llvm_libs support core option)
+ target_compile_definitions(doxygen PRIVATE ${LLVM_DEFINITIONS})
+- set(CLANG_LIBS libclang clangTooling ${llvm_libs})
++ set(CLANG_LIBS libclang clangTooling clangBasic clangLex ${llvm_libs})
+ endif()
+
+ target_link_libraries(doxygen
+diff --git a/src/clangparser.cpp b/src/clangparser.cpp
+index 77151d6e..2ea15ee2 100644
+--- a/src/clangparser.cpp
++++ b/src/clangparser.cpp
+@@ -4,6 +4,7 @@
+
+ #if USE_LIBCLANG
+ #include <clang-c/Index.h>
++#include "clang/Tooling/CompilationDatabase.h"
+ #include "clang/Tooling/Tooling.h"
+ #include <qfileinfo.h>
+ #include <stdlib.h>