summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-editors/e3/e3-2.8.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-editors/e3/e3-2.8.ebuild')
-rw-r--r--app-editors/e3/e3-2.8.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-editors/e3/e3-2.8.ebuild b/app-editors/e3/e3-2.8.ebuild
new file mode 100644
index 000000000000..b7ed30080e75
--- /dev/null
+++ b/app-editors/e3/e3-2.8.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Very tiny editor in ASM with emacs, pico, wordstar, and vi keybindings"
+HOMEPAGE="http://sites.google.com/site/e3editor/"
+SRC_URI="http://sites.google.com/site/e3editor/Home/${P}.tgz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+RESTRICT="strip"
+
+DEPEND=">=dev-lang/nasm-2.09.04"
+RDEPEND=""
+
+src_prepare() {
+ sed -i 's/-D$(EXMODE)//' Makefile || die
+}
+
+src_compile() {
+ emake -- $(usex amd64 64 32)
+}
+
+src_install() {
+ dobin e3
+ dosym e3 /usr/bin/e3em
+ dosym e3 /usr/bin/e3ne
+ dosym e3 /usr/bin/e3pi
+ dosym e3 /usr/bin/e3vi
+ dosym e3 /usr/bin/e3ws
+
+ newman e3.man e3.1
+ dohtml e3.html
+ dodoc ChangeLog README README_OLD
+}