summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-08-28 04:20:29 +0200
committerManuel Rüger <mrueg@gentoo.org>2015-08-28 04:23:05 +0200
commite31ae64ca383c64789a8078e535628f118a7933d (patch)
tree2aef5e1ba6bf59cfa962235ff901be55f653cde4 /app-editors/nano/nano-2.3.2-r1.ebuild
parentdev-vcs/hg-fast-export: version bump (diff)
downloadgentoo-e31ae64ca383c64789a8078e535628f118a7933d.tar.gz
gentoo-e31ae64ca383c64789a8078e535628f118a7933d.tar.bz2
gentoo-e31ae64ca383c64789a8078e535628f118a7933d.zip
app-editors/nano: Remove old
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'app-editors/nano/nano-2.3.2-r1.ebuild')
-rw-r--r--app-editors/nano/nano-2.3.2-r1.ebuild79
1 files changed, 0 insertions, 79 deletions
diff --git a/app-editors/nano/nano-2.3.2-r1.ebuild b/app-editors/nano/nano-2.3.2-r1.ebuild
deleted file mode 100644
index f5af13c29214..000000000000
--- a/app-editors/nano/nano-2.3.2-r1.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="4"
-
-inherit eutils autotools
-if [[ ${PV} == "9999" ]] ; then
- ESVN_REPO_URI="svn://svn.savannah.gnu.org/nano/trunk/nano"
- inherit subversion autotools
-else
- MY_P=${PN}-${PV/_}
- SRC_URI="http://www.nano-editor.org/dist/v${PV:0:3}/${MY_P}.tar.gz"
-fi
-
-DESCRIPTION="GNU GPL'd Pico clone with more functionality"
-HOMEPAGE="http://www.nano-editor.org/ https://www.gentoo.org/doc/en/nano-basics-guide.xml"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="debug justify +magic minimal ncurses nls slang +spell unicode"
-
-RDEPEND=">=sys-libs/ncurses-5.9-r1[unicode?]
- magic? ( sys-apps/file )
- nls? ( virtual/libintl )
- !ncurses? ( slang? ( sys-libs/slang ) )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
- virtual/pkgconfig"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-2.3.1-ncurses-pkg-config.patch
- epatch "${FILESDIR}"/${PN}-2.3.2-bind-unbind-docs.patch
- epatch "${FILESDIR}"/${PN}-2.3.1-{shell,gentoo}-nanorc.patch
- epatch_user
- eautoreconf
-}
-
-src_configure() {
- eval export ac_cv_{header_magic_h,lib_magic_magic_open}=$(usex magic)
- local myconf=()
- case ${CHOST} in
- *-gnu*|*-uclibc*) myconf+=( "--with-wordbounds" ) ;; #467848
- esac
- econf \
- --bindir="${EPREFIX}"/bin \
- $(use_enable !minimal color) \
- $(use_enable !minimal multibuffer) \
- $(use_enable !minimal nanorc) \
- --disable-wrapping-as-root \
- $(use_enable spell speller) \
- $(use_enable justify) \
- $(use_enable debug) \
- $(use_enable nls) \
- $(use_enable unicode utf8) \
- $(use_enable minimal tiny) \
- $(usex ncurses --without-slang $(use_with slang)) \
- "${myconf[@]}"
-}
-
-src_install() {
- default
- rm -rf "${ED}"/usr/share/nano/man-html
-
- dodoc ChangeLog README doc/nanorc.sample AUTHORS BUGS NEWS TODO
- dohtml doc/faq.html
- insinto /etc
- newins doc/nanorc.sample nanorc
- if ! use minimal ; then
- # Enable colorization by default.
- sed -i \
- -e '/^# include /s:# *::' \
- "${ED}"/etc/nanorc || die
- fi
-
- dodir /usr/bin
- dosym /bin/nano /usr/bin/nano
-}