summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-24 01:45:37 +0100
committerSam James <sam@gentoo.org>2022-08-24 01:45:37 +0100
commit7de3b1f1dd4d3809c68f4d93576cca7e2b60829a (patch)
treea699379ce8279f9096f37bc751a1bd0e0f382134 /app-editors/vile
parentdev-python/yara-python: update Manifest (diff)
downloadgentoo-7de3b1f1dd4d3809c68f4d93576cca7e2b60829a.tar.gz
gentoo-7de3b1f1dd4d3809c68f4d93576cca7e2b60829a.tar.bz2
gentoo-7de3b1f1dd4d3809c68f4d93576cca7e2b60829a.zip
app-editors/vile: add 9.8w
Closes: https://bugs.gentoo.org/848957 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors/vile')
-rw-r--r--app-editors/vile/Manifest1
-rw-r--r--app-editors/vile/vile-9.8w.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-editors/vile/Manifest b/app-editors/vile/Manifest
index b58629ecdc25..00935df1403b 100644
--- a/app-editors/vile/Manifest
+++ b/app-editors/vile/Manifest
@@ -1,2 +1,3 @@
DIST vile-9.8t.tgz 2352119 BLAKE2B fc1c75eba09e8be99945ba0d178fd150576d8108f906afb20dba265adaee9e5bea4869415d3ebceabf0b6b56c147add79e9c7e4fe34d7f4744930c3728e4a4a4 SHA512 4be4e37c7231395cae9236796073c2c3e428f1945283785a931c5d4cce94e0f970efa6634b0f9053679a00f4b4577704ea38ded2129e444b26ee9935a1c3d229
DIST vile-9.8v.tgz 2405398 BLAKE2B cd8753c57ff95c9b420026128fd19b7c689c99500da7cae91d3160dded46aa101b0cae32daeaf0377d4d72a5e526e8e4f25422bbbff2cc5ecdef10b7f04c8b39 SHA512 b752f26148bd4411ab6b31697459a16d8168f79ffad6b3509d6cf5d40611176b833e56f4bac21fe18ecdd256be467ba96ea98149daceab671002df49508eb8d2
+DIST vile-9.8w.tgz 2407322 BLAKE2B 824142c2d081db7c74ab4ce36db63e2d26e82954b32d274477f920b3519c75a249745365f7fb4f117f613c04fddd468394b4636d5f84d9f024eee3cb9c8332ba SHA512 54a96b400f479c633b917691fdab5ec5098ff1d6a6f5390c085635b4449ee7f02988e52c6b442918917455d02d5d74781ed57e4f944422576cf6532caaa446af
diff --git a/app-editors/vile/vile-9.8w.ebuild b/app-editors/vile/vile-9.8w.ebuild
new file mode 100644
index 000000000000..60b94f7129b1
--- /dev/null
+++ b/app-editors/vile/vile-9.8w.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Bump with app-editors/xvile
+
+DESCRIPTION="VI Like Emacs -- yet another full-featured vi clone"
+HOMEPAGE="https://invisible-island.net/vile/"
+SRC_URI="https://invisible-island.net/archives/vile/current/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="perl iconv"
+
+RDEPEND=">=sys-libs/ncurses-5.2:=
+ virtual/libcrypt:=
+ iconv? ( virtual/libiconv )
+ perl? ( dev-lang/perl:= )"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-devel/flex
+ virtual/pkgconfig"
+IDEPEND="app-eselect/eselect-vi"
+
+src_configure() {
+ econf \
+ --disable-stripping \
+ --with-ncurses \
+ --with-pkg-config \
+ $(use_with iconv) \
+ $(use_with perl)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc CHANGES* README doc/*.doc
+ docinto html
+ dodoc doc/*.html
+}
+
+pkg_postinst() {
+ einfo "Updating ${EPREFIX}/usr/bin/vi symlink"
+ eselect vi update --if-unset
+}
+
+pkg_postrm() {
+ einfo "Updating ${EPREFIX}/usr/bin/vi symlink"
+ eselect vi update --if-unset
+}