summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/elscreen
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/elscreen')
-rw-r--r--app-emacs/elscreen/Manifest1
-rw-r--r--app-emacs/elscreen/elscreen-1.4.6-r1.ebuild34
-rw-r--r--app-emacs/elscreen/files/50elscreen-gentoo.el1
-rw-r--r--app-emacs/elscreen/files/elscreen-1.4.6-emacs-24.patch154
-rw-r--r--app-emacs/elscreen/files/elscreen-1.4.6-void-variable-argi.patch71
-rw-r--r--app-emacs/elscreen/metadata.xml19
6 files changed, 280 insertions, 0 deletions
diff --git a/app-emacs/elscreen/Manifest b/app-emacs/elscreen/Manifest
new file mode 100644
index 000000000000..509c3300dec1
--- /dev/null
+++ b/app-emacs/elscreen/Manifest
@@ -0,0 +1 @@
+DIST elscreen-1.4.6.tar.gz 21680 SHA256 134cef5b4ffe75898ca30776b4a4191a9425cbafc650a43e87aae4188adbd650 SHA512 2f19941c9c3e74bbe3912e99f53710f42d33a5b063af99c3907c478d2f571a50a75942519bfcad3bf178585f736bb6e2baf2cdffe8ac66b8e4dbd1b0d881fab2 WHIRLPOOL 8eb4c82941bdee8af3e0e396623efcfae406e254cd8228579e53281311b299f4a0e90e5346292728a099344e0a6206ae0f5163bca428f09d4d2c110b55f70cc8
diff --git a/app-emacs/elscreen/elscreen-1.4.6-r1.ebuild b/app-emacs/elscreen/elscreen-1.4.6-r1.ebuild
new file mode 100644
index 000000000000..e0a1a9d18600
--- /dev/null
+++ b/app-emacs/elscreen/elscreen-1.4.6-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit elisp
+
+DESCRIPTION="Frame configuration management for GNU Emacs modelled after GNU Screen"
+HOMEPAGE="http://www.morishima.net/~naoto/j/software/elscreen/"
+SRC_URI="ftp://ftp.morishima.net/pub/morishima.net/naoto/ElScreen/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 hppa ~ia64 ~ppc ~ppc64 sparc x86"
+IUSE=""
+
+DEPEND=">=app-emacs/apel-10.8-r1"
+RDEPEND="${DEPEND}"
+
+ELISP_PATCHES="${PN}-1.4.6-void-variable-argi.patch ${PN}-1.4.6-emacs-24.patch"
+
+SITEFILE=50${PN}-gentoo.el
+DOCS="ChangeLog README"
+
+pkg_postinst() {
+ elisp-site-regen
+
+ echo
+ elog "ElScreen modifies standard Emacs keybindings and is therefore"
+ elog "no longer loaded from site-gentoo.el. Add the line"
+ elog " (require 'elscreen)"
+ elog "to your ~/.emacs file to enable it on Emacs startup."
+}
diff --git a/app-emacs/elscreen/files/50elscreen-gentoo.el b/app-emacs/elscreen/files/50elscreen-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/elscreen/files/50elscreen-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/elscreen/files/elscreen-1.4.6-emacs-24.patch b/app-emacs/elscreen/files/elscreen-1.4.6-emacs-24.patch
new file mode 100644
index 000000000000..dbcb77557f17
--- /dev/null
+++ b/app-emacs/elscreen/files/elscreen-1.4.6-emacs-24.patch
@@ -0,0 +1,154 @@
+--- elscreen-1.4.6-orig/elscreen.el 2013-05-23 21:31:14.011823000 +1000
++++ elscreen-1.4.6/elscreen.el 2013-10-03 20:55:35.497650931 +1000
+@@ -29,9 +29,9 @@
+ (eval-when-compile
+ (require 'static))
+
+-(static-defconst elscreen-on-xemacs (featurep 'xemacs))
+-(static-defconst elscreen-on-emacs (and (not elscreen-on-xemacs)
+- (>= emacs-major-version 21)))
++(static-defconst elscreen-on-xemacs (featurep 'xemacs)
++ (static-defconst elscreen-on-emacs (and (not elscreen-on-xemacs)
++ (>= emacs-major-version 21))))
+
+
+ ;;; User Customizable Variables:
+@@ -148,7 +148,8 @@
+
+ (static-when elscreen-on-emacs ;; GNU Emacs 21
+ (make-obsolete-variable 'elscreen-tab-display-create-screen
+- 'elscreen-tab-display-control)
++ 'elscreen-tab-display-control
++ "1.4.6")
+ (defcustom elscreen-tab-display-control t
+ "*Non-nil to display control tab at the most left side."
+ :tag "Show/Hide the Control Tab"
+@@ -201,13 +202,13 @@
+ (((class color))
+ (:background "blue" :foreground "black" :underline t)))
+ "Face for tabs other than current screen one."
+- :group 'elscreen))
++ :group 'elscreen)
+
+
+ ;;; Key & Menu bindings:
+
+-(defvar elscreen-map (make-sparse-keymap)
+- "Keymap for ElScreen.")
++ (defvar elscreen-map (make-sparse-keymap)
++ "Keymap for ElScreen."))
+ (define-key elscreen-map "\C-c" 'elscreen-create)
+ (define-key elscreen-map "c" 'elscreen-create)
+ (define-key elscreen-map "C" 'elscreen-clone)
+@@ -899,13 +900,13 @@
+ screen-list-string)
+ (cond
+ ((not (elscreen-screen-live-p screen)) ;; XXX
+- (when (interactive-p)
++ (when (called-interactively-p 'any)
+ (elscreen-message "There is no such screen")))
+ ((null screen-list)
+- (when (interactive-p)
++ (when (called-interactively-p 'any)
+ (elscreen-message "There is only one screen, cannot kill")))
+ ((or
+- (not (interactive-p))
++ (not (called-interactively-p 'any))
+ (yes-or-no-p (format "Really kill screens other than %d? " screen)))
+ (setq screen-list-string (mapconcat
+ (lambda (screen)
+@@ -914,7 +915,7 @@
+ screen-list ","))
+ (elscreen-goto-internal screen)
+ (elscreen-notify-screen-modification 'force-immediately)
+- (when (interactive-p)
++ (when (called-interactively-p 'any)
+ (elscreen-message (format "screen %s killed" screen-list-string)))))
+ screen-list))
+
+@@ -984,7 +985,7 @@
+ (defun elscreen-jump ()
+ "Switch to specified screen."
+ (interactive)
+- (let ((next-screen (string-to-number (string last-command-char))))
++ (let ((next-screen (string-to-number (string last-command-event))))
+ (if (and (<= 0 next-screen) (<= next-screen 9))
+ (elscreen-goto next-screen))))
+ (defalias 'elscreen-jump-0 'elscreen-jump)
+@@ -1046,7 +1047,7 @@
+ (princ (substitute-command-keys
+ (mapconcat 'symbol-value
+ elscreen-help-symbol-list "\n\n")))
+- (print-help-return-message)))
++ (help-print-return-message)))
+
+
+ ;;; Utility Functions
+@@ -1180,7 +1181,7 @@
+ creating one if none already exists."
+ (interactive)
+ (let* ((prompt "Go to the screen with specified buffer: ")
+- (create (or create (interactive-p)))
++ (create (or create (called-interactively-p 'any)))
+ (buffer-name (or (and (bufferp buffer) (buffer-name buffer))
+ (and (stringp buffer) buffer)
+ (and (featurep 'iswitchb)
+@@ -1207,7 +1208,7 @@
+ Use \\[toggle-read-only] to permit editing."
+ (interactive "FFind file read-only in new screen: ")
+ (elscreen-find-file filename)
+- (toggle-read-only 1))
++ (read-only-mode 1))
+
+ (defun elscreen-dired (dirname &optional switches)
+ (interactive (progn
+@@ -1373,27 +1374,28 @@
+ (defvar elscreen-e21-tab-format nil)
+ (make-variable-buffer-local 'elscreen-e21-tab-format)
+
+- (defsubst elscreen-e21-tab-create-keymap (&rest definitions)
+- (let ((keymap (make-sparse-keymap))
+- (key-function-pairs
+- (eval-when-compile
+- (mapcar
+- (lambda (key)
+- (cons key 'ignore))
+- (list 'mouse-1 'mouse-2 'mouse-3
+- 'down-mouse-1 'down-mouse-2 'down-mouse-3
+- 'drag-mouse-1 'drag-mouse-2 'drag-mouse-3)))))
+- (while definitions
+- (set-alist 'key-function-pairs (car definitions) (cadr definitions))
+- (setq definitions (cddr definitions)))
+- (mapc
+- (lambda (key-function-pair)
+- (let ((key (car key-function-pair))
+- (function (cdr key-function-pair)))
+- (define-key keymap (vector 'header-line key) function)))
+- key-function-pairs)
+- keymap))
+-
++ (eval-when-compile
++ (defsubst elscreen-e21-tab-create-keymap (&rest definitions)
++ (let ((keymap (make-sparse-keymap))
++ (key-function-pairs
++ (eval-when-compile
++ (mapcar
++ (lambda (key)
++ (cons key 'ignore))
++ (list 'mouse-1 'mouse-2 'mouse-3
++ 'down-mouse-1 'down-mouse-2 'down-mouse-3
++ 'drag-mouse-1 'drag-mouse-2 'drag-mouse-3)))))
++ (while definitions
++ (set-alist 'key-function-pairs (car definitions) (cadr definitions))
++ (setq definitions (cddr definitions)))
++ (mapc
++ (lambda (key-function-pair)
++ (let ((key (car key-function-pair))
++ (function (cdr key-function-pair)))
++ (define-key keymap (vector 'header-line key) function)))
++ key-function-pairs)
++ keymap)))
++
+ (defsubst elscreen-e21-tab-width ()
+ (if (numberp elscreen-display-tab)
+ elscreen-display-tab
diff --git a/app-emacs/elscreen/files/elscreen-1.4.6-void-variable-argi.patch b/app-emacs/elscreen/files/elscreen-1.4.6-void-variable-argi.patch
new file mode 100644
index 000000000000..b8225070a675
--- /dev/null
+++ b/app-emacs/elscreen/files/elscreen-1.4.6-void-variable-argi.patch
@@ -0,0 +1,71 @@
+--- elscreen.el.orig 2007-12-29 15:12:05.000000000 +0000
++++ elscreen.el
+@@ -1691,6 +1691,10 @@ Use \\[toggle-read-only] to permit editi
+ ("-e" . elscreen-command-line-funcall))))
+
+ (static-when elscreen-on-emacs
++ (cond
++ ; -----------------------
++ ((< emacs-major-version 23) ; emacs22 or prior to
++ (progn
+ (defun elscreen-e21-command-line ()
+ (when (string-match "\\`-" argi)
+ (error "Unknown option `%s'" argi))
+@@ -1703,11 +1707,55 @@ Use \\[toggle-read-only] to permit editi
+ (elscreen-command-line-find-file file file-count line column))
+ (setq line 0)
+ (setq column 0)
+- t)
++ t) ; defun
+
+ (add-hook 'after-init-hook (lambda ()
+ (add-to-list 'command-line-functions
+- 'elscreen-e21-command-line t))))
++ 'elscreen-e21-command-line t)))) ; progn
++ ) ; else
++ ; -----------------------
++ ((= emacs-major-version 23) ; emacs23
++ (progn
++ (defun elscreen-e23-command-line ()
++ (when (string-match "\\`-" argi)
++ (error "Unknown option `%s'" argi))
++ (setq file-count (1+ file-count))
++ (setq inhibit-startup-buffer-menu t)
++ (let* ((file
++ (expand-file-name
++ (command-line-normalize-file-name orig-argi)
++ cl1-dir)))
++ (elscreen-command-line-find-file file file-count cl1-line cl1-column))
++ (setq cl1-line 0)
++ (setq cl1-column 0)
++ t) ; defun
++
++ (add-hook 'after-init-hook (lambda ()
++ (add-to-list 'command-line-functions
++ 'elscreen-e23-command-line t)))) ; progn
++ ) ; else
++ ; -----------------------
++ ((> emacs-major-version 23) ; emacs24 or later
++ (progn
++ (defun elscreen-e24-command-line ()
++ (when (string-match "\\`-" cl1-argi)
++ (error "Unknown option `%s'" cl1-argi))
++ (setq file-count (1+ file-count))
++ (setq inhibit-startup-buffer-menu t)
++ (let* ((file
++ (expand-file-name
++ (command-line-normalize-file-name orig-argi)
++ cl1-dir)))
++ (elscreen-command-line-find-file file file-count cl1-line cl1-column))
++ (setq cl1-line 0)
++ (setq cl1-column 0)
++ t) ; defun
++
++ (add-hook 'after-init-hook (lambda ()
++ (add-to-list 'command-line-functions
++ 'elscreen-e24-command-line t)))) ; progn
++ )
++ )) ; endif (emacs22 or prior to)
+
+ (static-when elscreen-on-xemacs
+ (defadvice command-line-1 (around elscreen-xmas-command-line-1 activate)
diff --git a/app-emacs/elscreen/metadata.xml b/app-emacs/elscreen/metadata.xml
new file mode 100644
index 000000000000..105523fef1a2
--- /dev/null
+++ b/app-emacs/elscreen/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<longdescription>
+ Emacs is more of an "environment" than just an editor, since it has the
+ strong configuration language, emacs-lisp. There are a lot of applications
+ written in emacs-lisp, and you may run many applications on your Emacs at
+ the same time, i.e. e-mail reader, news reader, IRC client, a kind of IDE,
+ etc. These applications likely consist of two or more windows, so when you
+ switch among applications, you may want to save or restore how windows are
+ located (this is called as "window-configuration"). For this purpose, Emacs
+ has two functions, window-configuratin-to-register and jump-to-register, but
+ these are too primitive to use on a daily basis.
+
+ ElScreen provides the ease-to-use environment to save or restore several
+ window-configurations.
+</longdescription>
+</pkgmetadata>