summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2021-07-03 19:16:15 +0200
committerUlrich Müller <ulm@gentoo.org>2021-07-04 14:39:25 +0200
commit1162299d4546ec32ef26bf78816989761b591f4c (patch)
tree63e5b25dc7b1b38f85957256954b59c75877fda7 /app-emacs/helm
parentgames-emulation/stella: add 6.5.3 (diff)
downloadgentoo-1162299d4546ec32ef26bf78816989761b591f4c.tar.gz
gentoo-1162299d4546ec32ef26bf78816989761b591f4c.tar.bz2
gentoo-1162299d4546ec32ef26bf78816989761b591f4c.zip
app-emacs/helm: Don't check for autoload file in emacs-helm.sh
Closes: https://bugs.gentoo.org/800177 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs/helm')
-rw-r--r--app-emacs/helm/files/helm-3.6.0-no-autoload-check.patch24
-rw-r--r--app-emacs/helm/helm-3.6.0-r1.ebuild (renamed from app-emacs/helm/helm-3.6.0.ebuild)6
2 files changed, 27 insertions, 3 deletions
diff --git a/app-emacs/helm/files/helm-3.6.0-no-autoload-check.patch b/app-emacs/helm/files/helm-3.6.0-no-autoload-check.patch
new file mode 100644
index 000000000000..463cc8ccbacf
--- /dev/null
+++ b/app-emacs/helm/files/helm-3.6.0-no-autoload-check.patch
@@ -0,0 +1,24 @@
+https://bugs.gentoo.org/800177
+
+--- helm-3.6.0/emacs-helm.sh
++++ helm-3.6.0/emacs-helm.sh
+@@ -137,19 +137,6 @@
+
+ cd "${0%/*}" || exit 1
+
+-# Check if autoload file exists.
+-# It may be in a different directory if emacs-helm.sh is a symlink.
+-TRUENAME=$(find . -samefile "$0" -printf "%l")
+-if [ ! -z "$TRUENAME" ]; then
+- AUTO_FILE="${TRUENAME%/*}/helm-autoloads.el"
+-else
+- AUTO_FILE="helm-autoloads.el"
+-fi
+-if [ ! -e "$AUTO_FILE" ]; then
+- echo No autoloads found, please run make first to generate autoload file
+- exit 1
+-fi
+-
+
+ cat > $CONF_FILE <<EOF
+ (setq initial-scratch-message (concat initial-scratch-message
diff --git a/app-emacs/helm/helm-3.6.0.ebuild b/app-emacs/helm/helm-3.6.0-r1.ebuild
index f852381e5353..2a631cd56862 100644
--- a/app-emacs/helm/helm-3.6.0.ebuild
+++ b/app-emacs/helm/helm-3.6.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2019 Gentoo Authors
+# Copyright 2019-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -17,6 +17,7 @@ RDEPEND="app-emacs/async
app-emacs/popup"
BDEPEND="${RDEPEND}"
+PATCHES="${FILESDIR}/${P}-no-autoload-check.patch"
SITEFILE="50${PN}-gentoo.el"
src_compile() {
@@ -26,6 +27,5 @@ src_compile() {
src_install() {
elisp_src_install
- exeinto "${SITEETC}/${PN}"
- doexe emacs-helm.sh
+ dobin emacs-helm.sh
}