summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/mcomplete
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/mcomplete')
-rw-r--r--app-emacs/mcomplete/Manifest2
-rw-r--r--app-emacs/mcomplete/files/50mcomplete-gentoo.el7
-rw-r--r--app-emacs/mcomplete/mcomplete-1.10.ebuild19
-rw-r--r--app-emacs/mcomplete/mcomplete-1.5-r1.ebuild19
-rw-r--r--app-emacs/mcomplete/metadata.xml5
5 files changed, 52 insertions, 0 deletions
diff --git a/app-emacs/mcomplete/Manifest b/app-emacs/mcomplete/Manifest
new file mode 100644
index 000000000000..d904e74cbb12
--- /dev/null
+++ b/app-emacs/mcomplete/Manifest
@@ -0,0 +1,2 @@
+DIST mcomplete-1.10.el.xz 10780 SHA256 ba2a047e1c91b35301ae111e6a9e9b21b6fd6a60bda44fc177cda29c0de1e1a4 SHA512 c6ee7a56b63e10769cc2f30a7dcd0a3f085f996adee5944bffdf633b91118dea5e1e5360fde2f556041526133b71d1722d558f951286721a9a691c4f25d9fd17 WHIRLPOOL b7d791f76a5bc465865d337312c4b0512ea0cf74a6a87a9c1162b1b294993189c9ee9e7f2a3133df0ded49df201088795b3f5d08e0a6cc2bb1a1a37ddd4fa7b0
+DIST mcomplete-1.5.el.bz2 10740 SHA256 7702dec75fcc38ea22177d76c1fedf1f69a19439388b52ed25357d14012d0bf7 SHA512 becbf01cee4b8afcb4669eaa1326cf131a298164fd3953bf9257c06bbd0b1089cbb13f26b68bfff48b208fd7111e1f12703f875ed297a20a95ddf8a8c4f029ce WHIRLPOOL 4f4623f1d448ee8404ef065c9accc7d00d26f67c48dbd6aa24bc11b15f1311ba437360e98bd7588a3e614adfa24ce6432aa99ecae611847e2754d086b577c4e7
diff --git a/app-emacs/mcomplete/files/50mcomplete-gentoo.el b/app-emacs/mcomplete/files/50mcomplete-gentoo.el
new file mode 100644
index 000000000000..c9786b6b93cd
--- /dev/null
+++ b/app-emacs/mcomplete/files/50mcomplete-gentoo.el
@@ -0,0 +1,7 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'mcomplete-mode "mcomplete"
+ "Toggle minibuffer completion with prefix and substring matching." t)
+(autoload 'turn-on-mcomplete-mode "mcomplete"
+ "Turn on minibuffer completion with prefix and substring matching." t)
+(autoload 'turn-off-mcomplete-mode "mcomplete"
+ "Turn off minibuffer completion with prefix and substring matching." t)
diff --git a/app-emacs/mcomplete/mcomplete-1.10.ebuild b/app-emacs/mcomplete/mcomplete-1.10.ebuild
new file mode 100644
index 000000000000..879f3baf9fc1
--- /dev/null
+++ b/app-emacs/mcomplete/mcomplete-1.10.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="An improved interface to minibuffer completion"
+HOMEPAGE="http://homepage1.nifty.com/bmonkey/emacs/index-en.html
+ http://www.emacswiki.org/emacs/McompleteMode"
+# taken from http://homepage1.nifty.com/bmonkey/emacs/elisp/mcomplete.el
+SRC_URI="http://dev.gentoo.org/~ulm/distfiles/${P}.el.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/mcomplete/mcomplete-1.5-r1.ebuild b/app-emacs/mcomplete/mcomplete-1.5-r1.ebuild
new file mode 100644
index 000000000000..b4f926b91ecd
--- /dev/null
+++ b/app-emacs/mcomplete/mcomplete-1.5-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="An improved interface to minibuffer completion"
+HOMEPAGE="http://homepage1.nifty.com/bmonkey/emacs/index-en.html
+ http://www.emacswiki.org/emacs/McompleteMode"
+# taken from http://homepage1.nifty.com/bmonkey/emacs/elisp/mcomplete.el
+SRC_URI="mirror://gentoo/${P}.el.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/mcomplete/metadata.xml b/app-emacs/mcomplete/metadata.xml
new file mode 100644
index 000000000000..bc306fe58224
--- /dev/null
+++ b/app-emacs/mcomplete/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+</pkgmetadata>