summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/mldonkey
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/mldonkey')
-rw-r--r--app-emacs/mldonkey/Manifest1
-rw-r--r--app-emacs/mldonkey/files/50mldonkey-gentoo.el18
-rw-r--r--app-emacs/mldonkey/files/mldonkey-0.0.4b-vd.patch121
-rw-r--r--app-emacs/mldonkey/metadata.xml5
-rw-r--r--app-emacs/mldonkey/mldonkey-0.0.4b-r1.ebuild35
5 files changed, 180 insertions, 0 deletions
diff --git a/app-emacs/mldonkey/Manifest b/app-emacs/mldonkey/Manifest
new file mode 100644
index 000000000000..cfcbf3942b18
--- /dev/null
+++ b/app-emacs/mldonkey/Manifest
@@ -0,0 +1 @@
+DIST mldonkey-el-0.0.4b.tar.gz 17442 SHA256 5b14873c45c13bd4da553457798cdd7e552fb00dcba880343a958e63823d3f06 SHA512 3c6a16292968e0f40d319614bfd2a53c9612ec4121c5720f51498d8983f6b944c38fc1d664f1c7ebe1d68653ba62d828fa00092b1a1d278547c225b33f4e740b WHIRLPOOL 07e14a910a6748f2e0faea78aca80ea95758fa598a01317074208dbec60b7c2d262eb2771f1b3764ebb557ed4fcd76446d93de0bed4b45e5952a27822991f857
diff --git a/app-emacs/mldonkey/files/50mldonkey-gentoo.el b/app-emacs/mldonkey/files/50mldonkey-gentoo.el
new file mode 100644
index 000000000000..c3bb77b43aaa
--- /dev/null
+++ b/app-emacs/mldonkey/files/50mldonkey-gentoo.el
@@ -0,0 +1,18 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'mldonkey "mldonkey" "Run the MlDonkey interface." t)
+
+(setq mldonkey-vd-filename-filters
+ '(mldonkey-vd-filename-remove-p20
+ mldonkey-vd-filename-remove-trailing-ws))
+
+(setq mldonkey-vd-sort-functions
+ '((not mldonkey-vd-sort-dl-state)
+ (not mldonkey-vd-sort-dl-percent)))
+
+(setq mldonkey-vd-sort-fin-functions
+ '(mldonkey-vd-sort-dl-number))
+
+(add-hook 'mldonkey-pause-hook 'mldonkey-vd)
+(add-hook 'mldonkey-resume-hook 'mldonkey-vd)
+(add-hook 'mldonkey-commit-hook 'mldonkey-vd)
+(add-hook 'mldonkey-recover-temp-hook 'mldonkey-vd)
diff --git a/app-emacs/mldonkey/files/mldonkey-0.0.4b-vd.patch b/app-emacs/mldonkey/files/mldonkey-0.0.4b-vd.patch
new file mode 100644
index 000000000000..a763643f78b2
--- /dev/null
+++ b/app-emacs/mldonkey/files/mldonkey-0.0.4b-vd.patch
@@ -0,0 +1,121 @@
+Patch by Peter Salvi <vukung@yahoo.com> to conform to MLDonkey 2.9.2,
+taken from http://www.emacswiki.org/cgi-bin/wiki/download/mldonkey-vd.patch.gz
+and ported to mldonkey-0.0.4b
+
+--- mldonkey-el-0.0.4b-orig/mldonkey-vd.el 2005-01-15 20:54:53.000000000 +0100
++++ mldonkey-el-0.0.4b/mldonkey-vd.el 2008-01-03 10:53:18.000000000 +0100
+@@ -107,6 +107,26 @@
+ :group 'mldonkey
+ :type 'boolean)
+
++(defcustom mldonkey-show-release-status nil
++ "Show the release status of a download."
++ :group 'mldonkey
++ :type 'boolean)
++
++(defcustom mldonkey-show-comments nil
++ "Show the number of comments in a download."
++ :group 'mldonkey
++ :type 'boolean)
++
++(defcustom mldonkey-show-user nil
++ "Show the user of a download."
++ :group 'mldonkey
++ :type 'boolean)
++
++(defcustom mldonkey-show-group nil
++ "Show the group of a download."
++ :group 'mldonkey
++ :type 'boolean)
++
+ (defcustom mldonkey-show-filename t
+ "Show the filename of a download."
+ :group 'mldonkey
+@@ -275,6 +295,14 @@
+ ;; FIXME: does a network may contain spaces?
+ "\\[\\(.*?\\)[ \t]*\\([0-9]+\\)\\]" ; network and number
+ "[ \t]+"
++ "\\(R\\|\\-\\)" ; release status
++ "[ \t]+"
++ "\\([0-9]+\\)" ; comments
++ "[ \t]+"
++ "\\([^ \t]+\\)" ; user
++ "[ \t]+"
++ "\\([^ \t]+\\)" ; group
++ "[ \t]+"
+ "\\([^\n]+\\)" ; filename
+ "[ \t]+"
+ "\\([0-9\\.]+\\)" ; percent
+@@ -283,10 +311,9 @@
+ "[ \t]+"
+ "\\([0-9\\.]+\\(?:gb\\|mb\\|kb\\|b\\)\\)" ; size
+ "[ \t]+"
+- ;; "\\([0-9\\.]+\\(?:gb\\|mb\\|kb\\|b\\|[ \t]*chunks\\)\\)" ; left
+- "\\([0-9]+%\\)" ; avail
++ "\\([0-9:\\-]+\\)" ; last seen
+ "[ \t]+"
+- "\\([0-9]+\\):\\([0-9\\-]+\\)" ; age and last seen
++ "\\([0-9:\\-]+\\)" ; age
+ "[ \t]+"
+ "\\([0-9]+\\)/\\([0-9]+\\)" ; active sources and total sources
+ "[ \t]+"
+@@ -454,7 +481,7 @@
+ (setq mldonkey-vd-num-downloading (1+ mldonkey-vd-num-downloading))
+ (add-to-list
+ 'mldonkey-vd-downloading-list
+- (vconcat (mapcar 'mldonkey-vd-get-match (number-sequence 1 13))))))
++ (vconcat (mapcar 'mldonkey-vd-get-match (number-sequence 1 16))))))
+
+
+ (defun mldonkey-vd-get-finished ()
+@@ -523,13 +550,16 @@
+
+ (vector "net "
+ "# "
++ "rel "
++ "com "
++ "user "
++ "gr "
+ "file "
+ "% "
+ "down "
+ "size "
+- "av "
+- "a "
+ "l "
++ "a "
+ "as "
+ "ts "
+ "kb/s "
+@@ -553,8 +583,11 @@
+
+ (vector 'right
+ 'right
+- 'left
++ 'right
+ 'right
++ 'left
++ 'left
++ 'left
+ 'right
+ 'right
+ 'right
+@@ -584,13 +617,16 @@
+
+ (vector mldonkey-show-network
+ mldonkey-show-number
++ mldonkey-show-release-status
++ mldonkey-show-comments
++ mldonkey-show-user
++ mldonkey-show-group
+ mldonkey-show-filename
+ mldonkey-show-percent
+ mldonkey-show-downloaded
+ mldonkey-show-size
+- mldonkey-show-avail
+- mldonkey-show-days
+ mldonkey-show-last-seen
++ mldonkey-show-days
+ mldonkey-show-active-sources
+ mldonkey-show-total-sources
+ mldonkey-show-rate
diff --git a/app-emacs/mldonkey/metadata.xml b/app-emacs/mldonkey/metadata.xml
new file mode 100644
index 000000000000..bc306fe58224
--- /dev/null
+++ b/app-emacs/mldonkey/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+</pkgmetadata>
diff --git a/app-emacs/mldonkey/mldonkey-0.0.4b-r1.ebuild b/app-emacs/mldonkey/mldonkey-0.0.4b-r1.ebuild
new file mode 100644
index 000000000000..f60d7f90c5fa
--- /dev/null
+++ b/app-emacs/mldonkey/mldonkey-0.0.4b-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit elisp
+
+MY_P="${PN}-el-${PV}"
+DESCRIPTION="An Emacs Lisp interface to the MLDonkey core"
+HOMEPAGE="http://www.emacswiki.org/emacs/MlDonkey
+ http://web.archive.org/web/20070107165326/www.physik.fu-berlin.de/~dhansen/mldonkey/"
+SRC_URI="http://www.physik.fu-berlin.de/%7Edhansen/mldonkey/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+
+S="${WORKDIR}/${MY_P}"
+ELISP_PATCHES="${P}-vd.patch"
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile ml*.el
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ ewarn
+ ewarn "If your network gets really slow when you use mldonkey,"
+ ewarn "consider reducing the max number of connections. See bug #50510."
+ ewarn
+ elog "Remember to install net-p2p/mldonkey separately if you want to work"
+ elog "with a local instance."
+}