summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/python-mode
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/python-mode')
-rw-r--r--app-emacs/python-mode/Manifest4
-rw-r--r--app-emacs/python-mode/files/50python-mode-gentoo.el11
-rw-r--r--app-emacs/python-mode/metadata.xml8
-rw-r--r--app-emacs/python-mode/python-mode-5.2.0.ebuild27
-rw-r--r--app-emacs/python-mode/python-mode-6.0.12.ebuild26
-rw-r--r--app-emacs/python-mode/python-mode-6.1.1.ebuild22
-rw-r--r--app-emacs/python-mode/python-mode-6.1.2.ebuild22
7 files changed, 120 insertions, 0 deletions
diff --git a/app-emacs/python-mode/Manifest b/app-emacs/python-mode/Manifest
new file mode 100644
index 000000000000..3ce8be3efc94
--- /dev/null
+++ b/app-emacs/python-mode/Manifest
@@ -0,0 +1,4 @@
+DIST python-mode-5.2.0.tgz 73566 SHA256 84ee977fb7c639bc96cd4e8db0145c7a182489456e4d95a71c3612258b5013ac SHA512 cc31962bd99f76d5a250418ce53a88d6b06282810389d737c383637fba867716a8845a72390c0f87213963647315af34de857e5beb674b921461bf02212b62ca WHIRLPOOL 38e2097f65737bcf0e208bd50b2e34b8d2478160344806b8fcbddebb74f7622ffda97014be551515b996235900a7973fae912930853b1fb362dbb3d763de449d
+DIST python-mode.el-6.0.12.tar.gz 297981 SHA256 85a1ae9b8514330613887ef2cd305cef22c8338192942c09a82c6feab211cd39 SHA512 1b9c86e994d3e607a13cbfe743f5a7b527c00def756ad9a21d04681a755707580919517e5957cb16e64cf31e9204bc56e490e8d11c00d016590d04061a9ecb42 WHIRLPOOL 385296fd06b0c055e25d113f43a5bbf0a0cbc7280234508af7d334d5ae992551f1e4d8dec02eafc4c080650b071b4c36cf4bcc2e2c7ab75b249dacf493b7d3d9
+DIST python-mode.el-6.1.1.tar.gz 313595 SHA256 3eea9722d8407024dcad38b26029992333b357009c9f0d755e2ef7ac06c55a85 SHA512 66226db207421cd33812505e74b986b279534876386fa1b2bc90d58fb35cacfb9fd2790a3dd760becd2797a390d0960035f2ee0d5636c83daf6d0c699d122609 WHIRLPOOL a020e7ce9ceccb8e8d34e88e45bcee668462d286463a6b87ce26c14108c6c66b862bcd78ea7a962ff3f6644a6d4c8ffa06e290eff2a8fb828a21d5f45b44f441
+DIST python-mode.el-6.1.2.tar.gz 330107 SHA256 ae1223bba504c6db08b7a4fc5ef2e148ad861048b4146f5966ddb4ce39e244e3 SHA512 967ad7fdb3503c2dc37df79ba9f45ed7627a5b8e287cae9e8963a259a6568282c16d509e873c7d8b97e4acaafbd71dcec00e5ac71ed695b20ecddca5da20ba96 WHIRLPOOL 05a9f6f60fa0dca16695c1b9fd43fe5c9d9304cc564292412df12d1894f971c119b0d4a57c297684968e58e0bb4a5e9f4472700d7d9fff461f20294c4c5faabe
diff --git a/app-emacs/python-mode/files/50python-mode-gentoo.el b/app-emacs/python-mode/files/50python-mode-gentoo.el
new file mode 100644
index 000000000000..75812316482a
--- /dev/null
+++ b/app-emacs/python-mode/files/50python-mode-gentoo.el
@@ -0,0 +1,11 @@
+(add-to-list 'load-path "@SITELISP@")
+
+(autoload 'python-mode "python-mode" "Major mode for editing Python files." t)
+(autoload 'jython-mode "python-mode" "Major mode for editing Jython files." t)
+(autoload 'py-shell "python-mode"
+ "Start an interactive Python interpreter in another window." t)
+
+(add-to-list 'auto-mode-alist '("\\.py$" . python-mode))
+(add-to-list 'auto-mode-alist '("\\.pyx$" . python-mode))
+(add-to-list 'interpreter-mode-alist '("python" . python-mode))
+(add-to-list 'interpreter-mode-alist '("jython" . jython-mode))
diff --git a/app-emacs/python-mode/metadata.xml b/app-emacs/python-mode/metadata.xml
new file mode 100644
index 000000000000..4c84d631ad42
--- /dev/null
+++ b/app-emacs/python-mode/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<upstream>
+ <remote-id type="launchpad">python-mode</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/app-emacs/python-mode/python-mode-5.2.0.ebuild b/app-emacs/python-mode/python-mode-5.2.0.ebuild
new file mode 100644
index 000000000000..9d3fd3b82b76
--- /dev/null
+++ b/app-emacs/python-mode/python-mode-5.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+inherit elisp
+
+DESCRIPTION="An Emacs major mode for editing Python source"
+HOMEPAGE="https://launchpad.net/python-mode"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tgz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 arm hppa ia64 ppc ppc64 s390 sh x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+S="${WORKDIR}/${PN}"
+# doctest-mode has its own package, pycomplete is not yet ready for production
+ELISP_REMOVE="doctest-mode.el pycomplete.el"
+SITEFILE="50${PN}-gentoo.el"
+DOCS="NEWS"
+
+pkg_postinst() {
+ elisp-site-regen
+ elog "Note that doctest support is split out to app-emacs/doctest-mode."
+}
diff --git a/app-emacs/python-mode/python-mode-6.0.12.ebuild b/app-emacs/python-mode/python-mode-6.0.12.ebuild
new file mode 100644
index 000000000000..740e012612fb
--- /dev/null
+++ b/app-emacs/python-mode/python-mode-6.0.12.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit elisp
+
+MY_P="${PN}.el-${PV}"
+DESCRIPTION="An Emacs major mode for editing Python source"
+HOMEPAGE="https://launchpad.net/python-mode"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${MY_P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 arm hppa ia64 ppc ppc64 s390 sh x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+S="${WORKDIR}/${MY_P}"
+SITEFILE="50${PN}-gentoo.el"
+DOCS="NEWS README"
+
+pkg_postinst() {
+ elisp-site-regen
+ elog "Note that doctest and pymacs are in their own packages,"
+ elog "app-emacs/doctest-mode and app-emacs/pymacs, respectively."
+}
diff --git a/app-emacs/python-mode/python-mode-6.1.1.ebuild b/app-emacs/python-mode/python-mode-6.1.1.ebuild
new file mode 100644
index 000000000000..6ff5dafb5d7e
--- /dev/null
+++ b/app-emacs/python-mode/python-mode-6.1.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit readme.gentoo elisp
+
+MY_P="${PN}.el-${PV}"
+DESCRIPTION="An Emacs major mode for editing Python source"
+HOMEPAGE="https://launchpad.net/python-mode"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${MY_P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+S="${WORKDIR}/${MY_P}"
+SITEFILE="50${PN}-gentoo.el"
+DOCS="NEWS README"
+DOC_CONTENTS="Note that doctest and pymacs are in their own packages,
+ app-emacs/doctest-mode and app-emacs/pymacs, respectively."
diff --git a/app-emacs/python-mode/python-mode-6.1.2.ebuild b/app-emacs/python-mode/python-mode-6.1.2.ebuild
new file mode 100644
index 000000000000..6ff5dafb5d7e
--- /dev/null
+++ b/app-emacs/python-mode/python-mode-6.1.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit readme.gentoo elisp
+
+MY_P="${PN}.el-${PV}"
+DESCRIPTION="An Emacs major mode for editing Python source"
+HOMEPAGE="https://launchpad.net/python-mode"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${MY_P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+S="${WORKDIR}/${MY_P}"
+SITEFILE="50${PN}-gentoo.el"
+DOCS="NEWS README"
+DOC_CONTENTS="Note that doctest and pymacs are in their own packages,
+ app-emacs/doctest-mode and app-emacs/pymacs, respectively."