summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/quilt-el
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/quilt-el')
-rw-r--r--app-emacs/quilt-el/Manifest1
-rw-r--r--app-emacs/quilt-el/files/50quilt-el-gentoo.el7
-rw-r--r--app-emacs/quilt-el/files/quilt-el-0.45.4-header-window.patch10
-rw-r--r--app-emacs/quilt-el/files/quilt-el-0.48.0-tramp-recursion.patch11
-rw-r--r--app-emacs/quilt-el/metadata.xml13
-rw-r--r--app-emacs/quilt-el/quilt-el-0.48.0.ebuild22
6 files changed, 64 insertions, 0 deletions
diff --git a/app-emacs/quilt-el/Manifest b/app-emacs/quilt-el/Manifest
new file mode 100644
index 000000000000..36c6431a0248
--- /dev/null
+++ b/app-emacs/quilt-el/Manifest
@@ -0,0 +1 @@
+DIST quilt-el-0.48.0.tar.gz 13147 SHA256 6c7a80d7f121d4958e989ad98065667d328905b893551f2f3e6f56449506ad24 SHA512 0a198ef0f8354c927c4527bb7a3e99fd6d12f17cbe65c736341c527de440d144581205337163912ce04f83749c31833221cc4153d5736ffec060ad4ade73c694 WHIRLPOOL fc083629a622500105315ab8553f81721b9902132bb63ebf0a4132aee8303ba304a6779cdff9a6db282cc01b3cc66fd30ace4a9e27eb4adb5e795ea34d6e997b
diff --git a/app-emacs/quilt-el/files/50quilt-el-gentoo.el b/app-emacs/quilt-el/files/50quilt-el-gentoo.el
new file mode 100644
index 000000000000..ccdd69d19ab9
--- /dev/null
+++ b/app-emacs/quilt-el/files/50quilt-el-gentoo.el
@@ -0,0 +1,7 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'quilt-mode "quilt"
+ "Toggle quilt-mode. With positive arg, enable quilt-mode." t)
+(autoload 'quilt-hook "quilt"
+ "Enable quilt mode for quilt-controlled files.")
+(add-hook 'find-file-hooks 'quilt-hook)
+(add-hook 'after-revert-hook 'quilt-hook)
diff --git a/app-emacs/quilt-el/files/quilt-el-0.45.4-header-window.patch b/app-emacs/quilt-el/files/quilt-el-0.45.4-header-window.patch
new file mode 100644
index 000000000000..b2f532617f76
--- /dev/null
+++ b/app-emacs/quilt-el/files/quilt-el-0.45.4-header-window.patch
@@ -0,0 +1,10 @@
+--- quilt-el.orig/quilt.el
++++ quilt-el/quilt.el
+@@ -399,6 +399,7 @@
+ (cd quilt-header-directory)
+ (shell-command (concat "EDITOR=cat quilt -r header <" tmp))
+ (kill-buffer (current-buffer))
++ (delete-window)
+ (delete-file tmp)))
+
+ (defvar quilt-header-mode-map (make-keymap))
diff --git a/app-emacs/quilt-el/files/quilt-el-0.48.0-tramp-recursion.patch b/app-emacs/quilt-el/files/quilt-el-0.48.0-tramp-recursion.patch
new file mode 100644
index 000000000000..aa1bf5c97e8d
--- /dev/null
+++ b/app-emacs/quilt-el/files/quilt-el-0.48.0-tramp-recursion.patch
@@ -0,0 +1,11 @@
+--- quilt-el-0.48.0-orig/quilt.el
++++ quilt-el-0.48.0/quilt.el
+@@ -49,7 +49,7 @@
+
+ (defun quilt-find-dir (fn)
+ "Return the top level dir of quilt from FN."
+- (if (or (not fn) (equal fn "/"))
++ (if (or (not fn) (equal fn (file-name-directory fn)))
+ nil
+ (let ((d (file-name-directory fn)))
+ (if (file-accessible-directory-p (concat d "/.pc"))
diff --git a/app-emacs/quilt-el/metadata.xml b/app-emacs/quilt-el/metadata.xml
new file mode 100644
index 000000000000..dc70d2e97d27
--- /dev/null
+++ b/app-emacs/quilt-el/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<longdescription>
+ quilt-el is an Emacs minor mode for quilt. By using this, it becomes easy to
+ edit files controlled by quilt. The main features are as follows:
+ * Automatically detects files that are in a quilt hierarchy and enables
+ itself.
+ * Only files in topmost patch can be writable.
+ * Some handy shortcut keys of quilt commands.
+</longdescription>
+</pkgmetadata>
diff --git a/app-emacs/quilt-el/quilt-el-0.48.0.ebuild b/app-emacs/quilt-el/quilt-el-0.48.0.ebuild
new file mode 100644
index 000000000000..5de0684b57a1
--- /dev/null
+++ b/app-emacs/quilt-el/quilt-el-0.48.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp eutils
+
+DESCRIPTION="Quilt mode for Emacs"
+HOMEPAGE="http://satoru-takeuchi.org/dev/quilt-el/"
+SRC_URI="http://satoru-takeuchi.org/dev/${PN}/download/${P}.tar.gz"
+
+LICENSE="GPL-1+"
+SLOT="0"
+KEYWORDS="amd64 arm ppc ppc64 sparc x86"
+
+RDEPEND="dev-util/quilt"
+
+ELISP_PATCHES="${P}-tramp-recursion.patch
+ ${PN}-0.45.4-header-window.patch"
+SITEFILE="50${PN}-gentoo.el"
+DOCS="README changelog"