summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/wikipedia-mode
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/wikipedia-mode')
-rw-r--r--app-emacs/wikipedia-mode/Manifest1
-rw-r--r--app-emacs/wikipedia-mode/files/50wikipedia-mode-gentoo.el7
-rw-r--r--app-emacs/wikipedia-mode/files/wikipedia-mode-0.5-require-outline-magic.patch6
-rw-r--r--app-emacs/wikipedia-mode/metadata.xml15
-rw-r--r--app-emacs/wikipedia-mode/wikipedia-mode-0.5-r1.ebuild25
5 files changed, 54 insertions, 0 deletions
diff --git a/app-emacs/wikipedia-mode/Manifest b/app-emacs/wikipedia-mode/Manifest
new file mode 100644
index 000000000000..65e3b4332fc9
--- /dev/null
+++ b/app-emacs/wikipedia-mode/Manifest
@@ -0,0 +1 @@
+DIST wikipedia-mode-0.5.el.bz2 14243 SHA256 61941b617f74a6c0da72190e1c83b4b46601062273b70d773c2b0eed1670467f SHA512 d10ddfb13e45fae347fe286df919bd9840ea0c2b38e903b451a9c3b6b6ab768566021d12b898bdc7236d034a89ba582dc8d22827bd3b4d80a0363ab323bd045d WHIRLPOOL bccb1917c2f8230f1d76e0ce28e41fd9fe7ad51c5a66ee26313d525e34e11810b1c6904ddff35851d2c4c1a81cec590fed0730ec1758b7d641c18907df820a9e
diff --git a/app-emacs/wikipedia-mode/files/50wikipedia-mode-gentoo.el b/app-emacs/wikipedia-mode/files/50wikipedia-mode-gentoo.el
new file mode 100644
index 000000000000..1c302088ec70
--- /dev/null
+++ b/app-emacs/wikipedia-mode/files/50wikipedia-mode-gentoo.el
@@ -0,0 +1,7 @@
+(add-to-list 'load-path "@SITELISP@")
+
+(autoload 'wikipedia-mode "wikipedia-mode"
+ "Major mode for editing documents in Wikipedia markup." t)
+
+(add-to-list 'auto-mode-alist '("\\.wiki\\'" . wikipedia-mode))
+(add-to-list 'auto-mode-alist '("/[a-z]+\\.wikipedia\\.org" . wikipedia-mode))
diff --git a/app-emacs/wikipedia-mode/files/wikipedia-mode-0.5-require-outline-magic.patch b/app-emacs/wikipedia-mode/files/wikipedia-mode-0.5-require-outline-magic.patch
new file mode 100644
index 000000000000..caefca757631
--- /dev/null
+++ b/app-emacs/wikipedia-mode/files/wikipedia-mode-0.5-require-outline-magic.patch
@@ -0,0 +1,6 @@
+--- wikipedia-mode.el~
++++ wikipedia-mode.el
+@@ -386,2 +386,3 @@
+ (require 'font-lock)
++(require 'outline-magic)
+
diff --git a/app-emacs/wikipedia-mode/metadata.xml b/app-emacs/wikipedia-mode/metadata.xml
new file mode 100644
index 000000000000..526fe57e8937
--- /dev/null
+++ b/app-emacs/wikipedia-mode/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<longdescription>
+ An Emacs major mode for editing articles in Wikipedia and other wikis
+ running MediaWiki software offline. This mode tweaks Emacs's behavior in
+ several ways to make it easier to edit MediaWiki articles. In particular,
+ wikipedia-mode provides syntax highlighting for MediaWiki markup.
+</longdescription>
+<use>
+ <flag name='outline-magic'>Enable support for outline-mode extensions
+ (<pkg>app-emacs/outline-magic</pkg>)</flag>
+</use>
+</pkgmetadata>
diff --git a/app-emacs/wikipedia-mode/wikipedia-mode-0.5-r1.ebuild b/app-emacs/wikipedia-mode/wikipedia-mode-0.5-r1.ebuild
new file mode 100644
index 000000000000..44a2c1448b84
--- /dev/null
+++ b/app-emacs/wikipedia-mode/wikipedia-mode-0.5-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp eutils
+
+DESCRIPTION="Mode for editing Wikipedia articles off-line"
+HOMEPAGE="http://www.emacswiki.org/emacs/WikipediaMode"
+SRC_URI="mirror://gentoo/${P}.el.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="outline-magic"
+
+DEPEND="outline-magic? ( app-emacs/outline-magic )"
+RDEPEND="${DEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ use outline-magic && epatch "${FILESDIR}/${P}-require-outline-magic.patch"
+}