summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/zenirc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/zenirc')
-rw-r--r--app-emacs/zenirc/Manifest1
-rw-r--r--app-emacs/zenirc/files/50zenirc-gentoo.el2
-rw-r--r--app-emacs/zenirc/metadata.xml15
-rw-r--r--app-emacs/zenirc/zenirc-2.112-r1.ebuild43
4 files changed, 61 insertions, 0 deletions
diff --git a/app-emacs/zenirc/Manifest b/app-emacs/zenirc/Manifest
new file mode 100644
index 000000000000..beaf1bcf8e6a
--- /dev/null
+++ b/app-emacs/zenirc/Manifest
@@ -0,0 +1 @@
+DIST zenirc-2.112.tar.gz 270951 SHA256 05bc964e7845acc0f5be4e385f01ea7da48967ea409a59417507360c155988ab SHA512 3859eb21ad80c8a32e473a272bf2b024039a7a5e4c87a168a71ee2d045f678397daebdce81358be3a50a0dae63c7f8f417600f0964250fdb505def2803a13fac WHIRLPOOL bf90ba7ef0a8f43ca954afb50666c2367a2cea53c34ba7ae7543eaafe3eaebc5229ecd589e616cf9948d57b50fd5ec7680617ce6487a2fd66109cfcd0d7e83f3
diff --git a/app-emacs/zenirc/files/50zenirc-gentoo.el b/app-emacs/zenirc/files/50zenirc-gentoo.el
new file mode 100644
index 000000000000..c52c190d214a
--- /dev/null
+++ b/app-emacs/zenirc/files/50zenirc-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'zenirc "zenirc" "Start ZenIRC" t)
diff --git a/app-emacs/zenirc/metadata.xml b/app-emacs/zenirc/metadata.xml
new file mode 100644
index 000000000000..f4514376b4e9
--- /dev/null
+++ b/app-emacs/zenirc/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<longdescription>
+ ZenIRC is a full-featured scriptable IRC client for the EMACS text editor.
+ It runs on any OS where EMACS supports sockets. It is compatible with GNU
+ Emacs 18.59 and above, and all versions of XEmacs. ZenIRC is Free Software.
+ ZenIRC supports multiple irc sessions in separate buffers. There is a
+ rudimentary command syntax for use within those sessions, but most user
+ preferences and extensions are written and configured in emacs-lisp. Most
+ features are implemented via module extensions. For example, DCC (Direct
+ Client-to-Client) can be enabled at the user's option.
+</longdescription>
+</pkgmetadata>
diff --git a/app-emacs/zenirc/zenirc-2.112-r1.ebuild b/app-emacs/zenirc/zenirc-2.112-r1.ebuild
new file mode 100644
index 000000000000..bbca2a215066
--- /dev/null
+++ b/app-emacs/zenirc/zenirc-2.112-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit readme.gentoo elisp
+
+DESCRIPTION="A full-featured scriptable IRC client for the Emacs text editor"
+HOMEPAGE="http://www.zenirc.org/"
+SRC_URI="ftp://ftp.zenirc.org/pub/zenirc/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_configure() {
+ # econf won't work because of unknown options
+ ./configure --prefix="${EPREFIX}/usr/" || die "configure failed"
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ elisp-install ${PN} src/*.el src/*.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ doinfo doc/zenirc.info
+ dodoc BUGS INSTALL NEWS README TODO
+
+ cd doc
+ docinto doc
+ dodoc 666.conspiracy FAQ README-OLD ctcp.doc irc-operators \
+ server-list tao-of-irc tour.of.irc undernet
+
+ DOC_CONTENTS="Refer to the Info documentation and
+ ${SITELISP}/${PN}/zenirc-example.el for customization hints."
+ readme.gentoo_create_doc
+}