summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2018-11-24 10:51:53 +0100
committerUlrich Müller <ulm@gentoo.org>2018-11-24 11:18:08 +0100
commit03fa9fa397b19a4ff70e92ee533a130168c3d02f (patch)
tree6b4797ea3bb8ea0283bfc535999d3e402ace0ddd /app-emacs
parentprofiles: Drop 17.0 pdftk-related masks (diff)
downloadgentoo-03fa9fa397b19a4ff70e92ee533a130168c3d02f.tar.gz
gentoo-03fa9fa397b19a4ff70e92ee533a130168c3d02f.tar.bz2
gentoo-03fa9fa397b19a4ff70e92ee533a130168c3d02f.zip
app-emacs/popup: Initial import.
Ebuild based on a contribution by <thomas@famsim.de>, with modifications by me. Bug: https://bugs.gentoo.org/670926 Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/popup/Manifest1
-rw-r--r--app-emacs/popup/metadata.xml17
-rw-r--r--app-emacs/popup/popup-0.5.3.ebuild18
3 files changed, 36 insertions, 0 deletions
diff --git a/app-emacs/popup/Manifest b/app-emacs/popup/Manifest
new file mode 100644
index 000000000000..2b55d379564e
--- /dev/null
+++ b/app-emacs/popup/Manifest
@@ -0,0 +1 @@
+DIST popup-el-0.5.3.tar.gz 25785 BLAKE2B e0104a382730203a86c9ce4e1957c652c0e4b0ee84dfa465a94eddf942a249ccf83493bc04f8503e483f14cfeff3649f5264475531c10fe1a9cb1a08376b4499 SHA512 ad67e5d1e4d969151359a54759ae74b2f1107b25b56e7bcedf15995ff6bc0188916fcf5af64ee6ee2b5046e831ebb49c521724e224d7ddb473d3229f3094f5d5
diff --git a/app-emacs/popup/metadata.xml b/app-emacs/popup/metadata.xml
new file mode 100644
index 000000000000..83948483da3a
--- /dev/null
+++ b/app-emacs/popup/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<longdescription>
+ popup.el is a visual popup user interface library for Emacs.
+ This provides a basic API and common UI widgets such as popup
+ tooltips and popup menus.
+</longdescription>
+<stabilize-allarches/>
+<upstream>
+ <remote-id type="github">auto-complete/popup-el</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/app-emacs/popup/popup-0.5.3.ebuild b/app-emacs/popup/popup-0.5.3.ebuild
new file mode 100644
index 000000000000..5d7bcb2cb6ff
--- /dev/null
+++ b/app-emacs/popup/popup-0.5.3.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp
+
+MY_P="${PN}-el-${PV}"
+DESCRIPTION="Visual popup interface library for Emacs"
+HOMEPAGE="https://github.com/auto-complete/popup-el"
+SRC_URI="https://github.com/auto-complete/popup-el/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/${MY_P}"
+DOCS="README.md"