summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-12-25 15:04:03 +0100
committerDavid Seifert <soap@gentoo.org>2017-12-25 15:42:23 +0100
commit0f3630bc76d444c3480f1c9e17f3c201b183afc2 (patch)
tree36a3bc462fb8cd71c221d6baca7db54ee19ec73c /app-emacs
parentapp-doc/devmanual: [QA] Port to git-r3 (diff)
downloadgentoo-0f3630bc76d444c3480f1c9e17f3c201b183afc2.tar.gz
gentoo-0f3630bc76d444c3480f1c9e17f3c201b183afc2.tar.bz2
gentoo-0f3630bc76d444c3480f1c9e17f3c201b183afc2.zip
app-emacs/twittering-mode: [QA] Port to git-r3
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/twittering-mode/twittering-mode-2.0.0.ebuild12
-rw-r--r--app-emacs/twittering-mode/twittering-mode-3.0.0.ebuild12
-rw-r--r--app-emacs/twittering-mode/twittering-mode-9999.ebuild12
3 files changed, 15 insertions, 21 deletions
diff --git a/app-emacs/twittering-mode/twittering-mode-2.0.0.ebuild b/app-emacs/twittering-mode/twittering-mode-2.0.0.ebuild
index b858dc10fc4e..1e802fc217fc 100644
--- a/app-emacs/twittering-mode/twittering-mode-2.0.0.ebuild
+++ b/app-emacs/twittering-mode/twittering-mode-2.0.0.ebuild
@@ -1,15 +1,13 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=6
inherit elisp elisp-common eutils
-if [ "${PV}" = "9999" ]; then
+if [[ ${PV} == *9999 ]]; then
EGIT_REPO_URI="https://github.com/hayamiz/twittering-mode.git"
- inherit git-2
- SRC_URI=""
- KEYWORDS=""
+ inherit git-r3
IUSE="doc"
else
SRC_URI="mirror://sourceforge/twmode/${P}.tar.gz"
@@ -29,7 +27,7 @@ RDEPEND="app-crypt/gnupg"
src_compile() {
elisp-compile twittering-mode.el || die
- [ "${PV}" = "9999" ] && use doc && emake -C doc/manual
+ [[ ${PV} == *9999 ]] && use doc && emake -C doc/manual
}
src_test() {
@@ -37,6 +35,6 @@ src_test() {
}
src_install() {
- [ "${PV}" = "9999" ] && use doc && dodoc doc/manual/twmode/twmode.html
+ [[ ${PV} == *9999 ]] && use doc && dodoc doc/manual/twmode/twmode.html
elisp-install ${PN} twittering-mode.el *.elc || die
}
diff --git a/app-emacs/twittering-mode/twittering-mode-3.0.0.ebuild b/app-emacs/twittering-mode/twittering-mode-3.0.0.ebuild
index b858dc10fc4e..1e802fc217fc 100644
--- a/app-emacs/twittering-mode/twittering-mode-3.0.0.ebuild
+++ b/app-emacs/twittering-mode/twittering-mode-3.0.0.ebuild
@@ -1,15 +1,13 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=6
inherit elisp elisp-common eutils
-if [ "${PV}" = "9999" ]; then
+if [[ ${PV} == *9999 ]]; then
EGIT_REPO_URI="https://github.com/hayamiz/twittering-mode.git"
- inherit git-2
- SRC_URI=""
- KEYWORDS=""
+ inherit git-r3
IUSE="doc"
else
SRC_URI="mirror://sourceforge/twmode/${P}.tar.gz"
@@ -29,7 +27,7 @@ RDEPEND="app-crypt/gnupg"
src_compile() {
elisp-compile twittering-mode.el || die
- [ "${PV}" = "9999" ] && use doc && emake -C doc/manual
+ [[ ${PV} == *9999 ]] && use doc && emake -C doc/manual
}
src_test() {
@@ -37,6 +35,6 @@ src_test() {
}
src_install() {
- [ "${PV}" = "9999" ] && use doc && dodoc doc/manual/twmode/twmode.html
+ [[ ${PV} == *9999 ]] && use doc && dodoc doc/manual/twmode/twmode.html
elisp-install ${PN} twittering-mode.el *.elc || die
}
diff --git a/app-emacs/twittering-mode/twittering-mode-9999.ebuild b/app-emacs/twittering-mode/twittering-mode-9999.ebuild
index b858dc10fc4e..1e802fc217fc 100644
--- a/app-emacs/twittering-mode/twittering-mode-9999.ebuild
+++ b/app-emacs/twittering-mode/twittering-mode-9999.ebuild
@@ -1,15 +1,13 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=6
inherit elisp elisp-common eutils
-if [ "${PV}" = "9999" ]; then
+if [[ ${PV} == *9999 ]]; then
EGIT_REPO_URI="https://github.com/hayamiz/twittering-mode.git"
- inherit git-2
- SRC_URI=""
- KEYWORDS=""
+ inherit git-r3
IUSE="doc"
else
SRC_URI="mirror://sourceforge/twmode/${P}.tar.gz"
@@ -29,7 +27,7 @@ RDEPEND="app-crypt/gnupg"
src_compile() {
elisp-compile twittering-mode.el || die
- [ "${PV}" = "9999" ] && use doc && emake -C doc/manual
+ [[ ${PV} == *9999 ]] && use doc && emake -C doc/manual
}
src_test() {
@@ -37,6 +35,6 @@ src_test() {
}
src_install() {
- [ "${PV}" = "9999" ] && use doc && dodoc doc/manual/twmode/twmode.html
+ [[ ${PV} == *9999 ]] && use doc && dodoc doc/manual/twmode/twmode.html
elisp-install ${PN} twittering-mode.el *.elc || die
}