summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emulation/aqemu
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emulation/aqemu')
-rw-r--r--app-emulation/aqemu/Manifest1
-rw-r--r--app-emulation/aqemu/aqemu-0.8.2-r2.ebuild39
-rw-r--r--app-emulation/aqemu/files/aqemu-0.8.2_desktop_file.patch33
-rw-r--r--app-emulation/aqemu/files/aqemu-0.8.2_qt48_build.patch27
-rw-r--r--app-emulation/aqemu/files/aqemu-0.8.2_sigsev_propertis.patch41
-rw-r--r--app-emulation/aqemu/metadata.xml16
6 files changed, 157 insertions, 0 deletions
diff --git a/app-emulation/aqemu/Manifest b/app-emulation/aqemu/Manifest
new file mode 100644
index 000000000000..0251138dfa5c
--- /dev/null
+++ b/app-emulation/aqemu/Manifest
@@ -0,0 +1 @@
+DIST aqemu-0.8.2.tar.bz2 1025129 SHA256 03c4a95328f78238021168ca4887f9735641f10eb4eb1eff58b08c15b748bf03 SHA512 45f27f82ca307ffc50ea26a57631b47236fd04915274bb00a0720e65859e183d56c3243e0e31d71e5280d0941a9c80c1457b09d393e5c4d4deeb1fea4159459d WHIRLPOOL c5a058883df1424d5d1b2b028fca7fd6aae8b72281060a305a428e63ad5bfb1d062c56c18878b6a279a79953a88c760553a701b5c3346113836eb56ab4a30aa2
diff --git a/app-emulation/aqemu/aqemu-0.8.2-r2.ebuild b/app-emulation/aqemu/aqemu-0.8.2-r2.ebuild
new file mode 100644
index 000000000000..9d38d3c6eae7
--- /dev/null
+++ b/app-emulation/aqemu/aqemu-0.8.2-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit cmake-utils
+
+DESCRIPTION="Graphical interface for QEMU and KVM emulators, using Qt4"
+HOMEPAGE="http://sourceforge.net/projects/aqemu"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="vnc"
+
+DEPEND="${RDEPEND}"
+RDEPEND="app-emulation/qemu
+ vnc? ( net-libs/libvncserver )
+ dev-qt/qtgui:4
+ dev-qt/qttest:4
+ dev-qt/qtxmlpatterns:4"
+
+DOCS="AUTHORS CHANGELOG README TODO"
+PATCHES=(
+ "${FILESDIR}"/aqemu-0.8.2_sigsev_propertis.patch
+ "${FILESDIR}"/aqemu-0.8.2_qt48_build.patch
+ "${FILESDIR}"/aqemu-0.8.2_desktop_file.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ "-DMAN_PAGE_COMPRESSOR="
+ "-DWITHOUT_EMBEDDED_DISPLAY=$(use vnc && echo "OFF" || echo "ON")"
+ )
+
+ cmake-utils_src_configure
+}
diff --git a/app-emulation/aqemu/files/aqemu-0.8.2_desktop_file.patch b/app-emulation/aqemu/files/aqemu-0.8.2_desktop_file.patch
new file mode 100644
index 000000000000..4cf20ea578d0
--- /dev/null
+++ b/app-emulation/aqemu/files/aqemu-0.8.2_desktop_file.patch
@@ -0,0 +1,33 @@
+From 2a0f32e8cb46c8a1c0a33ed151737e5abb5679ed Mon Sep 17 00:00:00 2001
+From: Andrey Rijov <rdron@users.sourceforge.net>
+Date: Mon, 31 Oct 2011 19:38:17 +0400
+Subject: [PATCH] Updated aqemu.desktop file (See bug: 3430317)
+
+---
+ menu_data/aqemu.desktop | 9 +++++----
+ 1 files changed, 5 insertions(+), 4 deletions(-)
+
+--- a/menu_data/aqemu.desktop
++++ b/menu_data/aqemu.desktop
+@@ -1,14 +1,15 @@
+ [Desktop Entry]
+ Encoding=UTF-8
+-Name=AQEMU
+ Exec=aqemu
+ Terminal=false
+ Type=Application
+-Icon=aqemu_48x48.png
++Icon=aqemu_48x48
+ StartupNotify=true
+ Categories=System;Emulator;
+
+-Name[ru]=AQEMU
++Name=AQEMU
++Comment=Virtual machine manager
+ Name[en]=AQEMU
+-Comment[ru]=Управление виртуальными машинами
+ Comment[en]=Virtual machine manager
++Name[ru]=AQEMU
++Comment[ru]=Управление виртуальными машинами
+--
+1.7.4.1
diff --git a/app-emulation/aqemu/files/aqemu-0.8.2_qt48_build.patch b/app-emulation/aqemu/files/aqemu-0.8.2_qt48_build.patch
new file mode 100644
index 000000000000..afd1f0c853d4
--- /dev/null
+++ b/app-emulation/aqemu/files/aqemu-0.8.2_qt48_build.patch
@@ -0,0 +1,27 @@
+From 9b21d88a4f4a681f9e80c11e83e81c976e0fc91e Mon Sep 17 00:00:00 2001
+From: Andrey Rijov <rdron@users.sourceforge.net>
+Date: Sat, 29 Oct 2011 10:20:32 +0400
+Subject: [PATCH 1/1] Fix build error on Qt 4.8
+
+---
+ Embedded_Display/vncview.cpp | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Embedded_Display/vncview.cpp b/Embedded_Display/vncview.cpp
+index 9e105c9..0be5944 100644
+--- a/Embedded_Display/vncview.cpp
++++ b/Embedded_Display/vncview.cpp
+@@ -27,8 +27,8 @@
+ #include <QMessageBox>
+ #include <QInputDialog>
+ #define KMessageBox QMessageBox
+- #define error(parent, message, caption) \
+- critical(parent, caption, message)
++/* #define error(parent, message, caption) \
++ critical(parent, caption, message)*/
+ #else
+ #include "settings.h"
+ #include <KActionCollection>
+--
+1.7.4.1
+
diff --git a/app-emulation/aqemu/files/aqemu-0.8.2_sigsev_propertis.patch b/app-emulation/aqemu/files/aqemu-0.8.2_sigsev_propertis.patch
new file mode 100644
index 000000000000..b7cc5950bd5f
--- /dev/null
+++ b/app-emulation/aqemu/files/aqemu-0.8.2_sigsev_propertis.patch
@@ -0,0 +1,41 @@
+--- a/Device_Manager_Widget.cpp 2011-09-13 21:45:58.883389571 +0200
++++ b/Device_Manager_Widget.cpp 2011-09-13 21:55:01.401866022 +0200
+@@ -981,9 +981,10 @@
+ {
+ if( ui.Devices_List->currentItem()->data(512).toString() == "device" + QString::number(fx) )
+ {
+- finded = true;
+-
+ Storage_Devices.removeAt( fx );
++ ui.Devices_List->takeItem( ui.Devices_List->currentRow() );
++ finded = true;
++ break;
+ }
+ }
+
+@@ -993,10 +994,24 @@
+ "Incorrect Device!" );
+ return;
+ }
++ else
++ {
++ // Rename items
++ for( int ix = 0, count = 0; ix < ui.Devices_List->count(); ++ix )
++ {
++ if( ui.Devices_List->item(ix)->data(512).toString().contains("device") )
++ {
++ ui.Devices_List->item(ix)->setData( 512, QString("device%1").arg(count) );
++ ++count;
++ }
++ }
++
++ emit Device_Changet();
++ return;
++ }
+ }
+
+ ui.Devices_List->takeItem( ui.Devices_List->currentRow() );
+-
+ emit Device_Changet();
+ }
+
diff --git a/app-emulation/aqemu/metadata.xml b/app-emulation/aqemu/metadata.xml
new file mode 100644
index 000000000000..25667e2ea9cd
--- /dev/null
+++ b/app-emulation/aqemu/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>maksbotan@gentoo.org</email>
+ <description>Proxy maintainer (CC on bugs)</description>
+ </maintainer>
+ <maintainer>
+ <email>andreis.vinogradovs@gmail.com</email>
+ <description>Proxied maintainer (assign bugs)</description>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">aqemu</remote-id>
+ </upstream>
+</pkgmetadata>