summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-05 22:54:27 +0000
committerSam James <sam@gentoo.org>2021-04-05 22:59:27 +0000
commit95077ec9cfbd129b298cdd20f78ec3b48dc655a7 (patch)
treed3e251d9bef86a661e47950b08e51fc902cc19d7 /app-emulation/aqemu
parentnet-libs/kdsoap-ws-discovery-client: x86 stable (bug #774219) (diff)
downloadgentoo-95077ec9cfbd129b298cdd20f78ec3b48dc655a7.tar.gz
gentoo-95077ec9cfbd129b298cdd20f78ec3b48dc655a7.tar.bz2
gentoo-95077ec9cfbd129b298cdd20f78ec3b48dc655a7.zip
app-emulation/aqemu: port to cmake.eclass (from cmake-utils)
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-emulation/aqemu')
-rw-r--r--app-emulation/aqemu/aqemu-0.9.2.ebuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/app-emulation/aqemu/aqemu-0.9.2.ebuild b/app-emulation/aqemu/aqemu-0.9.2.ebuild
index 85102613981e..86008228bc21 100644
--- a/app-emulation/aqemu/aqemu-0.9.2.ebuild
+++ b/app-emulation/aqemu/aqemu-0.9.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="Graphical interface for QEMU and KVM emulators, using Qt5"
HOMEPAGE="https://sourceforge.net/projects/aqemu"
@@ -14,23 +14,25 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE="vnc"
-RDEPEND="app-emulation/qemu
+RDEPEND="
+ app-emulation/qemu
dev-qt/qtcore:5
dev-qt/qtnetwork:5
dev-qt/qtprintsupport:5
dev-qt/qttest:5
dev-qt/qtwidgets:5
- vnc? ( net-libs/libvncserver )"
+ vnc? ( net-libs/libvncserver )
+"
DEPEND="${RDEPEND}"
-DOCS=( AUTHORS CHANGELOG README TODO )
+#DOCS=( AUTHORS CHANGELOG README TODO )
PATCHES=( "${FILESDIR}/${PN}-0.9.2-qtbindir.patch" )
src_configure() {
local mycmakeargs=(
- "-DMAN_PAGE_COMPRESSOR="
- "-DWITHOUT_EMBEDDED_DISPLAY=$(usex vnc "OFF" "ON")"
+ -DMAN_PAGE_COMPRESSOR=""
+ -DWITHOUT_EMBEDDED_DISPLAY=$(usex vnc OFF ON)
)
- cmake-utils_src_configure
+ cmake_src_configure
}