summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2019-07-18 12:33:04 -0700
committerZac Medico <zmedico@gentoo.org>2019-07-18 12:48:23 -0700
commit602c4d6a74f7a99e3764294238d88ac4f706810a (patch)
tree0f366eaa82d81c39fca8a887ae8c5b32dcbfb213 /app-emulation/conmon
parentdev-ros/tf2: fix build with boost 1.70. (diff)
downloadgentoo-602c4d6a74f7a99e3764294238d88ac4f706810a.tar.gz
gentoo-602c4d6a74f7a99e3764294238d88ac4f706810a.tar.bz2
gentoo-602c4d6a74f7a99e3764294238d88ac4f706810a.zip
app-emulation/conmon: Bump to version 0.3.0
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-emulation/conmon')
-rw-r--r--app-emulation/conmon/Manifest1
-rw-r--r--app-emulation/conmon/conmon-0.3.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/app-emulation/conmon/Manifest b/app-emulation/conmon/Manifest
index 8b116b37d32d..a74a6bac540a 100644
--- a/app-emulation/conmon/Manifest
+++ b/app-emulation/conmon/Manifest
@@ -1 +1,2 @@
DIST conmon-0.2.0.tar.gz 48349 BLAKE2B f61d1750437102c3772669ac8cff75204bf6811a221212cb7127a439b57b70afacb460f4128413e242ccceb0fe44c417dcd0a7f08536f272131704f3a6cbd599 SHA512 81b6eb88a473c6b4e349e18ba48682dd15f5f1ad841d2ca6bead8b5f9b418dd20832a855a1c8d81ac77562d00cb6e5852aab4f6f4ce15f099ca63a0a3f432ec8
+DIST conmon-0.3.0.tar.gz 49021 BLAKE2B ca753f8fe0801cef4e392e2f60e58c51100628f0576c46d139c9c9827a927970ec63bb0aaebce6ac6ffaedae75b141730833b8adcafc8d9777900d96319edff3 SHA512 9a60f3eace596a8d12dc950597a9e3619a6728bf4555bb1636da3ac8ed8a6bc2ae28471cba9c7c3ad04b61a24aa4bbd28242a22940240bf27babb834031deea4
diff --git a/app-emulation/conmon/conmon-0.3.0.ebuild b/app-emulation/conmon/conmon-0.3.0.ebuild
new file mode 100644
index 000000000000..72995a2d2822
--- /dev/null
+++ b/app-emulation/conmon/conmon-0.3.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KEYWORDS="~amd64"
+DESCRIPTION="An OCI container runtime monitor"
+HOMEPAGE="https://github.com/containers/conmon"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="systemd"
+EGIT_COMMIT="8455ce1ef385120deb827d0f0588c04357bad4c4"
+SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+RDEPEND="dev-libs/glib:=
+ systemd? ( sys-apps/systemd:= )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ if ! use systemd; then
+ sed -e 's| pkg-config --exists libsystemd-journal | false |' \
+ -e 's| pkg-config --exists libsystemd | false |' \
+ -i Makefile || die
+ fi
+}
+
+src_compile() {
+ emake GIT_COMMIT="${EGIT_COMMIT}" \
+ all
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ PREFIX="/usr" \
+ install
+ dodir /usr/libexec/podman
+ ln "${ED}/usr/"{bin,libexec/podman}/conmon || die
+ dodoc README.md
+}