summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-04-14 10:50:07 +0200
committerMichał Górny <mgorny@gentoo.org>2019-04-14 10:50:08 +0200
commitcde8e8b9498d4159c3cd490d0f7d3dd77b0c98d4 (patch)
treef0c4edcc0288431c380cefede0daff1957d32d5b /app-emulation/grub-xen-host
parentpackage.mask: Last rite app-text/active-dvi (diff)
downloadgentoo-cde8e8b9498d4159c3cd490d0f7d3dd77b0c98d4.tar.gz
gentoo-cde8e8b9498d4159c3cd490d0f7d3dd77b0c98d4.tar.bz2
gentoo-cde8e8b9498d4159c3cd490d0f7d3dd77b0c98d4.zip
app-emulation/grub-xen-host: Replace STRIP_MASK with RESTRICT=strip
While at it, replace QA* with RESTRICT=binchecks and add missing ||die. Closes: https://bugs.gentoo.org/651420 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-emulation/grub-xen-host')
-rw-r--r--app-emulation/grub-xen-host/grub-xen-host-1.0.ebuild12
1 files changed, 4 insertions, 8 deletions
diff --git a/app-emulation/grub-xen-host/grub-xen-host-1.0.ebuild b/app-emulation/grub-xen-host/grub-xen-host-1.0.ebuild
index 8fe09f145e0f..9150a04e8c80 100644
--- a/app-emulation/grub-xen-host/grub-xen-host-1.0.ebuild
+++ b/app-emulation/grub-xen-host/grub-xen-host-1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -18,22 +18,18 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}"
-STRIP_MASK="usr/libexec/xen/bin/grub-x86_64-xen.bin"
-QA_EXECSTACK="usr/libexec/xen/bin/grub-x86_64-xen.bin"
-QA_WX_LOAD="usr/libexec/xen/bin/grub-x86_64-xen.bin"
-QA_PRESTRIPPED="usr/libexec/xen/bin/grub-x86_64-xen.bin"
-RESTRICT="test"
+RESTRICT="binchecks strip test"
src_configure() {
:
}
src_compile() {
- cat > "${S}/grub-bootstrap.cfg" <<- EOF
+ cat > "${S}/grub-bootstrap.cfg" <<- EOF || die
normal (memdisk)/grub.cfg
EOF
- cat > "${S}/grub.cfg" <<- EOF
+ cat > "${S}/grub.cfg" <<- EOF || die
if search -s -f /boot/xen/pvboot-x86_64.elf ; then
echo "Chainloading (${root})/boot/xen/pvboot-x86_64.elf"
multiboot "/boot/xen/pvboot-x86_64.elf"