summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emulation/libvirt-glib
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emulation/libvirt-glib')
-rw-r--r--app-emulation/libvirt-glib/Manifest2
-rw-r--r--app-emulation/libvirt-glib/libvirt-glib-0.2.0.ebuild54
-rw-r--r--app-emulation/libvirt-glib/libvirt-glib-0.2.1.ebuild53
-rw-r--r--app-emulation/libvirt-glib/metadata.xml10
4 files changed, 119 insertions, 0 deletions
diff --git a/app-emulation/libvirt-glib/Manifest b/app-emulation/libvirt-glib/Manifest
new file mode 100644
index 000000000000..d7bb12e00452
--- /dev/null
+++ b/app-emulation/libvirt-glib/Manifest
@@ -0,0 +1,2 @@
+DIST libvirt-glib-0.2.0.tar.gz 836245 SHA256 30b7e0f224f9cdcf34c1b05b08803cb617d057613ee96395ae517f4ee6c44a0b SHA512 23b698fe297247dd5ce06d9e37eed2025064ab76a52f008cb89cd835364a52c8fe60ae535f68e67fb6c3454d41328dd77c392efd594a3fb1a237d1beb25d19ae WHIRLPOOL 6ef50cc740fa1b43dafc4666ac221bb57312dd937ee693bd12e582e3cec784a5c7a5d22e3c15cc369ac0a24ae26ce64edc69d2c4b55fc2ea83a8e350bc8003ab
+DIST libvirt-glib-0.2.1.tar.gz 844657 SHA256 d856d37b708bc8bf9e6ac294edca7a53f2baa6d857c6f5859be58517a714a2fb SHA512 bd38b5c415f65bd6e8824d419c787afdd43aa322f03045f517f9bae88575de1a0975f0340b24bf776421eeb54632227d798e801a1611ce932878ad7bace3adfb WHIRLPOOL 99408b22553d8b4bea5df75750aea2339800ad45b7497eae1afdc79e11be256f0e79d29fe879ef4bc8992817178850058ee361fa4ac5a4b2213f09a6fa825cb2
diff --git a/app-emulation/libvirt-glib/libvirt-glib-0.2.0.ebuild b/app-emulation/libvirt-glib/libvirt-glib-0.2.0.ebuild
new file mode 100644
index 000000000000..1bde31326955
--- /dev/null
+++ b/app-emulation/libvirt-glib/libvirt-glib-0.2.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+VALA_MIN_API_VERSION="0.14"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 python-single-r1 vala
+
+DESCRIPTION="GLib and GObject mappings for libvirt"
+HOMEPAGE="http://libvirt.org/git/?p=libvirt-glib.git"
+SRC_URI="ftp://libvirt.org/libvirt/glib/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="+introspection python +vala"
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+ vala? ( introspection )
+"
+
+# https://bugzilla.redhat.com/show_bug.cgi?id=1093633
+RESTRICT="test"
+
+RDEPEND="
+ dev-libs/libxml2:2
+ >=app-emulation/libvirt-0.9.10:=
+ >=dev-libs/glib-2.38.0:2
+ introspection? ( >=dev-libs/gobject-introspection-0.10.8:= )
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-test-coverage \
+ --disable-static \
+ $(use_enable introspection) \
+ $(use_enable vala) \
+ $(use_with python)
+}
diff --git a/app-emulation/libvirt-glib/libvirt-glib-0.2.1.ebuild b/app-emulation/libvirt-glib/libvirt-glib-0.2.1.ebuild
new file mode 100644
index 000000000000..41e5fa80a899
--- /dev/null
+++ b/app-emulation/libvirt-glib/libvirt-glib-0.2.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 python-single-r1 vala
+
+DESCRIPTION="GLib and GObject mappings for libvirt"
+HOMEPAGE="http://libvirt.org/git/?p=libvirt-glib.git"
+SRC_URI="ftp://libvirt.org/libvirt/glib/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+introspection python +vala"
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+ vala? ( introspection )
+"
+
+# https://bugzilla.redhat.com/show_bug.cgi?id=1093633
+RESTRICT="test"
+
+RDEPEND="
+ dev-libs/libxml2:2
+ >=app-emulation/libvirt-0.9.10:=
+ >=dev-libs/glib-2.38.0:2
+ introspection? ( >=dev-libs/gobject-introspection-0.10.8:= )
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-test-coverage \
+ --disable-static \
+ $(use_enable introspection) \
+ $(use_enable vala) \
+ $(use_with python)
+}
diff --git a/app-emulation/libvirt-glib/metadata.xml b/app-emulation/libvirt-glib/metadata.xml
new file mode 100644
index 000000000000..670adf61506f
--- /dev/null
+++ b/app-emulation/libvirt-glib/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+<maintainer>
+ <email>tamiko@gentoo.org</email>
+ <name>Matthias Maier</name>
+ <description>Please CC me on bugs</description>
+</maintainer>
+</pkgmetadata>