summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2021-04-30 09:47:03 +0300
committerJoonas Niilola <juippis@gentoo.org>2021-04-30 10:01:30 +0300
commit8b4b75e0c921746ee6c4a4b1cb93bedcae1e30d1 (patch)
treeea51394e6865c88fe6f7848419ad65e06eb6c064 /app-emulation/lxc
parentdev-libs/raft: bump to 0.10.1 (diff)
downloadgentoo-8b4b75e0c921746ee6c4a4b1cb93bedcae1e30d1.tar.gz
gentoo-8b4b75e0c921746ee6c4a4b1cb93bedcae1e30d1.tar.bz2
gentoo-8b4b75e0c921746ee6c4a4b1cb93bedcae1e30d1.zip
app-emulation/lxc: bump to 4.0.7
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-emulation/lxc')
-rw-r--r--app-emulation/lxc/Manifest2
-rw-r--r--app-emulation/lxc/lxc-4.0.7.ebuild174
2 files changed, 176 insertions, 0 deletions
diff --git a/app-emulation/lxc/Manifest b/app-emulation/lxc/Manifest
index 3db082ff7623..6a74af90230e 100644
--- a/app-emulation/lxc/Manifest
+++ b/app-emulation/lxc/Manifest
@@ -1,2 +1,4 @@
DIST lxc-4.0.6.tar.gz 1363162 BLAKE2B e2d9d281cf521575aeecefbcba0c7b7f336ab73193be94e760b37eb6f3423ec3520f194549def6f64c1662f22b7df5a03dfc6b4e6dac1bf229c5f726f51b4d43 SHA512 98514796ef2091a291516ed7fde737df07ccfe374a0f8b4314e0ee992837e98ed02aa9f7809f8808a2f5ee1c7ae2dcea163531cdaedbb577211eeb9beff90c15
DIST lxc-4.0.6.tar.gz.asc 833 BLAKE2B 04b6bda0ed52a6ab8eebde4d3d5f1f6cb19eea017ae989d47323831d467324f99801b40c3bb70f00d7521753a298e6fa339f0da039c4d72b0163d0efc815d7e7 SHA512 baeafa5b63034e2884d5ab4f11710612bed1c61cd493ac19b9b24b93365b89325518b69878015b4b752f71beda47ecabf774b698e6be9ec9aa86376df2c302db
+DIST lxc-4.0.7.tar.gz 1485130 BLAKE2B 1b806282f3a07df1936f11a6c7c8f0f4dd10ca91aecb3cf881e4cd5c4106035828619ee4bcb163242206e6aafced7841fcd10c191f1b8d609d4e8cb19d81ba6c SHA512 cc04332466090154cf1862fad7a52c9ad7f08462cbe113b12092face43c0e92d53e082af7744667d5397e6289f4ffcf6787c0cb17648013d267b13437be4d992
+DIST lxc-4.0.7.tar.gz.asc 833 BLAKE2B 90e533b5fe96b1f8fd2d3dc08e45438b9211855c79ec514ab722ad5e5b6ec0cbd3579805143c81c854ac09d50ee14319404ee4523dff69c05f4a43137284235f SHA512 a64624b2796d0dac2e0c274cfaaf7c42c23d77903f643005bd5433543318c81b0e715042332a1c120250d4ef23d51ef9be0b7cedeced4f7bfe53d1aee46a6822
diff --git a/app-emulation/lxc/lxc-4.0.7.ebuild b/app-emulation/lxc/lxc-4.0.7.ebuild
new file mode 100644
index 000000000000..546b2e6e4505
--- /dev/null
+++ b/app-emulation/lxc/lxc-4.0.7.ebuild
@@ -0,0 +1,174 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools bash-completion-r1 linux-info flag-o-matic optfeature pam readme.gentoo-r1 systemd verify-sig
+
+DESCRIPTION="A userspace interface for the Linux kernel containment features"
+HOMEPAGE="https://linuxcontainers.org/ https://github.com/lxc/lxc"
+SRC_URI="https://linuxcontainers.org/downloads/lxc/${P}.tar.gz
+ verify-sig? ( https://linuxcontainers.org/downloads/lxc/${P}.tar.gz.asc )"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE="apparmor +caps doc examples libressl man pam selinux +ssl +tools verify-sig"
+
+RDEPEND="acct-group/lxc
+ acct-user/lxc
+ app-misc/pax-utils
+ sys-apps/util-linux
+ sys-libs/libcap
+ sys-libs/libseccomp
+ virtual/awk
+ caps? ( sys-libs/libcap )
+ pam? ( sys-libs/pam )
+ selinux? ( sys-libs/libselinux )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )"
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-4
+ apparmor? ( sys-apps/apparmor )"
+BDEPEND="doc? ( app-doc/doxygen )
+ man? ( app-text/docbook-sgml-utils )
+ verify-sig? ( app-crypt/openpgp-keys-linuxcontainers )"
+
+CONFIG_CHECK="~!NETPRIO_CGROUP
+ ~CGROUPS
+ ~CGROUP_CPUACCT
+ ~CGROUP_DEVICE
+ ~CGROUP_FREEZER
+
+ ~CGROUP_SCHED
+ ~CPUSETS
+ ~IPC_NS
+ ~MACVLAN
+
+ ~MEMCG
+ ~NAMESPACES
+ ~NET_NS
+ ~PID_NS
+
+ ~POSIX_MQUEUE
+ ~USER_NS
+ ~UTS_NS
+ ~VETH"
+
+ERROR_CGROUP_FREEZER="CONFIG_CGROUP_FREEZER: needed to freeze containers"
+ERROR_MACVLAN="CONFIG_MACVLAN: needed for internal (inter-container) networking"
+ERROR_MEMCG="CONFIG_MEMCG: needed for memory resource control in containers"
+ERROR_NET_NS="CONFIG_NET_NS: needed for unshared network"
+ERROR_POSIX_MQUEUE="CONFIG_POSIX_MQUEUE: needed for lxc-execute command"
+ERROR_UTS_NS="CONFIG_UTS_NS: needed to unshare hostnames and uname info"
+ERROR_VETH="CONFIG_VETH: needed for internal (host-to-container) networking"
+
+DOCS=( AUTHORS CONTRIBUTING MAINTAINERS NEWS README doc/FAQ.txt )
+
+pkg_setup() {
+ linux-info_pkg_setup
+}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.0.0-bash-completion.patch
+ "${FILESDIR}"/${PN}-2.0.5-omit-sysconfig.patch # bug 558854
+)
+
+VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/linuxcontainers.asc
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-flags -fno-strict-aliasing
+
+ local myeconfargs=(
+ --bindir=/usr/bin
+ --localstatedir=/var
+ --sbindir=/usr/bin
+
+ --with-config-path=/var/lib/lxc
+ --with-distro=gentoo
+ --with-init-script=systemd
+ --with-rootfs-path=/var/lib/lxc/rootfs
+ --with-runtime-path=/run
+ --with-systemdsystemunitdir=$(systemd_get_systemunitdir)
+
+ --disable-coverity-build
+ --disable-dlog
+ --disable-fuzzers
+ --disable-mutex-debugging
+ --disable-no-undefined
+ --disable-rpath
+ --disable-sanitizers
+ --disable-tests
+ --disable-werror
+
+ --enable-bash
+ --enable-commands
+ --enable-memfd-rexec
+ --enable-seccomp
+ --enable-thread-safety
+
+ $(use_enable apparmor)
+ $(use_enable caps capabilities)
+ $(use_enable doc api-docs)
+ $(use_enable examples)
+ $(use_enable man doc)
+ $(use_enable pam)
+ $(use_enable selinux)
+ $(use_enable ssl openssl)
+ $(use_enable tools)
+
+ $(use_with pam pamdir $(getpam_mod_dir))
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ mv "${ED}"/usr/share/bash-completion/completions/${PN} "${ED}"/$(get_bashcompdir)/${PN}-start || die
+ bashcomp_alias ${PN}-start \
+ ${PN}-{attach,cgroup,copy,console,create,destroy,device,execute,freeze,info,monitor,snapshot,stop,unfreeze,wait}
+
+ keepdir /etc/lxc /var/lib/lxc/rootfs /var/log/lxc
+ rmdir "${D}"/var/cache/lxc "${D}"/var/cache || die "rmdir failed"
+
+ find "${D}" -name '*.la' -delete -o -name '*.a' -delete || die
+
+ # Gentoo-specific additions!
+ newinitd "${FILESDIR}/${PN}.initd.8" ${PN}
+
+ # Remember to compare our systemd unit file with the upstream one
+ # config/init/systemd/lxc.service.in
+ systemd_newunit "${FILESDIR}"/${PN}_at.service.4.0.0 "lxc@.service"
+
+ DOC_CONTENTS="
+ For openrc, there is an init script provided with the package.
+ You should only need to symlink /etc/init.d/lxc to
+ /etc/init.d/lxc.configname to start the container defined in
+ /etc/lxc/configname.conf.
+
+ Correspondingly, for systemd a service file lxc@.service is installed.
+ Enable and start lxc@configname in order to start the container defined
+ in /etc/lxc/configname.conf."
+ DISABLE_AUTOFORMATTING=true
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+
+ elog "Please run 'lxc-checkconfig' to see optional kernel features."
+ elog
+ optfeature "automatic template scripts" app-emulation/lxc-templates
+ optfeature "Debian-based distribution container image support" dev-util/debootstrap
+ optfeature "snapshot & restore functionality" sys-process/criu
+}