summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-05-07 23:58:00 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-05-07 23:58:00 +0200
commit10a139f721a67e8ef8940b5e84ce38f3871cd716 (patch)
tree72f0042104aa21a9fbf10e4ec6d0a61a669de442 /app-emulation/nemu
parentdev-python/guessit: remove old. (diff)
downloadgentoo-10a139f721a67e8ef8940b5e84ce38f3871cd716.tar.gz
gentoo-10a139f721a67e8ef8940b5e84ce38f3871cd716.tar.bz2
gentoo-10a139f721a67e8ef8940b5e84ce38f3871cd716.zip
app-emulation/nemu: new package.
nEMU a ncurses interface for QEMU. Gentoo-Bug: https://bugs.gentoo.org/615922 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-emulation/nemu')
-rw-r--r--app-emulation/nemu/Manifest1
-rw-r--r--app-emulation/nemu/metadata.xml16
-rw-r--r--app-emulation/nemu/nemu-1.1.0.ebuild42
3 files changed, 59 insertions, 0 deletions
diff --git a/app-emulation/nemu/Manifest b/app-emulation/nemu/Manifest
new file mode 100644
index 000000000000..88319548c808
--- /dev/null
+++ b/app-emulation/nemu/Manifest
@@ -0,0 +1 @@
+DIST nemu-1.1.0.tar.gz 52456 SHA256 da9df77ab2579890b2513ac78bac1a3bff3789d1fee326b31acd77a94c59f4dd SHA512 d0eb1b0df61f417fe25295c4f2d0c54d8f11153f03afd8e2fb5f59122558f1e5d1021d73b0b6a4e13dc80c4eabb8a20eabccf472ff4d5c82f27eefa83a5c773d WHIRLPOOL 91a775f67fc197b840a9f9d047b6144e0d109ed4acfd130f08fc5bc2d1f9827e907f2664ec5ef773717fcaa1e111d3ec78cd6e5b6ea2e781ee27242ae771572c
diff --git a/app-emulation/nemu/metadata.xml b/app-emulation/nemu/metadata.xml
new file mode 100644
index 000000000000..b6f3889baf54
--- /dev/null
+++ b/app-emulation/nemu/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="google-code">cofoja</remote-id>
+ <remote-id type="github">nhatminhle/cofoja</remote-id>
+ </upstream>
+ <maintainer type="person">
+ <email>monsieurp@gentoo.org</email>
+ <name>Patrice Clement</name>
+ </maintainer>
+<maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-emulation/nemu/nemu-1.1.0.ebuild b/app-emulation/nemu/nemu-1.1.0.ebuild
new file mode 100644
index 000000000000..93bfd51e27f3
--- /dev/null
+++ b/app-emulation/nemu/nemu-1.1.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="ncurses interface for QEMU"
+HOMEPAGE="https://unixdev.ru/nemu"
+SRC_URI="http://unixdev.ru/src/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+vnc debug"
+
+RDEPEND="
+ virtual/udev
+ virtual/libusb:1=
+ dev-db/sqlite:3=
+ sys-libs/ncurses:0=[unicode]
+ app-emulation/qemu[vnc]
+ vnc? ( net-misc/tigervnc )"
+
+DEPEND="
+ ${RDEPEND}
+ sys-devel/gettext"
+
+src_configure() {
+ local mycmakeargs=(
+ -DNM_WITH_VNC_CLIENT=$(usex vnc)
+ -DNM_DEBUG=$(usex debug)
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ elog "Old database is not supported (nEMU versions < 1.0.0)."
+ elog "You will need to delete current database."
+ elog "If upgraded from 1.0.0, execute script:"
+ elog "/usr/share/nemu/scripts/upgrade_db.sh"
+}