summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2019-04-26 12:39:19 +0200
committerManuel Rüger <mrueg@gentoo.org>2019-04-26 12:39:58 +0200
commit736d08d97f5c93245bf9ed6aa60a7c84cde869ee (patch)
tree27cb2ab8269fb45a201b22812bf1e80bc07d62db /app-emulation/runc
parentsys-apps/logwatch: 7.4.3 stable on arm64 (diff)
downloadgentoo-736d08d97f5c93245bf9ed6aa60a7c84cde869ee.tar.gz
gentoo-736d08d97f5c93245bf9ed6aa60a7c84cde869ee.tar.bz2
gentoo-736d08d97f5c93245bf9ed6aa60a7c84cde869ee.zip
app-emulation/runc: Version bump to 1.0.0_rc8
Package-Manager: Portage-2.3.65, Repoman-2.3.12 Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
Diffstat (limited to 'app-emulation/runc')
-rw-r--r--app-emulation/runc/Manifest1
-rw-r--r--app-emulation/runc/runc-1.0.0_rc8.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/app-emulation/runc/Manifest b/app-emulation/runc/Manifest
index 7496b666bb9f..287936a5ed53 100644
--- a/app-emulation/runc/Manifest
+++ b/app-emulation/runc/Manifest
@@ -2,3 +2,4 @@ DIST runc-1.0.0_rc5_p20180509.tar.gz 1185576 BLAKE2B b56f9c185c061f51a1fd81c19d3
DIST runc-1.0.0_rc6_p20181203.tar.gz 1202869 BLAKE2B 5b5808fc65f3725e5cc22794c5ff6c5eba6016110358b0f60dd3378df2e5b64afb5631e5652f45e9721838dd02745b8c5a88abfcd244de202196ac16bfccd5a7 SHA512 ec3d3fec773f2f9df714b0813efb110e21e328634e0b4ae77f323a892d0327aea5d4b6f9ae2a549aa06fda5b27431f4514fd663c7033dc170ca1a03627931f9d
DIST runc-1.0.0_rc6_p20190216.tar.gz 1663903 BLAKE2B d6094e85f1d35e1dcc7aed94adffe384f651953568345a9f6edb7ef17b24e25d8572ba84a23326c134c2dae28e1d62d0715a8bd6d949d7ef5cbc4cbc6af2f635 SHA512 e3d61506b44f05dfbad2e07d917c8408edea54c87a472ceb109e2ba2a1685b26f1407c2fe7660d416b60fc2583414af09567bcb8b3c95bc14f725d120373337c
DIST runc-1.0.0_rc7.tar.gz 1665891 BLAKE2B eea7fa8f37d788d3e4ba97161ba2369cbdd660218f136bfb57430bf4080709707ed2bf10209f6eadaffe281e5222ccf2c085407fb2c4799c81266504750e24da SHA512 3c5cf70985f080afc633b79d7d5a045d1f5300398e2cc91770653a0f4b2dd38ac2b4ed25c199e92bc7399f9a711c28ed3fb6262fc4a8700527b3e45356d6f723
+DIST runc-1.0.0_rc8.tar.gz 1665924 BLAKE2B 542cbdefaaa1ef89d2abf8e31ca8116f26cddbfc3fb94dc8c7e94c51750b179ed557bee857ec80ede7280856c66c01c7961a26dc7e6202276baca46c691a3903 SHA512 f213b6a7fa96597d2ba1068f77752bccc0a1d62e0aac02ec8d2a2552dc3c1140fd4e52b2daeb0ac8fc09c48abe4521834450baae01ad4165308813eee7654a2b
diff --git a/app-emulation/runc/runc-1.0.0_rc8.ebuild b/app-emulation/runc/runc-1.0.0_rc8.ebuild
new file mode 100644
index 000000000000..7ebc6da0002a
--- /dev/null
+++ b/app-emulation/runc/runc-1.0.0_rc8.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN="github.com/opencontainers/${PN}"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit golang-build golang-vcs
+else
+ MY_PV="${PV/_/-}"
+ RUNC_COMMIT="425e105d5a03fabd737a126ad93d62a9eeede87f" # Change this when you update the ebuild
+ SRC_URI="https://${EGO_PN}/archive/${RUNC_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64"
+ inherit golang-build golang-vcs-snapshot
+fi
+
+DESCRIPTION="runc container cli tools"
+HOMEPAGE="http://runc.io"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="+ambient apparmor hardened +kmem +seccomp"
+
+RDEPEND="
+ apparmor? ( sys-libs/libapparmor )
+ seccomp? ( sys-libs/libseccomp )
+ !app-emulation/docker-runc
+"
+
+src_prepare() {
+ pushd src/${EGO_PN}
+ default
+ sed -i -e "/^GIT_BRANCH/d"\
+ -e "/^GIT_BRANCH_CLEAN/d"\
+ -e "/^COMMIT_NO/d"\
+ -e "s/COMMIT :=.*/COMMIT := ${RUNC_COMMIT}/"\
+ Makefile || die
+ popd || die
+}
+
+src_compile() {
+ # Taken from app-emulation/docker-1.7.0-r1
+ export CGO_CFLAGS="-I${ROOT}/usr/include"
+ export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')
+ -L${ROOT}/usr/$(get_libdir)"
+
+ # build up optional flags
+ local options=(
+ $(usex ambient 'ambient' '')
+ $(usex apparmor 'apparmor' '')
+ $(usex seccomp 'seccomp' '')
+ $(usex kmem '' 'nokmem')
+ )
+
+ GOPATH="${S}" emake BUILDTAGS="${options[*]}" -C src/${EGO_PN}
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ dobin runc
+ dodoc README.md PRINCIPLES.md
+ popd || die
+}