summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-23 11:49:27 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-23 12:10:53 +0200
commitba5c8cfcf5de516c0b6088dae50ab85cd4b396cc (patch)
treed221e82b41ce73a318ad314996046a851ad5338c /app-emulation/sen
parentmedia-sound/frescobaldi: py3_9, xdg-utils -> xdg (diff)
downloadgentoo-ba5c8cfcf5de516c0b6088dae50ab85cd4b396cc.tar.gz
gentoo-ba5c8cfcf5de516c0b6088dae50ab85cd4b396cc.tar.bz2
gentoo-ba5c8cfcf5de516c0b6088dae50ab85cd4b396cc.zip
app-emulation/sen: Enable py3.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-emulation/sen')
-rw-r--r--app-emulation/sen/sen-0.6.1_p20200905.ebuild15
1 files changed, 6 insertions, 9 deletions
diff --git a/app-emulation/sen/sen-0.6.1_p20200905.ebuild b/app-emulation/sen/sen-0.6.1_p20200905.ebuild
index 0ce4e0dc2ae1..fe1a19b03c8f 100644
--- a/app-emulation/sen/sen-0.6.1_p20200905.ebuild
+++ b/app-emulation/sen/sen-0.6.1_p20200905.ebuild
@@ -1,11 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1
COMMIT="02e5872ee2905861e1da06ab5174e1a3f41f0e0b"
@@ -18,25 +16,24 @@ S="${WORKDIR}/${PN}-${COMMIT}"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="dev-python/urwid[${PYTHON_USEDEP}]
dev-python/urwidtrees[${PYTHON_USEDEP}]
dev-python/docker-py[${PYTHON_USEDEP}]
"
-DEPEND="${RDEPEND}
+BDEPEND="
test? (
- dev-python/pytest[${PYTHON_USEDEP}]
dev-python/flexmock[${PYTHON_USEDEP}]
)
"
+distutils_enable_tests pytest
+
python_install_all() {
distutils-r1_python_install_all
dodoc -r docs
}
python_test() {
- pytest -vv tests || die "pytest failed"
+ epytest tests
}