summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-03-10 14:01:11 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-03-10 14:30:53 +0100
commitb8a8c517c47277794f4702e2dcbc7ef6eebdcbd9 (patch)
tree2f4d199d83880cfb89fbc2a2ca7a14be4707b8ba /app-emulation/wine-desktop-common
parentx11-libs/gdk-pixbuf: bump to 2.38.1 (diff)
downloadgentoo-b8a8c517c47277794f4702e2dcbc7ef6eebdcbd9.tar.gz
gentoo-b8a8c517c47277794f4702e2dcbc7ef6eebdcbd9.tar.bz2
gentoo-b8a8c517c47277794f4702e2dcbc7ef6eebdcbd9.zip
app-emulation/wine-desktop-common: EAPI-7 bump, soften blocker, use xdg
Drop invalid HOMEPAGE link. Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-emulation/wine-desktop-common')
-rw-r--r--app-emulation/wine-desktop-common/wine-desktop-common-20150204-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-emulation/wine-desktop-common/wine-desktop-common-20150204-r1.ebuild b/app-emulation/wine-desktop-common/wine-desktop-common-20150204-r1.ebuild
new file mode 100644
index 000000000000..d43b6fa3837d
--- /dev/null
+++ b/app-emulation/wine-desktop-common/wine-desktop-common-20150204-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg
+
+DESCRIPTION="Various desktop menu items and icons for wine"
+HOMEPAGE="https://github.com/NP-Hardass/wine-desktop-common
+ https://bazaar.launchpad.net/~ubuntu-wine/wine/ubuntu-debian-dir/files/head:/debian/"
+SRC_URI="https://github.com/NP-Hardass/${PN}/archive/${PV//./}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="!app-emulation/wine:0"
+PDEPEND="app-eselect/eselect-wine"
+
+# These use a non-standard "Wine" category, which is provided by
+# /etc/xdg/applications-merged/wine.menu
+QA_DESKTOP_FILE="usr/share/applications/wine-browsedrive.desktop
+usr/share/applications/wine-notepad.desktop
+usr/share/applications/wine-uninstaller.desktop
+usr/share/applications/wine-winecfg.desktop"
+
+S=${WORKDIR}/${PN}-${PV//./}
+
+src_install() {
+ emake install DESTDIR="${D}" EPREFIX="${EPREFIX}"
+}