summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-16 23:15:03 +0100
committerSam James <sam@gentoo.org>2021-06-18 23:50:11 +0100
commit055efdba6f794cd3181aec537e52c72a874a4c70 (patch)
treeddc4fb16ed72ef79f882131fd4b7bf96070273d5 /app-emulation
parentapp-emulation/libguestfs: fix libxcrypt RPATH (diff)
downloadgentoo-055efdba6f794cd3181aec537e52c72a874a4c70.tar.gz
gentoo-055efdba6f794cd3181aec537e52c72a874a4c70.tar.bz2
gentoo-055efdba6f794cd3181aec537e52c72a874a4c70.zip
app-emulation/libguestfs: enable OCaml by default for tools
Needed for some common/popular tools. Closes: https://bugs.gentoo.org/789354 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/libguestfs/libguestfs-1.38.6-r103.ebuild6
-rw-r--r--app-emulation/libguestfs/libguestfs-1.44.1.ebuild4
2 files changed, 6 insertions, 4 deletions
diff --git a/app-emulation/libguestfs/libguestfs-1.38.6-r103.ebuild b/app-emulation/libguestfs/libguestfs-1.38.6-r103.ebuild
index 94ccee694c3b..13ce7ab088ae 100644
--- a/app-emulation/libguestfs/libguestfs-1.38.6-r103.ebuild
+++ b/app-emulation/libguestfs/libguestfs-1.38.6-r103.ebuild
@@ -20,7 +20,7 @@ LICENSE="GPL-2 LGPL-2"
SLOT="0/"${MY_PV_1}""
KEYWORDS="~amd64"
-IUSE="doc erlang +fuse gtk inspect-icons introspection libvirt lua ocaml +perl python ruby selinux static-libs systemtap test"
+IUSE="doc erlang +fuse gtk inspect-icons introspection libvirt lua +ocaml +perl python ruby selinux static-libs systemtap test"
RESTRICT="!test? ( test )"
REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )
@@ -180,9 +180,11 @@ pkg_postinst() {
if ! use gtk ; then
einfo "virt-p2v NOT installed"
fi
+
if ! use ocaml ; then
- einfo "Ocaml based tools and bindings (sysprep, ...) NOT installed"
+ einfo "OCaml based tools and bindings (virt-resize, virt-sparsify, virt-sysprep, ...) NOT installed"
fi
+
if ! use perl ; then
einfo "Perl based tools NOT build"
fi
diff --git a/app-emulation/libguestfs/libguestfs-1.44.1.ebuild b/app-emulation/libguestfs/libguestfs-1.44.1.ebuild
index 08c3774a0938..a82e43a0ab06 100644
--- a/app-emulation/libguestfs/libguestfs-1.44.1.ebuild
+++ b/app-emulation/libguestfs/libguestfs-1.44.1.ebuild
@@ -20,7 +20,7 @@ LICENSE="GPL-2 LGPL-2"
SLOT="0/${MY_PV_1}"
KEYWORDS="~amd64"
-IUSE="doc erlang +fuse gtk inspect-icons introspection libvirt lua ocaml +perl python ruby selinux static-libs systemtap test"
+IUSE="doc erlang +fuse gtk inspect-icons introspection libvirt lua +ocaml +perl python ruby selinux static-libs systemtap test"
RESTRICT="!test? ( test )"
REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )
@@ -204,7 +204,7 @@ pkg_postinst() {
fi
if ! use ocaml ; then
- einfo "OCaml based tools and bindings (sysprep, ...) NOT installed"
+ einfo "OCaml based tools and bindings (virt-resize, virt-sparsify, virt-sysprep, ...) NOT installed"
fi
if ! use perl ; then