summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-11-27 16:26:28 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2019-11-27 16:26:40 -0600
commit245c1e260651c01d11352d1d833edf1c2a047783 (patch)
tree8b78ab522afac723a82ebabb3008263a571f945b /app-emulation
parentsys-apps/ed: stable 1.15-r1 for hppa, bug #699828 (diff)
downloadgentoo-245c1e260651c01d11352d1d833edf1c2a047783.tar.gz
gentoo-245c1e260651c01d11352d1d833edf1c2a047783.tar.bz2
gentoo-245c1e260651c01d11352d1d833edf1c2a047783.zip
app-emulation/diskimage-builder: 2.30.0 bump
Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/diskimage-builder/Manifest1
-rw-r--r--app-emulation/diskimage-builder/diskimage-builder-2.30.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-emulation/diskimage-builder/Manifest b/app-emulation/diskimage-builder/Manifest
index 321fcf456db9..eb1efa0ae35e 100644
--- a/app-emulation/diskimage-builder/Manifest
+++ b/app-emulation/diskimage-builder/Manifest
@@ -1,2 +1,3 @@
DIST diskimage-builder-2.28.2.tar.gz 424565 BLAKE2B 77bad24f857de7fb17cb727f7f5168f86434e4cfeecef286da5b3351e9fdfeb0d1dc2472f800024a35adb40aa04155bb7cfa3a0772ed8186a21b31b582809312 SHA512 0bdce552a896834c97f2a982865a93f39f62d0ee68d001c60d320e831c25456a392b4510ed94d7123851dad262e5ccb38a541d0dda5d620f91cf9ab54776efaa
DIST diskimage-builder-2.29.1.tar.gz 426780 BLAKE2B cd5b9c2cce5c289ef7f76ad41bf4b51ba6319c782be91b97a82d828c177912696ce6f94774d7294aca0d4af401d4d4e0ddd5fdd6d799e4e560ab03f971498b03 SHA512 cb083024739486c7651ce97ab36a30461754aae226af23b2ce757eca7c71e0fec42af07b8973f9c8344012238c4ae9d6252189ce6288d6451e020302f2dc35bf
+DIST diskimage-builder-2.30.0.tar.gz 428448 BLAKE2B 4cb4c47c07885713f160a958aa2d80d57b9ae496961bce976beddab59f0760abadaaccc1db8c4f29458dd8f247d7d5c21164a34ef91a4d4b48212f1fa612dadd SHA512 4ed6e745b1184c0462ce0500fa5e5dc8754a7185b76a6b5963c5ca9e20ca0bce7f2a5166b4472ca69498cc5f00e8a6e7ae17fd3794e830679e4f3a22e74956c7
diff --git a/app-emulation/diskimage-builder/diskimage-builder-2.30.0.ebuild b/app-emulation/diskimage-builder/diskimage-builder-2.30.0.ebuild
new file mode 100644
index 000000000000..86d3bb124b34
--- /dev/null
+++ b/app-emulation/diskimage-builder/diskimage-builder-2.30.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_6 python3_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Golden Disk Image builder."
+HOMEPAGE="http://docs.openstack.org/developer/diskimage-builder/"
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://opendev.org/openstack/diskimage-builder.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/networkx-1.10[${PYTHON_USEDEP}]
+ <dev-python/networkx-2.3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ >=dev-python/flake8-2.5.4[${PYTHON_USEDEP}]
+ <dev-python/flake8-2.6.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ app-emulation/qemu
+ sys-block/parted
+ sys-fs/multipath-tools
+ sys-fs/dosfstools
+ sys-apps/gptfdisk
+ !dev-python/dib-utils[${PYTHON_USEDEP}]"