summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2016-01-18 19:52:58 -0500
committerNP-Hardass <NP-Hardass@gentoo.org>2016-01-18 21:02:59 -0500
commit4513d5026dc7f32b01a49b5b30c41035c3f11c40 (patch)
treee7bd69a61fbda5aa3e69cad2c1531ef0af07f6b8 /app-emulation
parentapp-emulation/wine: Version bump to 1.8, renable gst w/ staging (diff)
downloadgentoo-4513d5026dc7f32b01a49b5b30c41035c3f11c40.tar.gz
gentoo-4513d5026dc7f32b01a49b5b30c41035c3f11c40.tar.bz2
gentoo-4513d5026dc7f32b01a49b5b30c41035c3f11c40.zip
app-emulation/wine: update 9999
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine/wine-9999.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/app-emulation/wine/wine-9999.ebuild b/app-emulation/wine/wine-9999.ebuild
index 5150817f6cc2..e8b401a9beef 100644
--- a/app-emulation/wine/wine-9999.ebuild
+++ b/app-emulation/wine/wine-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -27,16 +27,16 @@ MV="4.5.6"
STAGING_P="wine-staging-${PV}"
STAGING_DIR="${WORKDIR}/${STAGING_P}"
WINE_GENTOO="wine-gentoo-2015.03.07"
-GST_P="wine-1.7.34-gstreamer-v5"
+GST_P="wine-1.7.55-gstreamer-v5"
DESCRIPTION="Free implementation of Windows(tm) on Unix"
HOMEPAGE="http://www.winehq.org/"
SRC_URI="${SRC_URI}
gecko? (
- abi_x86_32? ( mirror://sourceforge/${PN}/Wine%20Gecko/${GV}/wine_gecko-${GV}-x86.msi )
- abi_x86_64? ( mirror://sourceforge/${PN}/Wine%20Gecko/${GV}/wine_gecko-${GV}-x86_64.msi )
+ abi_x86_32? ( https://dl.winehq.org/wine/wine-gecko/${GV}/wine_gecko-${GV}-x86.msi )
+ abi_x86_64? ( https://dl.winehq.org/wine/wine-gecko/${GV}/wine_gecko-${GV}-x86_64.msi )
)
- mono? ( mirror://sourceforge/${PN}/Wine%20Mono/${MV}/wine-mono-${MV}.msi )
- gstreamer? ( https://dev.gentoo.org/~tetromino/distfiles/${PN}/${GST_P}.patch.bz2 )
+ mono? ( https://dl.winehq.org/wine/wine-mono/${MV}/wine-mono-${MV}.msi )
+ gstreamer? ( https://dev.gentoo.org/~np-hardass/distfiles/${PN}/${GST_P}.patch.bz2 )
https://dev.gentoo.org/~tetromino/distfiles/${PN}/${WINE_GENTOO}.tar.bz2"
if [[ ${PV} == "9999" ]] ; then
@@ -56,8 +56,8 @@ REQUIRED_USE="|| ( abi_x86_32 abi_x86_64 )
pipelight? ( staging )
s3tc? ( staging )
vaapi? ( staging )
- ?? ( gstreamer staging )
osmesa? ( opengl )" #286560
+ #?? ( gstreamer staging ) #Should be fixed by pre/post patchset
# FIXME: the test suite is unsuitable for us; many tests require net access
# or fail due to Xvfb's opengl limitations.
@@ -240,9 +240,9 @@ src_prepare() {
# patch on top.
if use staging; then
PATCHES+=(
- "${FILESDIR}/${PN}-1.7.39-gstreamer-v5-staging-pre.patch"
+ "${FILESDIR}/${PN}-1.7.55-gstreamer-v5-staging-pre.patch"
"${WORKDIR}/${GST_P}.patch"
- "${FILESDIR}/${PN}-1.7.39-gstreamer-v5-staging-post.patch" )
+ "${FILESDIR}/${PN}-1.7.55-gstreamer-v5-staging-post.patch" )
else
PATCHES+=( "${WORKDIR}/${GST_P}.patch" )
fi
@@ -318,7 +318,7 @@ multilib_src_configure() {
$(use_with oss)
$(use_with pcap)
$(use_with png)
- $(use_with pulseaudio)
+ $(use_with pulseaudio pulse)
$(use_with threads pthread)
$(use_with scanner sane)
$(use_enable test tests)