summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2018-10-03 13:16:35 +0300
committerSergey Popov <pinkbyte@gentoo.org>2018-10-03 13:21:36 +0300
commit5348dfdd461a4a7fcd3b58f5aec1311f6612fcbb (patch)
tree85d1d64917624b1e2bcd3bbef0075aeb325c7c5f /app-emulation
parentapp-emulation/dynamips: revision bump (diff)
downloadgentoo-5348dfdd461a4a7fcd3b58f5aec1311f6612fcbb.tar.gz
gentoo-5348dfdd461a4a7fcd3b58f5aec1311f6612fcbb.tar.bz2
gentoo-5348dfdd461a4a7fcd3b58f5aec1311f6612fcbb.zip
app-emulation/dynamips: version bump
Signed-off-by: Sergey Popov <pinkbyte@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/dynamips/Manifest1
-rw-r--r--app-emulation/dynamips/dynamips-0.2.18.ebuild40
-rw-r--r--app-emulation/dynamips/files/dynamips-0.2.18-docs.patch20
3 files changed, 61 insertions, 0 deletions
diff --git a/app-emulation/dynamips/Manifest b/app-emulation/dynamips/Manifest
index 3e4504e49624..49458378e134 100644
--- a/app-emulation/dynamips/Manifest
+++ b/app-emulation/dynamips/Manifest
@@ -1 +1,2 @@
DIST dynamips-0.2.14-source.zip 961813 BLAKE2B 71da393bfd5624ad47eda578eafd0f5b8b535d9a93c3ebc8902901c0415168098bb27ea44e92cbb230d0cf2ebb904311665978f1b30e6d35c7792b813a5cd8d2 SHA512 8c3d85998a61cae1e3e82501a00e886c954686f9a19a44acb7dee8b13911c0155ce2cdfecbdc41ed5d279266abdf77a5c3f2753fde12217b138313ffa46dabf8
+DIST dynamips-0.2.18.tar.gz 833554 BLAKE2B 8152b436e8fc43061c5603a44ceae8feebdd4593649d2fb6a1814ca22cfce2f671f6f98df5f03ee6eeef10cf09fc444d406edd8d3b4a6037a89cf0e8301774ac SHA512 d66e32d72ecc9ebff5232377ac9aa5b966ceb08884cc7f8dc4a8cf3f56305e7cefd677624ba66278f6603a3b275c384bd0ff3905932461b1f8056106cd272a4c
diff --git a/app-emulation/dynamips/dynamips-0.2.18.ebuild b/app-emulation/dynamips/dynamips-0.2.18.ebuild
new file mode 100644
index 000000000000..1b58ec9cfdad
--- /dev/null
+++ b/app-emulation/dynamips/dynamips-0.2.18.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Cisco 7200/3600 Simulator"
+HOMEPAGE="https://github.com/GNS3/dynamips"
+SRC_URI="https://github.com/GNS3/dynamips/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="ipv6"
+
+RDEPEND="dev-libs/elfutils
+ net-libs/libpcap"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+DOCS=( ChangeLog README.md RELEASE-NOTES )
+
+PATCHES=( "${FILESDIR}/${P}-docs.patch" )
+
+src_prepare() {
+ # comment out DYNAMIPS_FLAGS to respect CFLAGS
+ sed -e "s:^set ( DYNAMIPS_FLAGS:#&:" -i cmake/dependencies.cmake || die
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DANY_COMPILER=1
+ -DENABLE_IPV6="$(usex ipv6)"
+ )
+ cmake-utils_src_configure
+}
diff --git a/app-emulation/dynamips/files/dynamips-0.2.18-docs.patch b/app-emulation/dynamips/files/dynamips-0.2.18-docs.patch
new file mode 100644
index 000000000000..d94da32812b4
--- /dev/null
+++ b/app-emulation/dynamips/files/dynamips-0.2.18-docs.patch
@@ -0,0 +1,20 @@
+--- a/CMakeLists.txt 2018-09-28 13:12:14 +0300
++++ b/CMakeLists.txt 2018-09-28 13:12:39 +0300
+@@ -37,16 +37,6 @@
+ add_subdirectory ( stable )
+ add_subdirectory ( unstable )
+
+-install_docs (
+- "ChangeLog"
+- "COPYING"
+- "MAINTAINERS"
+- "README.md"
+- "README.hypervisor"
+- "RELEASE-NOTES"
+- "TODO"
+- )
+-
+ # uninstall target - leaves behind any directory created during install
+ set ( _templatefile "${CMAKE_SOURCE_DIR}/cmake/cmake_uninstall.cmake.in" )
+ set ( _scriptfile "${CMAKE_BINARY_DIR}/cmake_uninstall.cmake" )
+