summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Hamann <code@ares-macrotechnology.com>2021-05-12 08:50:10 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-07-01 10:04:17 +0300
commit69a878ba0c4cabe0828679c1ebf75131de008aca (patch)
treea9278848823e323f89a9d9032eac82897d65abd2 /app-emulation
parentnet-print/cups-filters: remove unmaintained long-time broken -9999 (diff)
downloadgentoo-69a878ba0c4cabe0828679c1ebf75131de008aca.tar.gz
gentoo-69a878ba0c4cabe0828679c1ebf75131de008aca.tar.bz2
gentoo-69a878ba0c4cabe0828679c1ebf75131de008aca.zip
app-emulation/firecracker-bin: Bump to 0.24.4
Signed-off-by: Sebastian Hamann <code@ares-macrotechnology.com> Bug: https://bugs.gentoo.org/794907 Closes: https://github.com/gentoo/gentoo/pull/20782 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/firecracker-bin/Manifest2
-rw-r--r--app-emulation/firecracker-bin/firecracker-bin-0.24.4.ebuild79
2 files changed, 81 insertions, 0 deletions
diff --git a/app-emulation/firecracker-bin/Manifest b/app-emulation/firecracker-bin/Manifest
index eda9019e0493..cc179636cd34 100644
--- a/app-emulation/firecracker-bin/Manifest
+++ b/app-emulation/firecracker-bin/Manifest
@@ -2,3 +2,5 @@ DIST firecracker-v0.24.1-aarch64.tgz 1427360 BLAKE2B 17d85c6843dfa90bf871d5ff7dc
DIST firecracker-v0.24.1-x86_64.tgz 1434986 BLAKE2B a6b206042fe4dfa873cfa1da4f591242f0224d2c98b367635534497d2bf82e218c409e473be618bd2902594ea24a8c710c853f2f1a00ac96f917a100e80aec0b SHA512 b719520464e3d5c9ff072c73639af71895bfcca9ac4964f2a255ed2d8d3b264a92566f7b87078c163c0f1ce21b9d5bd11cb38eb7cb784c5e18581ee531a0bcaf
DIST firecracker-v0.24.2-aarch64.tgz 1429004 BLAKE2B 8d5624f6f6f154678ffab945bbb293e3ab53c75fa324273d9cd99366d78230aef1ce0a23c0b8efdca9fd87edabc0e196dda0cacabf7ebb33ec86edf7c46dd92e SHA512 9bd83d278c3f4f294c4391aac1bd82712bde7190ad706e1b84a0ec9ad489c09f5fa77bd448a25a08b932230b38e44b3dbcdcc37b2ccacfd87d37c7ee65e6c1c6
DIST firecracker-v0.24.2-x86_64.tgz 1434481 BLAKE2B d2b81e2b3341317f296c63f14b2699dbf207e2e3a83871e38ef1666c105112788308c773afad61a85f7c6f4009f2373c80f12a52549120d92a42bae54891bf59 SHA512 2a574276296685117acf4e1d425ca75ecb8ad06680ae81e183d73853ff57cbca2f4cf4f42cb013d8d88d18146c0d84d2b098829ca5f6e9402213fecdf539a283
+DIST firecracker-v0.24.4-aarch64.tgz 1427501 BLAKE2B 98a9725cfa6fca607081a5c2461980b02417400a58ddce872a45c09b14559b41998dc6707de280c399535262d29dbd5120d5e2eff1b8403f84d66625e97700aa SHA512 fe2d8441a790310f0fecd82fc316e214d9d03f182f3837ac4d5464101954053c5a98976b7178ffe7e6c1e0fbc4a7e7203ccd92e4f8bc74fbccfd889adc7e43cc
+DIST firecracker-v0.24.4-x86_64.tgz 1435102 BLAKE2B 893d1c8392f76cc45668cc8823daae2895f675cbcdffb3431fe51495964611f61263caeaa7a149c5dd0f29122e8a6f8705e66166b1c6a192c9c97d49b7f915c8 SHA512 42f316de6bf1444cc7163b02dedd1492c21d0583da1a2a5193e3941cc1d6a59c3c79d275df3d903914f30d021a3e6c7d8f7338c12c088426adf22045750b7db3
diff --git a/app-emulation/firecracker-bin/firecracker-bin-0.24.4.ebuild b/app-emulation/firecracker-bin/firecracker-bin-0.24.4.ebuild
new file mode 100644
index 000000000000..c957b4a10f3a
--- /dev/null
+++ b/app-emulation/firecracker-bin/firecracker-bin-0.24.4.ebuild
@@ -0,0 +1,79 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info
+
+DESCRIPTION="Secure and fast microVMs for serverless computing (static build)"
+HOMEPAGE="https://firecracker-microvm.github.io https://github.com/firecracker-microvm/firecracker"
+SRC_URI="
+ amd64? (
+ https://github.com/firecracker-microvm/firecracker/releases/download/v${PV}/firecracker-v${PV}-x86_64.tgz
+ )
+ arm64? (
+ https://github.com/firecracker-microvm/firecracker/releases/download/v${PV}/firecracker-v${PV}-aarch64.tgz
+ )"
+
+LICENSE="|| ( Apache-2.0 MIT Apache-2.0-with-LLVM-exceptions ) MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RESTRICT="test strip"
+
+RDEPEND="!app-emulation/firecracker
+ acct-group/kvm"
+
+QA_PREBUILT="/usr/bin/firecracker
+ /usr/bin/jailer"
+
+S="${WORKDIR}"
+
+pkg_pretend() {
+ if use kernel_linux && kernel_is lt 4 14; then
+ eerror "Firecracker requires a host kernel of 4.14 or higher."
+ elif use kernel_linux; then
+ if ! linux_config_exists; then
+ eerror "Unable to check your kernel for KVM support"
+ else
+ CONFIG_CHECK="~KVM ~TUN ~BRIDGE ~VHOST_VSOCK"
+ ERROR_KVM="You must enable KVM in your kernel to continue"
+ ERROR_KVM_AMD="If you have an AMD CPU, you must enable KVM_AMD in"
+ ERROR_KVM_AMD+=" your kernel configuration."
+ ERROR_KVM_INTEL="If you have an Intel CPU, you must enable"
+ ERROR_KVM_INTEL+=" KVM_INTEL in your kernel configuration."
+ ERROR_TUN="You will need the Universal TUN/TAP driver compiled"
+ ERROR_TUN+=" into your kernel or loaded as a module to use"
+ ERROR_TUN+=" virtual network devices."
+ ERROR_BRIDGE="You will also need support for 802.1d"
+ ERROR_BRIDGE+=" Ethernet Bridging for some network configurations."
+ ERROR_VHOST_VSOCK="To use AF_VSOCK sockets for communication"
+ ERROR_VHOST_VSOCK+=" between host and guest, you will need to enable"
+ ERROR_VHOST_VSOCK+=" the vhost virtio-vsock driver in your kernel."
+
+ if use amd64 || use amd64-linux; then
+ if grep -q AuthenticAMD /proc/cpuinfo; then
+ CONFIG_CHECK+=" ~KVM_AMD"
+ elif grep -q GenuineIntel /proc/cpuinfo; then
+ CONFIG_CHECK+=" ~KVM_INTEL"
+ fi
+ fi
+
+ # Now do the actual checks setup above
+ check_extra_config
+ fi
+ fi
+}
+
+src_compile() { :; }
+
+src_install() {
+ if use amd64; then
+ my_arch=x86_64
+ elif use arm64; then
+ my_arch=aarch64
+ fi
+
+ newbin "release-v${PV}/firecracker-v${PV}-${my_arch}" firecracker
+ newbin "release-v${PV}/jailer-v${PV}-${my_arch}" jailer
+}