summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2021-08-17 08:43:10 -0400
committerBrian Evans <grknight@gentoo.org>2021-08-17 08:43:10 -0400
commitc1d9f5f0539ef154f8b1961ca1bdfc7478e1a9ee (patch)
tree3411f1db025a945d83a11954715c353536516df7 /app-eselect
parentapp-eselect/eselect-php: call tmpfiles_process() in pkg_postinst(). (diff)
downloadgentoo-c1d9f5f0539ef154f8b1961ca1bdfc7478e1a9ee.tar.gz
gentoo-c1d9f5f0539ef154f8b1961ca1bdfc7478e1a9ee.tar.bz2
gentoo-c1d9f5f0539ef154f8b1961ca1bdfc7478e1a9ee.zip
app-eselect/eselect-php: Set TMPFILES_OPTIONAL
As per the eclass instructions, this should be set and virtual/tmpfiles dependency tied to fpm as the pkg_postinst is also conditional on fpm Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'app-eselect')
-rw-r--r--app-eselect/eselect-php/eselect-php-0.9.7-r1.ebuild4
-rw-r--r--app-eselect/eselect-php/eselect-php-9999.ebuild4
2 files changed, 6 insertions, 2 deletions
diff --git a/app-eselect/eselect-php/eselect-php-0.9.7-r1.ebuild b/app-eselect/eselect-php/eselect-php-0.9.7-r1.ebuild
index f08853b023cc..3ff3114139a4 100644
--- a/app-eselect/eselect-php/eselect-php-0.9.7-r1.ebuild
+++ b/app-eselect/eselect-php/eselect-php-0.9.7-r1.ebuild
@@ -3,6 +3,7 @@
EAPI=7
+TMPFILES_OPTIONAL="yes"
inherit tmpfiles
DESCRIPTION="PHP eselect module"
@@ -16,7 +17,8 @@ IUSE="fpm apache2"
# The "DirectoryIndex" line in 70_mod_php.conf requires mod_dir.
RDEPEND="app-admin/eselect
- apache2? ( www-servers/apache[apache2_modules_dir] )"
+ apache2? ( www-servers/apache[apache2_modules_dir] )
+ fpm? ( virtual/tmpfiles )"
src_configure() {
# We expect localstatedir to be "var"ish, not "var/lib"ish, because
diff --git a/app-eselect/eselect-php/eselect-php-9999.ebuild b/app-eselect/eselect-php/eselect-php-9999.ebuild
index b983a7d7ba5f..aaf4cb6fd250 100644
--- a/app-eselect/eselect-php/eselect-php-9999.ebuild
+++ b/app-eselect/eselect-php/eselect-php-9999.ebuild
@@ -3,6 +3,7 @@
EAPI=7
+TMPFILES_OPTIONAL="yes"
inherit autotools git-r3 tmpfiles
DESCRIPTION="PHP eselect module"
@@ -16,7 +17,8 @@ IUSE="fpm apache2"
# The "DirectoryIndex" line in 70_mod_php.conf requires mod_dir.
RDEPEND="app-admin/eselect
- apache2? ( www-servers/apache[apache2_modules_dir] )"
+ apache2? ( www-servers/apache[apache2_modules_dir] )
+ fpm? ( virtual/tmpfiles )"
src_prepare() {
default