summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2015-08-09 16:34:14 +0200
committerJulian Ospald <hasufell@gentoo.org>2015-08-09 16:40:52 +0200
commitd09acb34e7a76961f52dd7fef851c236e16f9a05 (patch)
tree21b3aed9005916b7d25272e0fb3819938bf8802a /app-eselect
parent[QA] Remove executable bit from files, bug 550434. (diff)
downloadgentoo-d09acb34e7a76961f52dd7fef851c236e16f9a05.tar.gz
gentoo-d09acb34e7a76961f52dd7fef851c236e16f9a05.tar.bz2
gentoo-d09acb34e7a76961f52dd7fef851c236e16f9a05.zip
app-eselect/eselect-renpy: version bump to 0.6
Preparation for games-engines/renpy-6.99.5 bump.
Diffstat (limited to 'app-eselect')
-rw-r--r--app-eselect/eselect-renpy/eselect-renpy-0.6.ebuild39
-rw-r--r--app-eselect/eselect-renpy/files/renpy.eselect-0.615
2 files changed, 54 insertions, 0 deletions
diff --git a/app-eselect/eselect-renpy/eselect-renpy-0.6.ebuild b/app-eselect/eselect-renpy/eselect-renpy-0.6.ebuild
new file mode 100644
index 000000000000..cee7ecb79f3c
--- /dev/null
+++ b/app-eselect/eselect-renpy/eselect-renpy-0.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit games
+
+DESCRIPTION="Manages renpy symlink"
+HOMEPAGE="http://www.gentoo.org/proj/en/eselect/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="app-eselect/eselect-lib-bin-symlink"
+
+S=${WORKDIR}
+
+pkg_setup() { :; }
+
+src_prepare() {
+ sed \
+ -e "s#@GAMES_BINDIR@#${GAMES_BINDIR}#" \
+ "${FILESDIR}"/renpy.eselect-${PV} > "${WORKDIR}"/renpy.eselect || die
+}
+
+src_configure() { :; }
+
+src_compile() { :; }
+
+src_install() {
+ insinto /usr/share/eselect/modules
+ doins renpy.eselect
+}
+
+pkg_preinst() { :; }
+
+pkg_postinst() { :; }
diff --git a/app-eselect/eselect-renpy/files/renpy.eselect-0.6 b/app-eselect/eselect-renpy/files/renpy.eselect-0.6
new file mode 100644
index 000000000000..cc9d140dbfb8
--- /dev/null
+++ b/app-eselect/eselect-renpy/files/renpy.eselect-0.6
@@ -0,0 +1,15 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id: renpy.eselect-0.5,v 1.1 2014/08/23 02:24:04 hasufell Exp $
+
+DESCRIPTION="Manage default renpy version"
+MAINTAINER="hasufell@gentoo.org"
+VERSION="0.6"
+
+SYMLINK_PATH="@GAMES_BINDIR@/renpy"
+SYMLINK_TARGETS=( renpy-6.14 renpy-6.15 renpy-6.16 renpy-6.17 renpy-6.18 renpy-6.99 )
+SYMLINK_DESCRIPTION='default renpy'
+SYMLINK_CRUCIAL=1
+
+inherit bin-symlink
+